Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Alt+F2 not working with Emerald decorator

  1. #1
    sabatier NNTP User

    Default Alt+F2 not working with Emerald decorator

    Hi,

    The shortcut Alt+F2 will not bring up a run dialog since I set Emerald as my window decorator. I've tried the following but to no avail:

    In ccsm -> General Options -> Key bindings I made sure that Run Dialog shortcut is enabled and set to Alt+F2. Also, in KDE Control center -> Keyboard & Mouse -> Keyboard Shortcuts, the Run Command is binded to ALT-F2 so that can't be the problem.

    So I tried this instead:
    In ccsm -> General Options -> Commands, I set commandline0 to "dcop kdesktop KDesktopIface popupExecuteCommand"
    Then I set its key binding to Alt+F2. Then disabled the Run Command shortcut mentioned above. Still to no avail.


    I'd really appreciate any suggestions on how to solve this.

    Regards,

    sabatier
    Last edited by sabatier; 27-Aug-2008 at 03:23. Reason: Added more info

  2. #2

    Default Re: Alt+F2 not working with Emerald decorator

    sorry to bring up an old thread, but i have the same problem here. any fixes?

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Alt+F2 not working with Emerald decorator

    Hi,

    In the CCSM under General (compiz 0.7) There's a tab that says commands. For command line 0 type
    krunner

    then click the keybindings tab and set Run Command 0 as alt+f2

    if you already have the Run Dialog enabled there will be a conflict so you just click Disable run Dialog.

    For compiz 0.8, in the CCSM under Commands set Command Line 0 as
    krunner

    You'll also have to set up ksnapshot so set Command Line 1 as
    ksnapshot --current

    Then click the keybindings tab and set Run Command 0 as alt+f2 and set Run Command 1 as your print screen button.

    Hope this helps!

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: Alt+F2 not working with Emerald decorator

    I have the same problem now on openSUSE 11.2. In gtk-window-decorator alt+f2 works fine (with compiz) but not in emerald. Since I have gnome, I don't have krunner. So, how to fix this in gnome?
    Chameleon in my heart since 2006.

  5. #5
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: Alt+F2 not working with Emerald decorator

    Sorry, but I have to say: BUMP.
    Chameleon in my heart since 2006.

  6. #6
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Alt+F2 not working with Emerald decorator

    What is Alt+F2 supposed to do? I'm a KDE user and there it opens a dialogue
    that lets you type in the name of a program you'd like to run. If it's
    supposed to do the same thing in GNOME it may be possible to configure it
    manually in the Gnome equivalent of kcontrol (or whatever they're calling
    it now in KDE4) .

    I know, not really helpful, but at least another bump for the issue.

    --
    kev.

  7. #7

    Default Re: Alt+F2 not working with Emerald decorator

    I also don't know what is the command for gnome run dialog, but maybe gnome-do will fit you? Or gmrun.

  8. #8
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: Alt+F2 not working with Emerald decorator

    Thanks for the answer! Yes, it is supposed to open gnome run dialog, which opens with gtk-window-manager or metacity window manager, but not kde. My gnome hotkeys have alt+f2 to run dialog and compiz settings have alt+f2 for run... gnome-do doesn't work properly for me, and I don't like it either. Gmrun is not a recognizible package.
    Chameleon in my heart since 2006.

  9. #9
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: Alt+F2 not working with Emerald decorator

    Any thoughts? I have yet not figured this out. Bump.
    Chameleon in my heart since 2006.

  10. #10
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: Alt+F2 not working with Emerald decorator

    I have waited too long for answer. Maybe I should give up and use gtk-window-decorator for now on...NOT! BUMP.
    Chameleon in my heart since 2006.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •