Results 1 to 8 of 8

Thread: what is rpmlib (PayloadIsLzma)

Hybrid View

  1. #1

    Question what is rpmlib (PayloadIsLzma)

    hi everybody,
    sorry if i ve posted this question more than once, but im really stuck now, when i try to install the snort2.8 package on suse 10.3 (downloaded from Software.openSUSE.org) i get this error:

    error: Dependence required:
    libdnet.so.1 is needed for snort-2.8.2.2-1.1.i586
    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed for
    snort-2.8.2.2-1.1.i586
    when i try to install the libnet package i get the same error of the rpmlib package

    the problem i didnt find this package and it appears that many people have the same issue

    please heeelp me!!
    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: what is rpmlib (PayloadIsLzma)

    RPM packages compressed with LZMA cannot be installed on < 11.0 without upgrading RPM yet. LZMA compression is new to 11.0. Sorry, don't ask me how to upgrade, I don't have any 10.3 machines anymore.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,009
    Blog Entries
    1

    Default Re: what is rpmlib (PayloadIsLzma)

    Have a look at Webpin

    I'm guessing all will be well if you install the lzma and liblzmadec0 packages. I'm running opensuse 11, so unfortunately can't provide more info.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: what is rpmlib (PayloadIsLzma)

    ken yap wrote:
    > RPM packages compressed with LZMA cannot be installed on < 11.0 without
    > upgrading RPM yet. LZMA compression is new to 11.0. Sorry, don't ask me
    > how to upgrade, I don't have any 10.3 machines anymore.
    >
    >


    hmmmmm....it kinda sounds like openSUSE has (inadvertently?) done to
    us what M$ routinely does their own....that, is gently (?) FORCE an
    upgrade..

    i wonder, if openSUSE intends to do the same....OR, if i can actually
    _choose_ to run 10.3 for the full two years i was led to believe it
    would be supported by the community..

    maybe there is a play to patch 10.3 to allow it to use LZMA
    compressed rpms..... OR what??

    --
    see caveat: http://tinyurl.com/6aagco
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: what is rpmlib (PayloadIsLzma)

    Quote Originally Posted by DenverD View Post
    i wonder, if openSUSE intends to do the same....OR, if i can actually
    _choose_ to run 10.3 for the full two years i was led to believe it
    would be supported by the community..

    maybe there is a play to patch 10.3 to allow it to use LZMA
    compressed rpms..... OR what??
    No so fast, it hasn't been established that the OP was installing an official 10.3 snort package update, just one he got from a repository.

    Updates for 10.3 will probably continue to be supplied in the legacy format, or there will be (and I believe there is) an upgrade to the rpm program/libraries to handle LZMA format.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: what is rpmlib (PayloadIsLzma)

    > No so fast, it hasn't been established that the OP was installing an
    > official 10.3 snort package update, just one he got from a repository.


    got'ch....i agree!

    > (and I believe there is) an upgrade to the rpm
    > program/libraries to handle LZMA format.


    also correct, and i installed same, based on deano's post...

    BTW, you ever use that "one click" install?? man i lost track of all
    the clicking you have to do
    - click the button on the web site
    - click to send the rpm to YaST *or* hard drive
    - then, do you wanna install? we are gonna add a repository, is that
    ok? click, do you know bad software can harm your computer? click,
    are you SURE you wanna install? click,
    - AND, when YaST opens new dialogs to BOASTFULLY show it is working
    (downloading repository files and syncing) likely as not it STEALS
    focus, and plops itself down in the CENTER of the screen, ON top (of
    the oo.o doc i was trying to type into) saying LOOK AT ME....just
    like i remember Win3.1 did....sick, egotistical programmers thinking
    THEIR code running is what i should think is the most important thing
    going on in MY life..
    - AND there must be some more clicks i forgot....
    - one would think the programmer never heard of starting a new
    thread and NOT taking focus....must have 'grown up' in Windows[tm]

    what a lot clicking (and waiting) just to avoid the command line..

    --
    see caveat: http://tinyurl.com/6aagco
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  7. #7
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: what is rpmlib (PayloadIsLzma)

    what a lot clicking (and waiting) just to avoid the command line..
    /me agrees. I still use & prefer the cli for installing software,whether it is rpm's or doing the /configure/make/make install boogie

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  8. #8

    Default Re: what is rpmlib (PayloadIsLzma)

    I am way too late with a comment here, but I updated successfully I think, the clamav-0.95.2-6.1.i586.rpm to the clamav-0.95.3-17.1.i586.rpm on a SuSE 10.1 machine. The package is from SLED 10 Index of /repositories/security/SLE_10/i586

    clamscan -V
    ClamAV 0.95.3/9999/Sat Nov 7 09:23:30 2009

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •