Results 1 to 6 of 6

Thread: Compiz in 11.2

  1. #1

    Default Compiz in 11.2

    Hello Folks,

    Great job on 11.2. Snappy, beautiful and stable.
    I am having some problem with compiz. When I try to activate compiz from 'Desktop Settings', it says, 'Compositing is not supported on your system.Required X extensions (XComposite and XDamage) are not available.' Any ideas what is this about.

    I did recompile and install nvidia drivers. I am running 64 bit OS.

    Thanks in advance.

    Nittin

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Compiz in 11.2

    Is this kde or gnome?
    What video card do you have?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Compiz in 11.2

    Sorry, I see nvidia now

    You say you installed the driver - was that manually?
    Did you also run sax2 -r from a su terminal?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    upscope NNTP User

    Default Re: Compiz in 11.2

    caf4926 wrote:

    >
    > Sorry, I see nvidia now
    >
    > You say you installed the driver - was that manually?
    > Did you also run *sax2 -r* from a su terminal?
    >

    I finally got this working. I deinstalled all compiz rpms. still had above
    message about XDamage and XComposite after a reboot. Then found the
    following link:

    http://forum.kde.org/viewtopic.php?f=111&t=10337

    I followed the instructions for change to /etc/X11/xorg.conf:

    Deleted:
    -----------
    Section "Extensions"
    Option "Composite" "off"
    EndSection
    ------------

    Added:
    ------------
    Section "Extensions"
    Option "Damage" "true"
    Option "Composite" "true"
    EndSection
    -------------

    Most effects I select now work.

    Hope this helps.
    --
    Russ
    [openSUSE 11.2 (8 2.6.31.5-0.1-default x86_64] KDE 4.3.2 release 2, Intel
    Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)

  5. #5

    Default Re: Compiz in 11.2

    Thanks a ton. It works for me.

    Thank You

  6. #6
    upscope NNTP User

    Default Re: Compiz in 11.2

    hitechchef wrote:

    >
    > Thanks a ton. It works for me.
    >
    > Thank You
    >

    Your welcome, not sure if that's a bug or something intended.

    --
    Russ
    [openSUSE 11.2 (8 2.6.31.5-0.1-default x86_64] KDE 4.3.2 release 2, Intel
    Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc (2)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •