Results 1 to 4 of 4

Thread: cant install snort 2.8

  1. #1

    Unhappy cant install snort 2.8

    greetings,
    im trying to install snort 2.8 on suse 10.3, but i get everytime
    the same error when i run the make command:

    make[7]: *** no rule to make target installation . stop.

    and then i get recursive errors

    please anyone could help me???

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,640
    Blog Entries
    15

    Default Re: cant install snort 2.8

    Quote Originally Posted by wajdislama
    greetings,
    im trying to install snort 2.8 on suse 10.3, but i get everytime
    the same error when i run the make command:

    make[7]: *** no rule to make target installation . stop.

    and then i get recursive errors

    please anyone could help me???
    Hi
    Have you run the ./configure command before make, what instructions are
    in the readme or install files?

    If you search here, there are already rpms built...
    http://software.opensuse.org/search

    You could also download the src rpm and build from that if you want to
    see what is happening, then install from the built rpms.

    Code:
    rpmbuild --rebuild <name_of_src_rpm>
    rpm -Uhv /usr/src/packages/RPMS/<your_arch>/<name_or_rpm>
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 1 day 0:45, 1 user, load average: 0.06, 0.13, 0.20
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3

    Default Re: cant install snort 2.8

    i run ./configure --with-mysql and everything goes right

    i ve ddownloaded the snort package from Software.openSUSE.org

    but this time the error was:

    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed for snort-2.8.2.1.1
    it appears i have an old rpm wich doesnt support the new rpm packages (or
    something like that)
    i didnt find any solution to fix this problem, could someone please help me?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,640
    Blog Entries
    15

    Default Re: cant install snort 2.8

    Quote Originally Posted by wajdislama
    i run ./configure --with-mysql and everything goes right

    i ve ddownloaded the snort package from 'Software.openSUSE.org'
    (http://software.opensuse.org/search)

    but this time the error was:

    > rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed for snort-2.8.2.1.1


    it appears i have an old rpm wich doesnt support the new rpm packages
    (or
    something like that)
    i didnt find any solution to fix this problem, could someone please
    help me?
    Hi
    Did you select 10.3 in the drop-down? That would indicate you have
    downloaded the one for 11?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 1 day 19:50, 2 users, load average: 0.10, 0.08, 0.08
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •