Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Phonon problem - need to revert

  1. #1

    Default Phonon problem - need to revert

    Hi all,

    I installed the wrong phon xine backend thingy and need a n00b friendly solution if its available.

    Dimble:
    "i upgraded my 11.0 to 4.1, and it now says on boot-up; "failed to enable Phonon, reverting to previous method".
    sound works ok, so it isn't really a problem, just mentioning it."


    Snakeyes:
    "Hi, install a package called phonon-backend-xine"

    Dimble:
    "having done that, i now get the following knotify error message after login:
    Unable to use Xine Multimedia Backend:
    The plugin 'phonon_xine' uses an incompatible KDE library (4.1.60 (KDE 4.1.60 (KDE 4.2 >= 20080709)) "release 43.4").
    sound still works, but i am about to give this laptop to my non-techy sister who will not like error messages popping up for no good reason.
    anyone know what the problem is; and how a non-technical sort like myself might fix it?"


    Slammer64:
    "Dimble, it looks like you are using the Unstable repo rather than Factory, could you verify that please?"

    Dimble:
    "hi there, i am indeed, any ideas on how i might rectify matters?"

    Many thanks for any assistance rendered.

    Dimble

  2. #2
    Join Date
    Mar 2008
    Location
    NE Arkansas
    Posts
    1,126

    Default Re: Phonon problem - need to revert

    I replaced my 11.0 KDE4 install with 11.1 alpha2 and those problems went away

    I've done 3 updates using the factory repos & alls well; sure there are some nit-noids & part of that is the learning process.
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1 B & Leap 43.2; and, Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15 & T-weed

  3. #3

    Default Re: Phonon problem - need to revert

    is it possible to do an easy upgrade from 11.0 to 11.1 A2 or is it a straight re-install over the top?

    cheers.

  4. #4

    Default Re: Phonon problem - need to revert

    Don't switch to 11.1. Your sister is gonna have an even worse time with an alpha OS. What you should do is enable factory repo and reinstall KDE 4 entirely by using the patterns in yast. I've had no trouble with factory packages so far. You should also think about deleting the .kde4 directory in your home folder.

  5. #5

    Default Re: Phonon problem - need to revert

    sounds promising, could you give me any more pointers on how i reinstall KDE using patterns?

    will i then have to reinstall 4.1?

    and will i still have the original problem on phonon not being used?

    is it not simply possible to revert to a pre xine-patch state, a glorified "undo" if you will..........?

    cheers

  6. #6

    Default Re: Phonon problem - need to revert

    Well the problem is that using unstable repo for kde 4.1 is a really dangerous move and can sometimes lead to an unbootable kde. Reverting to factory repos is basically uninstalling and reinstalling anyway.

    But here's how to do it. This method is not using patterns because there's some really weird bugs in yast patterns management. In the end its the same thing.

    1.)Go to yast->software repositories and remove the unstable kde 4.1 repo

    2.)Go to yast->addon products->community repositories and enable the KDE 4.1 Factory repo.

    3.)Go to yast->software management, select the Repositories Filter. Select the KDE factory repository. Right click inside the package list->all in this list->update unconditionally.

    This should revert all packages back to factory and you should have a stable kde install. Remove .kde4 from your home directory after install.

  7. #7

    Default Re: Phonon problem - need to revert

    cheers, sounds do-able.

  8. #8

    Default Re: Phonon problem - need to revert

    Quote Originally Posted by Benjamin_Xiao View Post
    Well the problem is that using unstable repo for kde 4.1 is a really dangerous move and can sometimes lead to an unbootable kde. Reverting to factory repos is basically uninstalling and reinstalling anyway.

    But here's how to do it. This method is not using patterns because there's some really weird bugs in yast patterns management. In the end its the same thing.

    1.)Go to yast->software repositories and remove the unstable kde 4.1 repo

    2.)Go to yast->addon products->community repositories and enable the KDE 4.1 Factory repo.

    3.)Go to yast->software management, select the Repositories Filter. Select the KDE factory repository. Right click inside the package list->all in this list->update unconditionally.

    This should revert all packages back to factory and you should have a stable kde install. Remove .kde4 from your home directory after install.
    re. 2.) i don't have a 4.1 factory repo listed............

  9. #9

    Default Re: Phonon problem - need to revert

    do you mean: KDE4:Factoryesktop

    because having used the one click link for what i think is 4.1 factory i still have nothing labelled as such.............

  10. #10

    Default Re: Phonon problem - need to revert

    having selected Filter:Repositories in software management it won't bring up any sybmenu when i right click on KDE4.........

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •