Results 1 to 4 of 4

Thread: Openoffice: Problem with mathematical symbols

  1. #1

    Default Openoffice: Problem with mathematical symbols

    I have received some school homework in a word document. It is math homework so it has a lot of mathematical symbols in it.
    Some symbols are not shown correctly in openoffice on opensuse 11 though, and are replaced by questionmarks or squares.

    I tried opening it in openoffice in windows xp in virtualbox and there everything is displayed correctly.

    Any ideas what could be the problem?
    I tried installing tahoma fonts but it didn't make any difference.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,439

    Default Re: Openoffice: Problem with mathematical symbols

    The immediate cause is probably that the symbols were not encoded in utf8. OpenOffice on Windows almost certainly reads the code pages available in Windows and uses the symbols from that code page. In Linux it has no way of knowing what this was.

    According to Oo Help, the Oo Quickstarter offers an option to Setup some aspects of the way Oo interprets MS documents. I have never used it but I know that, for certain other foreign formats, Oo asks you for the encoding. So it may be possible to turn on the encoding option for MS documents rather than allowing Oo to make its own decision.

  3. #3

    Default Re: Openoffice: Problem with mathematical symbols

    I just tried to open the document in openoffice on windows again and I can see that the objects that are not shown correctly are something called "OLE".

    The thing you mention with quickstart has not worked for me since I can find no options that could help this.

    The problem persists when I receive it as pdf made in Office 2007, the same symbols are shown as questionmarks an squares.

    I even installed word viewer in wine and there it looks a little better, but random symbols are missing.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,439

    Default Re: Openoffice: Problem with mathematical symbols

    If you can open the document in OpenOffice on Windows and all the symbols are displayed correctly, try saving it in ODF format and opening that version in OpenOffice on Linux.

    Another possibility may be opening it as a Formula document in OpenOffice in Windows and saving it as a Formula document rather than a Text document.

    As this isn't listed as a problem in the list of known problems converting from Word to Oo, I am assuming there is a way of getting round it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •