Results 1 to 4 of 4

Thread: problem with kdevelop.

  1. #1

    Default problem with kdevelop.

    Hi all... I am a student basically so i use programming tools mostly.I tried to work in kdevelop but after opening a file (or writing code and saving from kdevelop) i tried to compile from build menu. But there is nothing in that menu .no compile option, run option etc. What to do to get them ? thanks in advance...

  2. #2
    Join Date
    Jun 2008

    Default Re: problem with kdevelop.


    i suggest to create a new project or to import an existing project. Kdevelop cannot compile apps when it does not know how to compile them (does it use automake, qmake and so on).

    If your project does not use any of these build systems then you can create a custom Makefile which then can be used by Kdevelop or create a new automake based project and add your source files via the automake manager. That's probably the easiest way

    hope this helps

  3. #3

    Default Re: problem with kdevelop.

    press shift+F9
    it compiles it!
    which icon u have chosen?
    IDE for c/c++?

  4. #4

    Default Re: problem with kdevelop.

    I suggest migrating to a different IDE. KDevelop is good however if you are learning and need to focus more on getting the code down and testing - experimenting then perhaps try codeblocks, I recently installed it and have it to be the nicest IDE for C++ development, although that is personal opinion.

    Anyway i suggest at least trying it, its very small in comparison to KDevelop

    Installation can be done in yast or perhaps just choose one of the links after searching "codeblocks" using

    Hope this makes things a bit simpler
    My SurfAus Website

    Check it out if you are a surfer or plan to surf in Australia!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts