Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Volume settings not holding

  1. #1
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Volume settings not holding

    Hey all,

    I've run into a very frustrating problem with sound on OpenSUSE 11.0: I had no sound on my system, so I went into YaST and opened the sound module to check the volume settings. After I opened the volume settings, all the settings except the PCM and Master Volume were on 0, so I moved them to appropriate settings, and the sound instantly came back. The problem is that when I click the OK button to save the volume settings, I lose my sound again, and after reopening the volume settings, they are all on 0 again. The only major thing that has changed on my OpenSUSE is updating Java, but I'm not sure if that would have anything to do with this problem.

    Any ideas?

    Thank you very much (in advanced)!

    Folding@Home
    Help save lives with Folding@Home

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    I've run into a very frustrating problem with sound on OpenSUSE 11.0: I had no sound on my system, so I went into YaST and opened the sound module to check the volume settings. After I opened the volume settings, all the settings except the PCM and Master Volume were on 0, so I moved them to appropriate settings, and the sound instantly came back. The problem is that when I click the OK button to save the volume settings, I lose my sound again, and after reopening the volume settings, they are all on 0 again.
    Besides going into YaST > Hardware > Sound, did you also try your mixer?
    (alsamixer if gnome, and kmix if kde) ?

    If your mixer works for restoring your volume levels, but they do not hold their either, then run su -c 'alsactl store' #enter root password when prompted.

    Also check that you do not have a permissions problem (where user root has sound and a regular user does not have sound). If so, note the work around in the audio troubleshooting guide by adding a regular user to group audio:
    Audio Troubleshooting Guide - openSUSE - How_To_Fix_a_Permissions_Problem
    and note you need to log in and log out of Linux for the above to work.

  3. #3
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    Thanks, OldCPU!

    I ran the two commands that you posted, and now I have sound, but only the "Headphone" volume setting changed. While it changed, it is also stuck at 76, and when I change it and click "OK," the volume goes back to 76. I have control over my main volume (both through the desktop icon for volume and my keyboard, I just can't change the volume settings for individual items, such as my headphones and microphone. One thing I have a question about is ALSA-Mixer. I'm not really familiar with the mixer or ALSA in general, so I'm not sure about how to change settings through the mixer. So, basically to sum it up, the headphone volume changed to 76 and now I can hear through my headphones, but all the volume settings still do not stay at what I set them when I close the Sound module for YaST.

    Thanks again, OldCPU, for getting my sound back at least!

    Greatly appreciated!

    Folding@Home
    Help save lives with Folding@Home

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    now I have sound, but only the "Headphone" volume setting changed. While it changed, it is also stuck at 76, and when I change it and click "OK," the volume goes back to 76. I have control over my main volume (both through the desktop icon for volume and my keyboard, I just can't change the volume settings for individual items, such as my headphones and microphone. One thing I have a question about is ALSA-Mixer. I'm not really familiar with the mixer or ALSA in general, so I'm not sure about how to change settings through the mixer. So, basically to sum it up, the headphone volume changed to 76 and now I can hear through my headphones, but all the volume settings still do not stay at what I set them when I close the Sound module for YaST.
    Its possible we can progress further, but to do so with some degree of accuracy (and to minimize the speculation) I would need more information on your system.

    If you wish to pursue this, to provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

    Also, please copy and paste the following, one line at a time, into a gnome-terminal/konsole and post the output here.
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    groups

  5. #5

    Angry Re: Volume settings not holding

    Quote Originally Posted by oldcpu View Post
    Also check that you do not have a permissions problem (where user root has sound and a regular user does not have sound).
    Ironically, it was just last night that I discovered this was the final cause of my sound problems on my Thinkpad 600E (which has enough hardware and driver sound problems to fill a book).

    So, why aren't ordinary users automatically added to the "sound" group?

    And, why don't any of the utilities that fail because of these permission problems say something, rather than simply presenting a nearly blank window, as KMix does?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: Volume settings not holding

    Quote Originally Posted by rahyman View Post
    So, why aren't ordinary users automatically added to the "sound" group?
    I don't know the real answer, but I have a suspicion.

    IMHO the problem is rooted in the very philosophy and associated anarchy that goes with Linux. Because Linux is opensource and free, there is minimal enforcement of hard fast rules. Contribution from volunteers is necessary, and in the desire not to scare off the volunteers, there is a large degree of anarchy in how contributions are structured. Also, since Linux is based on an opensource free software concept, large projects, such as creating an audio driver for sound, have contributions from many different individuals. Hence many parts of the driver (which are designed for some hardware audio codecs) which are created by various volunteers, do not require the regular user belong to group audio, and indeed adding the regular user in such cases could cause problems. BUT other parts of the audio driver, created by other volunteer individuals, DOES require a user belong to group audio. Again, there is anarchy.

    Trying to create an installation program that covers these different possibilities is extremely difficult, and despite the best efforts, some sound devices slip through the cracks.

    This of course, is VERY MUCH IMHO.

    Quote Originally Posted by rahyman View Post
    And, why don't any of the utilities that fail because of these permission problems say something, rather than simply presenting a nearly blank window, as KMix does?
    Well, they might actually say something, if one only knew where to look. One just has to know where to look. Possibly buried in "dmesg" or possibly buried in one of the /var/log files. ...

  7. #7
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    I answered the ALSA survey the best I could (I'm not familiar with sound drivers).

    The output can be found here.

    The other outputs for the command were:

    rpm -qa | grep alsa


    alsa-plugins-1.0.17.git20080827-1.1
    alsa-tools-gui-1.0.17.git20080715-1.11
    alsa-oss-1.0.17.git20080715-2.8
    alsa-plugins-pulse-1.0.17.git20080827-1.1
    alsa-firmware-1.0.17.git20080617-2.1
    alsa-tools-1.0.17.git20080715-1.11

    rpm -qa | grep pulse


    pulseaudio-module-lirc-0.9.11-27.1
    pulseaudio-utils-0.9.11-27.1
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    alsa-plugins-pulse-1.0.17.git20080827-1.1
    libpulse-browse0-0.9.11-27.1
    pulseaudio-module-x11-0.9.11-27.1
    pulseaudio-module-zeroconf-0.9.11-27.1
    pulseaudio-0.9.11-27.1
    pulseaudio-esound-compat-0.9.11-27.1
    libpulse0-0.9.11-27.1
    libpulse-mainloop-glib0-0.9.11-27.1
    libpulsecore4-0.9.11-27.1
    pulseaudio-module-bluetooth-0.9.11-27.1
    pulseaudio-module-gconf-0.9.11-27.1

    rpm -q libasound2


    libasound2-1.0.17.git20080816-1.1

    uname -a


    Linux linux-h7g9 2.6.25.11-0.1-pae #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux

    cat /etc/modprobe.d/sound


    options snd slots=snd-hda-intel
    # u1Nb.Dtr+5XJCMB0:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    groups


    users dialout video


    I tried to answer the questions as best I could, but since I'm not familiar with sound cards and sound drivers, I answered a few of the questions with "no" since I wasn't familiar with the hardware or since I didn't believe I used the software it asked about. To add to this, the volume reset again, and it's not holding at 76 anymore. So, for the time being, the only way I am able to listen to sound, say if I listen to a video on Youtube, I have to keep the volume window in the YaST sound module open. Immediately after I close the window, the volume resets to 0 and I have no sound again. Sorry for not giving precise information about the problem, it's just that I'm not sure where to check for this information.

    Thank you for your patience.

    Folding@Home
    Help save lives with Folding@Home

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    groups
    users dialout video
    Thanks. I do not see group audio there. Did you remove yourself from group audio?

    Please re-read this post of mine:
    Quote Originally Posted by oldcpu View Post
    Also check that you do not have a permissions problem (where user root has sound and a regular user does not have sound). If so, note the work around in the audio troubleshooting guide by adding a regular user to group audio:
    Audio Troubleshooting Guide - openSUSE - How_To_Fix_a_Permissions_Problem
    and note you need to log in and log out of Linux for the above to work.
    If you had added yourself to group "audio" I think I would have seen "audio" as an output in the groups command.

    Quote Originally Posted by Unseen-Ghost View Post
    The output can be found here.
    Thanks. I see a 2.6.25.11-pae kernel on a 32-bit openSUSE-11.0 with an AD1988 codec on your ASUS P5B-VMDO computer.

    I note some things in your mixer that potentially could cause a problem, but even more important, I see that you do not have the alsa modules installed that you need.

    Quote Originally Posted by Unseen-Ghost View Post
    rpm -qa | grep alsa
    alsa-plugins-1.0.17.git20080827-1.1
    alsa-tools-gui-1.0.17.git20080715-1.11
    alsa-oss-1.0.17.git20080715-2.8
    alsa-plugins-pulse-1.0.17.git20080827-1.1
    alsa-firmware-1.0.17.git20080617-2.1
    alsa-tools-1.0.17.git20080715-1.11
    You are missing alsa-driver-kmp-pae and alsa. You must install both of those apps. Are you certain you copy and pasted the output of that command correctly? You have to know that if you paste the wrong output, I will waste time (yours and mine) giving a bad recommendation.

    Frankly, if the above is correct, I don't understand how you can have any sound.

    Anyway, based on the above, and assuming adding your user name to group audio does not solve your problem (note you must log out and back in of Linux for adding your user to group audio to have any success), I recommend you update your alsa to fix this problem. Please open a gnome-terminal / konsole and type "su" (no quotes - enter root password when prompted) and then sequentially copy and paste the following six zypper commands to fix your incorrect alsa configuration:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
    Code:
    zypper install alsa alsa-utils alsa-oss alsa-plugins alsa-plugins-pulse alsa-tools alsa-tools-gui alsa-firmware libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
    Code:
    zypper install alsa-driver-kmp-pae
    Code:
    zypper rr multimedia
    When that command completes, restart your PC to unload alsa and reload alsa and test your audio. .... There is still a good chance it won't work ... If that happens, then we can look at adding a line to your /etc/modprobe.d/sound file.

    You posted this:
    Quote Originally Posted by Unseen-Ghost View Post
    cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel
    # u1Nb.Dtr+5XJCMB0:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    So AFTER updating your alsa, please add a 4th line to that file, so that the file looks like this:
    options snd slots=snd-hda-intel
    # u1Nb.Dtr+5XJCMB0:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    options snd-hda-intel model=auto
    and then restart your alsa by copy and pasting this:
    su -c 'rcalsasound restart'
    and then test your audio.

    Note my reference for this is the ALSA-Configuration.txt file that comes with the alsa documentation:
    Code:
    	AD1988/AD1988B/AD1989A/AD1989B
    	  6stack	6-jack
    	  6stack-dig	ditto with SPDIF
    	  3stack	3-jack
    	  3stack-dig	ditto with SPDIF
    	  laptop	3-jack with hp-jack automute
    	  laptop-dig	ditto with SPDIF
    	  auto		auto-config reading BIOS (default)
    If "auto" does not work, then try replace "auto" with "6stack-dig" in that /etc/modprobe.d/sound file, save it, and restart alsa again as explained above. Test your audio, ... if "6stack-dig" does not work, then replace "6stack-dig" with "6stack" and restart alsa and test your sound. ... etc .. trying each of the models in the ALSA-Configuration.txt quote I have above ... I'm confident you "catch the drift" ..

    Good luck!

  9. #9
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    Okay, I added myself to the group audio and restarted my system, but that didn't solve the problem. On the topic of the output for the command rpm -qa | grep alsa, I accidentally left off the first line of the output, which was alsa-1.0.17.git20080816-1.1. Sorry about that. Even with ASLA already being installed, I tried the Zypper commands, but since all the packages in the second command were already installed, they would not install. I also installed alsa-driver-kmp-pae and then restarted, but still to no avail. I also added the "auto" line to the "/etc/modprobe.d/sound" file. I ran into an issue when I tried to restart ALSA through the terminal. When I issued the command: su -c 'rcalsasound restart', I was given the output that two tasked were done (done in bold and bright-green), but a blank error window with the Gnome panel icon in the top left corner appeared. The window only had the title "Error" on the top bar with the minimize and exit button, but with no text on the error prompted. The volume icon on the task bar also disappeared and I was unable to right-click on the task bar. So, I pressed Ctrl+Alt+Backspace twice and when I logged back in, I got the following error message (the top of prompt was off the top of my screen, so I was only able to see the message itself, but not the title):


    Assistive technology support has been requested for this
    session, but the accessibility registry was not found. Please
    ensure that the AT-SPI package is installed. Your session
    has been started without assistive technology support.

    I restarted my system after this just to be sure, and when I logged back in, there were no errors, and the session started as normal. Because the "auto" line didn't fix the problem, I changed it to "6stack-dig" and I tried the ALSA restart command one more time, but the same blank error message appeared and when I logged out through Ctrl+Alt+Backspace, the same assistive technology error occurred, and when Gnome loaded, the task bar was missing completely. So, I restarted. I checked the volume again, and this time, the "headphone" volume option was missing. But the "Front" volume was at 69, but because I have no option for my headphones, I don't have any sound (NOTE: I have a headset with microphone, and I don't use speakers). So, just guessing, but by using the 6-dig command, ALSA isn't recognizing the front jacks on my computer, where my headset headphones and microphone are plugged in. Also, the volume settings, if I change them, reset after it it "OK" (the "Front" volume goes back to 69). Maybe this can help?

    Thanks again.

    Folding@Home
    Help save lives with Folding@Home

  10. #10

    Default Re: Volume settings not holding

    I am having the exact same problem but on 10.3. The one thing in the thread that we have in common is updating Java. As near as I can remember my sound was working fine. I think it quit working after I installed the latest Java security patch.

    I seem to remember something about Java and sound issues from early on when I first installed 10.3 on my laptop and struggled through getting the sound to work.

    Is it possible the Java patch hosed something up?

    Jim

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •