Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Volume settings not holding

  1. #11
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    I added the Java repository and updated the Java packages, but to no avail. The problem still occurs.

    Just to add, I removed the extra line from the sound file, and still, the headphones volume option did not come back.

    Folding@Home
    Help save lives with Folding@Home

  2. #12
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    Okay, I added myself to the group audio and restarted my system, but that didn't solve the problem.
    Note you have to restart after this, although this appears to be a mute point given the problems you experienced later.

    Quote Originally Posted by Unseen-Ghost View Post
    On the topic of the output for the command rpm -qa | grep alsa, I accidentally left off the first line of the output, which was alsa-1.0.17.git20080816-1.1. Sorry about that. ...... snipped ..........(NOTE: I have a headset with microphone, and I don't use speakers).
    These sort of omissions (ie not mentioning you do not user speakers until now, and forgetting to mention a key installed application) make it very difficult to provide support that is not a waste of both of our time. Such omissions increase the risk that a bad recommendation can be given. ...

    ... anyway ... back to the problem at hand ...

    Quote Originally Posted by Unseen-Ghost View Post
    I also installed alsa-driver-kmp-pae and then restarted, but still to no avail.
    You left it installed, right? Please, I want to do a quality check. Type:
    rpm -qa | grep alsa
    rpm -q libasound2
    uname -a
    and post the output here

    Quote Originally Posted by Unseen-Ghost View Post
    So, I pressed Ctrl+Alt+Backspace twice and when I logged back in, I got the following error message (the top of prompt was off the top of my screen, so I was only able to see the message itself, but not the title):


    Assistive technology support has been requested for this
    session, but the accessibility registry was not found. Please
    ensure that the AT-SPI package is installed. Your session
    has been started without assistive technology support.
    I am a KDE user, and this is a Gnome specific error. I do not believe your alsa install will cause this. I believe something else that you have done may have brought this about. ... Did you install the package at-spi recently? (To find out when try:
    rpm -qa --last | grep at-spi

    You will have to get a Gnome user to help you here. Maybe the "assistive technologies" is not needed and can be disabled with a gnome desktop configuration in something like "preferences > assistive techology" , but you need a Gnome user now to help you in that.

    Back to your audio,

    Quote Originally Posted by Unseen-Ghost View Post
    I changed it to "6stack-dig" and I tried the ALSA restart command one more time, but the same blank error message appeared and when I logged out through Ctrl+Alt+Backspace, the same assistive technology error occurred, and when Gnome loaded, the task bar was missing completely. So, I restarted. I checked the volume again, and this time, the "headphone" volume option was missing.
    I do not think changing to "6stack-dig" is the cause of the "headphone" volume option missing. I believe you have done something else (and like your omitting to include "alsa" in the list and like your not mentioning you do not use your speakers) you simply are not aware something you are doing is important information.


    Quote Originally Posted by Unseen-Ghost View Post
    But the "Front" volume was at 69, but because I have no option for my headphones, I don't have any sound
    What is your criteria for now sound? Are you using the recommended speaker test?
    speaker-test -Dplug:front -c2 -l5 -twav

    Quote Originally Posted by Unseen-Ghost View Post
    So, just guessing, but by using the 6-dig command, ALSA isn't recognizing the front jacks on my computer, where my headset headphones and microphone are plugged in. Also, the volume settings, if I change them, reset after it it "OK" (the "Front" volume goes back to 69).
    I don't think so. I think you have another problem.

    I read on a Ubuntu forum that a Ubuntu forum user with an Asus P5B-VM user solved their audio problem by adding to lines to their /etc/modprobe.d/alsa-base file (thats the same as the opensuse "/etc/modprobe.d/sound" file):
    options snd-hda-intel model=6stack-dig
    options snd-pcm-oss dsp_map=1

    Upgrade to alsa 1.0.15 - Ubuntu Forums

    You could try adding BOTH lines to your /etc/modprobe.d/sound file:
    options snd slots=snd-hda-intel
    # u1Nb.Dtr+5XJCMB0:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    options snd-hda-intel model=6stack-dig
    options snd-pcm-oss dsp_map=1
    That is based on a Ubuntu users success with same hardware. Note you must restart alsa afterward with
    su -c 'rcalsasound restart'

    Also, as a quality check, post contents of your /etc/modprobe.d/sound file after making the above changes .. ie
    cat /etc/modprobe.d/sound

    And please, do not restart your PC with <CTR><ALT><BACKSPACE> unless absolutely NOTHING else works. Its simply a BAD idea. Is this the Gnome way of doing things? If your desktop is frozen try <CTR><ALT><F2> and log on to a terminal and kill the offending app (or restart from the terminal after loggin on as a regular user with: su -c 'shutdown -r now' . That is preferable to the abrupt killing of your desktop with <CTR><ALT><BACKSPACE> . I have no idea how many (if any) glitches you have caused by many <CTR><ALT><BACKSPACE> efforts.

    Anyway, now the bottom line ... it appears to me with this "assistive technogies" errors you have other gnome specific problems that are messing up your sound. I can't help with Gnome, so unless you solve your "assistive technolgies" problems, then I as a KDE user (who strongly dislikes gnome) simply can not help you.

    If it were me (with my strongly disliking Gnome) I would re-install with KDE-3.5.9.

  3. #13
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    Again, I'm really sorry about leaving that important information out: the last I would want to do is waste your time, considering how much information you have given so far. Just so all the information is out there, and I don't let anything fall through the cracks: I have 6 jacks on the back of my computer that are connected directly to the motherboard (with an integrated sound card on the motherboard) and 2 jacks in the front, where the plug for the microphone and the plug for the headset (the output that goes to the headset), which is not attached, like the rear jacks, to my motherboard, but they are connected to it. Using the "quality check commands," I got the following outputs:

    rpm -qa | grep alsa


    alsa-1.0.17.git20080816-1.1
    alsa-driver-kmp-pae-1.0.16.20080828_2.6.25.11_0.1-1.1
    alsa-utils-1.0.17.git20080820-1.1
    alsa-plugins-1.0.17.git20080827-1.1
    alsa-tools-gui-1.0.17.git20080715-1.11
    alsa-oss-1.0.17.git20080715-2.8
    alsa-plugins-pulse-1.0.17.git20080827-1.1
    alsa-firmware-1.0.17.git20080617-2.1
    alsa-tools-1.0.17.git20080715-1.11
    rpm -q libasound2


    libasound2-1.0.17.git20080816-1.1

    uname -a


    Linux linux-h7g9 2.6.25.11-0.1-pae #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux

    On the topic of the Gnome issue with assistive technology, I've never had it happen before. The only good thing is that it doesn't seem like a major problem because I restarted the computer after words and everything worked as normal. So, because it doesn't sound like a major issue and everything went back to normal after it, I'll try to deal with it as a secondary issue after this one. In any case, the output for the command you gave me for at-spi is:

    rpm -qa --last | grep at-spi


    at-spi-1.22.1-18.1 Tue 10 Jun 2008 08:19:55 AM EDT

    On the issue of the headphone volume option disappearing, it could be my fault that I did something wrong. The only reason I thought it was the 6-dig command was because that was the only thing I changed, restarted my system, and the next time I checked the sound and volume settings, the option for headphone volume was missing. Again, it could be my fault; although, just using deductive reasoning seeing as the change in the sound file was the only change I manually made, and then the headphone volume disappeared. The one way I was checking my sound was (considering I didn't have a sound clip or something of that nature to test it) was either through the sound test option in the YaST Sound Module or by playing a video online, which would have the same effect (no sound when the volume was stuck and sound when it was working) as the sound test in YaST. When I issued the command to test the sound that you provided, I got the following output, which contained an error:

    speaker-test -Dplug:front -c2 -l5 -twav



    speaker-test 1.0.18rc2

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Playback open error: -16,Device or resource busy

    The Playback open error: -16,Device or resource busy notice would repeat indefinitely until I halted the command. I'm not sure what that means, but maybe it can be of some assistance. I also added the two lines of script to the sound file. In case it is of any use, the same error occurred when I restarted the sound driver through the terminal, with the blank error and all, but it could possibly be caused because I have the volume icon on my task bar, which went blank after I issued the sound restart command. The output from the terminal was (just to be sure everything went as it is supposed to):

    su -c 'rcalsasound restart'


    Shutting down sound driver................done
    Starting sound driver: hda-intel..........done

    NOTE: There were NO periods in the actual command, but for the sake of a visual reference, they are added. Also, the done's are in bright green, like the normal completed command output would be. Just to be sure that I changed the sound file properly, the output that I got from the "cat" command is:

    cat /etc/modprobe.d/sound



    options snd slots=snd-hda-intel
    # u1Nb.Dtr+5XJCMB0:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=6stack-dig
    options snd-pcm-oss dsp_map=1

    The one thing I noticed was that there is a blank line as the first line in the file. It was there before I ever edited the file, but I wasn't sure if it was that big of a deal. Just wanted to let you know in case is might be causing a problem. On the issue of Ctrl+Alt+Backspace, I normally don't use this, as I just simply click the logout option in Gnome, but when I tried that, the system locked up, and I was unable to logout. Also, all the programs that were open at the time (Firefox and terminal) did not respond, so the only option was to press Ctrl+Alt+Backspace to force the system to logout. After I changed the file, restarted the sound driver, and after a restart to fix the assistive technology error, the volume is still not holding. The one thing that did change, though, is that when I opened YaST Volume Module after the restart, the "Analog Mix" option was set to 100 when I opened the window. I also ran the volume test through the terminal again, and got the following output:

    speaker-test -Dplug:front -c2 -l5 -twav



    speaker-test 1.0.18rc2

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 64 to 16384
    Period size range from 32 to 8192
    Using max buffer size 16384
    Periods = 4
    was set period_size = 4096
    was set buffer_size = 16384
    0 - Front Left
    1 - Front Right
    Time per period = 2.744583
    0 - Front Left
    1 - Front Right
    Time per period = 2.986679
    0 - Front Left
    1 - Front Right
    Time per period = 2.986569
    0 - Front Left
    1 - Front Right
    Time per period = 3.071745
    0 - Front Left
    1 - Front Right
    Time per period = 2.986589

    Which is good, because the error I originally got went away, so it seems like something changed. The headphone option for volume is also, still missing. To make it easier to see the volume module instead of explaining it, I've attached a screenshot of the window: click here. Also, the following is a screenshot of the sound card options through YaST: click here. Sorry for such a lengthy post, I just wanted to make sure I was as extensive as I could be. Hope this provides some useful information.

    Thank you again!

    Folding@Home
    Help save lives with Folding@Home

  4. #14
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    I have 6 jacks on the back of my computer that are connected directly to the motherboard (with an integrated sound card on the motherboard) and 2 jacks in the front, where the plug for the microphone and the plug for the headset (the output that goes to the headset), which is not attached, like the rear jacks, to my motherboard, but they are connected to it.
    Thanks. ... 6-jacks suggests to me that a "6stack" (and not a "3stack") model option is superior, although one could still try a 3stack (although I think it unlikely to work).

    Quote Originally Posted by Unseen-Ghost View Post
    rpm -qa | grep alsa ....... snipped ......
    OK, that looks correct. I assume you have restarted openSUSE Linux since updating to this version.

    Quote Originally Posted by Unseen-Ghost View Post
    On the topic of the Gnome issue with assistive technology, I've never had it happen before.
    This is Gnome specific. You will need to research this on your own and/or get a Gnome user to help you. As I noted above, I am not a Gnome fan. I use KDE.

    Quote Originally Posted by Unseen-Ghost View Post
    rpm -qa --last | grep at-spi
    at-spi-1.22.1-18.1 Tue 10 Jun 2008 08:19:55 AM EDT
    OK, so this was not a recent install, but its been on your PC for a while.

    Quote Originally Posted by Unseen-Ghost View Post
    On the issue of the headphone volume option disappearing, it could be my fault that I did something wrong. The only reason I thought it was the 6-dig command was because that was the only thing I changed, restarted my system, and the next time I checked the sound and volume settings, the option for headphone volume was missing.
    I don't know. The 6stack-dig model option could be wrong. A Ubuntu user noted it worked, but I have seen lots of inaccurate information on Ubuntu sites, so while there can be jems of information there, one can get "fools gold" as well.

    Quote Originally Posted by Unseen-Ghost View Post
    When I issued the command to test the sound that you provided, I got the following output, which contained an error:
    speaker-test -Dplug:front -c2 -l5 -twav

    speaker-test 1.0.18rc2
    ......... snipped ......
    Playback open error: -16,Device or resource busy
    Next time this happens, figure out what has grabbed your audio device! Simply copy and paste:
    lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
    run that at anytime, and it should tell you what device has use of the audio.

    Quote Originally Posted by Unseen-Ghost View Post
    I also added the two lines of script to the sound file.
    Did that help after a reboot? Or the same as before (ie the same without it)?

    Quote Originally Posted by Unseen-Ghost View Post
    su -c 'rcalsasound restart'
    Shutting down sound driver................done
    Starting sound driver: hda-intel..........done
    That looks good to me.

    Quote Originally Posted by Unseen-Ghost View Post
    cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.Dtr+5XJCMB0:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=6stack-dig
    options snd-pcm-oss dsp_map=1
    That looks good to me, but I recommend you remove the blank line that you noted. You can always put it back if it messes up things.

    Quote Originally Posted by Unseen-Ghost View Post
    On the issue of Ctrl+Alt+Backspace, I normally don't use this, as I just simply click the logout option in Gnome, but when I tried that, the system locked up, and I was unable to logout.
    In KDE we can press <CTRL><ESC> and bring up a task manager, where the offending app can be killed.

    Quote Originally Posted by Unseen-Ghost View Post
    The one thing that did change, though, is that when I opened YaST Volume Module after the restart, the "Analog Mix" option was set to 100 when I opened the window.
    Note going to YaST is likely going to wipe out your custom /etc/modprobe.d/sound file settings.

    Quote Originally Posted by Unseen-Ghost View Post
    I also ran the volume test through the terminal again, and got the following output:

    speaker-test -Dplug:front -c2 -l5 -twav

    speaker-test 1.0.18rc2
    .... snipped .......
    0 - Front Left
    1 - Front Right
    Did you hear a ladies voice say "Front left", "Front Right" at the same time?

    Now, have you added your user to group "audio" yet? Please try this. Note after adding your user to group audio, you need to log out of Linux and log back in again (restarting may be the easiest way to do this, if you do not understand).

    Quote Originally Posted by Unseen-Ghost View Post
    The headphone option for volume is also, still missing. To make it easier to see the volume module instead of explaining it, I've attached a screenshot of the window: click here. Also, the following is a screenshot of the sound card options through YaST: click here.
    The mixer in the pix you link to is either Pulse Audio or Gnome specific. I never see that. As a KDE-3.5.9 user I see Kmix instead. I can not help you much with your mixer, other than speculate. And if I were to speculate I would ask you to try your "line" setting to see if that is a "line out" that supports your headphones? Also I would speculate that you should play with your surround sound setting and your LFE, Side and Center to see if those produce more stable sound. You can always switch them off later if need be.

    Now, reference your /etc/modprobe.d/sound file, you can also try an option other than 6stack-dig. ... ie you can try instead 6stack, or laptop-dig or one of the other options. Of course you need to get the /etc/modprobe.d/sound file syntax correct (but I think you have that figured by now) and you need to restart alsa after each attempt with "rcalsasound restart" with root permissions.
    Code:
    	AD1988/AD1988B/AD1989A/AD1989B
    	  6stack	6-jack
    	  6stack-dig	ditto with SPDIF
    	  3stack	3-jack
    	  3stack-dig	ditto with SPDIF
    	  laptop	3-jack with hp-jack automute
    	  laptop-dig	ditto with SPDIF
    	  auto		auto-config reading BIOS (default)
    Good luck.

  5. #15
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    I added the "audio" group to my current username through Group and User Management in YaST. I restarted my system, but the problem still occurred. So, it doesn't appear to be a permission or group error. Also, when I issued the command to test the volume, I didn't hear a female voice in my headset, but the output changed from error message to the normal output after adding the two line of code to the sound file. So, at least that's something positive. But, what I found to be interesting, and possibly a lead in the right direction is when I clicked on "Sound" under the Gnome Control Panel, where system sounds, such as beeps and other sound-on-action settings are controlled, I got a bug error. The error window itself said:


    Bug reporting tool

    The application gnome-settings-daemon has crashed.
    Information about the crash has been successfully collected.

    This application is not known to bug-buddy, therefore the
    bug report cannot be sent to the GNOME Bugzilla. Please
    save the bug to a text file and report it to the appropriate
    bug tracker for this application.

    The readout for the error was: click here. Then the following error occurred:


    Unable to start the settings manager 'gnome-settings-daemon'.
    Without the GNOME settings manager running, some
    preferences may not take effect. This could indicate a
    problem with Bonobo, or a non-GNOME (e.g. KDE) settings
    manager may already be active and conflicting with the
    GNOME settings manager.

    I've had a problem with Bonobo errors like these before, but it never warned me that some settings might not take effect. The only reason I think this error is connected, because that seems like what is happening with the YaST Sound module: the volume settings aren't taking effect when I set them. In case it helps for anyone else that see this post, I went into the the /var/log/YaST2 and searched for all the lines containing "bonobo" I could find. The following is all the lines of "bonobo" information that was contained in the log file: click here. Just to see if there was an error on the frontend side, I changed the YaST2 GUI to Qt instead of GTK, but the same problem persisted. I also ran YaST through KDE3, but the same problem still occurred. Considering my best bet would be to create a bug report on Gnome Bugzilla, I'm going to try that as soon as possible.

    Thank you very much OldCPU for your help!

    Folding@Home
    Help save lives with Folding@Home

  6. #16
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    Also, when I issued the command to test the volume, I didn't hear a female voice in my headset, but the output changed from error message to the normal output after adding the two line of code to the sound file.
    That suggests to me there is a strong possibility that a judicious mixer setting could solve this. You could take out paper and pen, and record every possible mixer setting combination to see if you can find one that works.

  7. #17
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    I added the "audio" group to my current username through Group and User Management in YaST. I restarted my system, but the problem still occurred. So, it doesn't appear to be a permission or group error.
    Maybe yes, maybe no. If your mixer is also set wrong, then you could have two errors (permissions and bad mixer setting).

  8. #18
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    I'm not very familiar with Mixers: would it be okay if you could elaborate a little more on it?

    Sorry for my lack of knowledge on this.

    Thank you for the patience!

    Folding@Home
    Help save lives with Folding@Home

  9. #19
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Volume settings not holding

    Quote Originally Posted by Unseen-Ghost View Post
    I'm not very familiar with Mixers: would it be okay if you could elaborate a little more on it?
    You are using Gnome. You will need a Gnome user to walk you through the Gnome mixer.

  10. #20
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Volume settings not holding

    Okay. Thank you so much for your help!

    Folding@Home
    Help save lives with Folding@Home

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •