Results 1 to 7 of 7

Thread: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

  1. #1

    Default Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    System is 11.0 x86_64, I need bug-buddy 32 bit as javaws 32 bit needs it for an application:

    Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory

    ls /usr/lib/gtk-2.0/moduleslibferret.so libgail.so

    ls /usr/lib64/gtk-2.0/ libgnomebreakpad.so and more

    Using yast2, software, it only allows for a reinstall of bug-buddy (the package containing libgnomebreakpad) i586. How do I install both versions?

    Finally, I upgrade from 10.3 to 11.0, which didn't seems to work out perfectly. So maybe something went wrong there?

  2. #2

    Default Re: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    This is just a guess and may not work... But have you tried downloading the i586 RPM and installing it manually?

  3. #3

    Default Re: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    I considered it, but I prefer doing it by the yast/smart package manager to avoid update trouble later. Nevertheless I checked it:

    error: Failed dependencies:
    libelf.so.1 is needed by bug-buddy-2.22.0-34.1.i586
    libelf.so.1(ELFUTILS_1.0) is needed by bug-buddy-2.22.0-34.1.i586
    libgtop-2.0.so.7 is needed by bug-buddy-2.22.0-34.1.i586

    Does someone know whether it is at all possible to install both a i586 and a x86_64 version of a package under Suse 11.0?

  4. #4

    Default Re: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    Do you need the 64 bit version of bug-buddy specifically for any reason?

    Because if you only need the 32 bit version, and the 64 bit version is giving you trouble, why bother? But, I do agree, you should be able to install both, unfortunately I'm new to SUSE and using yast so I can't be much more help. (If you were using yum, it'd be a different story )

    Also, I did a quick check, those libraries you were missing have separate 32 bit counterparts in yast... So if all else fails, install them and switch to bug-buddy i586 in yast, that way everything will still be kept up to date.

  5. #5

    Default Re: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    Thanks for the suggestion, I tried that, but then yast complains:

    architecture change libelf1...x86_64 to libelf1...i586

    To me, that sounds that some very general library (elf1) is then gone, many programs depend on it I suppose.

  6. #6

    Default Re: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    Hmm, yes, I just noticed that the separate 32-bit version of libelf is libelf0... Well, I guess all you can do is hope one of the more knowledgeable members take a look at this thread

  7. #7

    Default Re: Bug-buddy x86_64 and i586 for libgnomebreakpad.so

    Thanks for pointing out. libelf0 and libelf0-32bit are also both installed. Redhat folks also had a similar problem, but this solution doesn't work for SuSE using yast.

    Anybody a suggestion how to solve this problem?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •