Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Workstation time falling behind

  1. #21
    Tilman Schmidt NNTP User

    Default Re: Workstation time falling behind

    South African Librarian schrieb:
    > output of /etc/init.d/ntp status
    >
    > Code:
    > --------------------
    >
    > remote refid st t when poll reach delay offset jitter
    > ==============================================================================
    > *LOCAL(0) .LOCL. 10 l 14 64 377 0.000 0.000 3.906
    > sabela.saix.net 193.67.79.202 2 u 381 1024 377 16.924 664495. 2613.28
    > induna.saix.net 193.67.79.202 2 u 400 1024 377 23.639 664456. 2718.25
    >
    > Checking for network time protocol daemon (NTPD): running


    So the time servers are reachable alright but for some reason the initial
    clock setting did not work, so the NTP daemon sees a clock difference of
    11 minutes which it considers too big to adjust.

    > After that I executed /etc/init.d/ntp start


    That doesn't do anything if, as in your case, the NTP daemon is already running.
    Yes, it prints:

    > Starting network time protocol daemon (NTPD) done


    but that's a lie. :-) Try

    /etc/init.d/ntp restart

    instead which should stop the daemon, re-execute the initial clock setting
    procedure, and then restart the daemon. Note what it says in the second step,
    in particular. It should say something like
    "Try to get initial date and time via NTP from <name_or_IP_address>"
    followed by some indication of success or failure.
    If it displays nothing of the sort, check in your /etc/sysconfig/ntp file
    whether the option NTPD_INITIAL_NTPDATE has been disabled, and re-enable it
    if necessary. If it displays a failure message, analyze that further.
    If it succeeds, chances are your network interface does not come up quick
    enough during system start, causing the initial attempt to contact a time
    server to fail. That is a weak point in this scheme of starting NTP.

    HTH
    T.

  2. #22

    Default Re: Workstation time falling behind

    Quote Originally Posted by ken_yap View Post
    Hmm, I realised we haven't checked for /etc/adjtime yet. This is a file that contains adjustments to the system clock. If it contains insane values it will make the system clock run very oddly. Please do:

    Code:
    cat /etc/adjtime
    and post the values, if the file exists. Then delete the file, resync your workstation and see how it goes.

    The meaning of the values in this file are explained in man hwclock.
    Code:
    cat /etc/adjtime
    -128.247721 1221814930 0.000000
    1219849494
    UTC
    File was deleted, will leave PC on over the weekend and see how it goes.

    Thanks

  3. #23

    Default Re: Workstation time falling behind

    Quote Originally Posted by Tilman Schmidt View Post
    /etc/init.d/ntp restart

    instead which should stop the daemon, re-execute the initial clock setting
    procedure, and then restart the daemon. Note what it says in the second step,
    in particular. It should say something like
    "Try to get initial date and time via NTP from <name_or_IP_address>"
    followed by some indication of success or failure.
    If it displays nothing of the sort, check in your /etc/sysconfig/ntp file
    whether the option NTPD_INITIAL_NTPDATE has been disabled, and re-enable it
    if necessary. If it displays a failure message, analyze that further.
    If it succeeds, chances are your network interface does not come up quick
    enough during system start, causing the initial attempt to contact a time
    server to fail. That is a weak point in this scheme of starting NTP.

    HTH
    T.
    Thanks - will try this on Monday as I don't want to do too many things at once.

    Enjoy the weekend!

    Libs

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •