Results 1 to 10 of 10

Thread: Beagle not running--KDE help search not available

  1. #1
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Beagle not running--KDE help search not available

    wonderful, i was just trying to find something in the KDE help and
    found this:

    "Application Manuals
    KDE Application Manuals
    The Beagle daemon is not running, search is not available"

    GREAT plan, give the job to the CPU hog-hound that everyone shoots on
    sight!!

    way to go!!!

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Beagle not running--KDE help search not available

    * DenverD,

    if you have a question, don't hesitate asking. Rants should go to soapbox, though.
    BTW, Beagle is working just fine here with Opensuse 11.

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Beagle not running--KDE help search not available

    you are right, sorry:

    how can i have full KDE help without Beagle running in 10.3?

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  4. #4
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Beagle not running--KDE help search not available

    Hmm,weird, i don't have beagle running/installed & still get KDE help, tried running susehelp from the cli ?

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Beagle not running--KDE help search not available

    deltaflyer44 wrote:
    > Hmm,weird, i don't have beagle running/installed & still get KDE help,


    try this:

    open personal settings/configure desktop, go System Administration >
    Login Manager > Convenience

    note that under "Enable Auto-Login" there are two check boxes, one
    labeled "Persistent" the other "Lock Session"...now, click the "Help"
    button and find either of those words on the displayed page, looking
    especially under the topic or Convenience...

    not there, is it?

    so, lets search (using the KDE Help Center, search blank:

    type in Persistent (leave all search settings as default, that is:
    search Manpages, KDE Application Manuals, openSUSE Documentation (en)
    and Release Notes) and click "Search"...scroll down the list looking
    for any clue as to what the Persistent check box under Enable
    Auto-Login might mean...

    maybe you can find something (if so please tell me) but i
    couldn't...but, i DID find this:

    "Application Manuals
    KDE Application Manuals
    The Beagle daemon is not running, search is not available"

    THEN: close the Help Center, go back to the Login Manager, and let
    pretend we want to actually enable/disable Auto-Login, so click on
    the "Administrator Mode" at the bottom, give root pass, click on
    "Convenience" tab, scratch your head trying to figure out what
    "Persistent" or "Lock session" buttons might do, and click the "Help"
    button to find out..

    and, instead of the KDE Help Center opening (like before) now i get a
    Help Center pop up dialog saying: "A search index does not yet
    exist. Do you want to create the index now?" with "Create" and "Do
    Not Create" buttons...

    click on "Create"

    now the Help Center opens (completely empty of all text), and also a
    "Build Search Index - KDE Help Center" dialog saying: "To be able to
    search a document, there needs to exist a search index. The status
    column of the list below shows, if an index for a document exists. To
    Create an index check the box in the list and press the "Build Indes"
    button."

    BUT, there is NO list...the the Search Scope/Status window is
    completely empty..

    there is a note "Index folder:
    file:///root/.kde4/share/apps/khelpcenter/index/
    and a "Change" button, click it--nothing happens

    and, since "Build Index" is grayed out, the only option is to click
    "Cancel"

    oh WAIT, it is hung here...

    no! though "Cancel" does nothing, i clicked the close window X at the
    windows top, and the "Build Search Index - KDE Help Center" dialog
    closed..

    the KDE Help Center (still blank) remains, and closed obediently when
    clicked on the X...

    my conclusion is that neither "Persistent" nor "Lock session" check
    box options are explained, AND Beagle _is_ required for FULL KDE help
    use, AND if you need help while doing root duties in the Login
    Manager, you better do your reading before you switch to root..

    the good news is: it is hump day.

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  6. #6
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Beagle not running--KDE help search not available

    my conclusion is that neither "Persistent" nor "Lock session" check
    box options are explained
    i find this also, but, still did not need beagle to build index,everything else i agree with.

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Beagle not running--KDE help search not available

    > but, still did not need beagle to build
    > index,everything else i agree with.


    hmmmmmm...so, you don't get that "KDE Application Manuals
    The Beagle daemon is not running, search is not available"

    hmmmm....i wonder why....i had beagle running for days...i'm sure it
    had plenty of time to build an initial index.....AND, i clicked the
    "Build Search Index" button at the bottom of the KDE Help Center
    window...and had it do its thing..

    strange.

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Beagle not running--KDE help search not available

    started beagle and now it says:

    KDE Application Manuals
    - kdebluetooth
    - kate
    - kdm

    wonderful! have to feed that hound to be able to search KDE App Manuals in 10.3--WHY?
    maybe it was fixed in 11.0 with KDE3.something??
    DD
    Caveat: http://is.gd/bpoMD
    Posted via http.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: Beagle not running--KDE help search not available

    Hope I'm not confusing apples with oranges here, but hoping its related. From opensuse 11 with beagle disabled, I launch a KDE3 app:

    KDE Contol Centre > Help > KDE Contol Centre Handbook

    This brings up KDE Help Centre. The search box is there but 'Search' button is inactive (greyed out). There is a 'Build Search Index' button, and clickong on it can result in 'Build Creation Finished', but I still can't search...if I really have to, I will reinstall beagle/kerry to see if this behaviour is rectified.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: Beagle not running--KDE help search not available

    Ok, cancel that. After the build index was created, and KDE Help relaunched, searching now works for me. So maybe 10.3 and 11 are different in this respect?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •