Results 1 to 3 of 3

Thread: DVD drive, USB storage will not auto mount

  1. #1

    Unhappy DVD drive, USB storage will not auto mount

    I had this problem back on my 10.2 system and solved it via the agony documented in this thread

    Now, I set up a new 10.3 system for school I volunteer at. Guess what? Same problem...DVD drive and USB storage devices will not mount.

    So, I'm back to trying to configure PolicyKit -- except on this system I don't even have a file called /etc/PolicyKit/privilege.d/desktop-console.privilege

    I've got nothing in the directories I normally look in. It looks like HAL and PolicyKit are not even running. I tried to start autofs in system services and it fails to start with "error 7", whatever that means.

    Can anyone help me? I'm willing to put the dozens of hours that will probably be required to get openSUSE to recognize removable media, but I don't even know where to start in this case. How do I get HAL and PolicyKit to be configured and started up on my system, so I can start to experiment with their config files?

    Chuck (really disappointed that this hasn't been fixed yet)

  2. #2
    Join Date
    Jun 2008
    Auckland, NZ
    Blog Entries

    Default Re: DVD drive, USB storage will not auto mount

    PolicyKit has been upgraded significantly since 10.2 disto was realesed. PolicyKit config files now at /usr/share/PolicyKit/policy/ directory. In particular, have a look at:

    cat /usr/share/PolicyKit/policy/

    Forgetting PolicyKit for the moment, do you have 'usb_storage' module loaded?

    Another worthwhile step is to try and upgrade hal and PolicyKit packages via YOU.

  3. #3

    Default Re: DVD drive, USB storage will not auto mount

    Until I get a VPN set up I have to drive to the school to check this machine so I'm at a bit of a disadvantage. I did attempt to use YAST to install a newer version of HAL and PolicyKit last night, but it zips right through the "install" without returning any error messages -- and it doesn't do anything.

    I'm starting to get bad flashbacks from my 10.2 experience, and am thinking to either ditch openSUSE and move to another distro, or try to reinstall openSUSE. Seems like the fresh install of 10.3 worked fine but something in the list of "automatic updates" is what cratered my DVD drive and USB functionality. This pretty much mirrors the experience I had with 10.2.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts