Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: package devel not found

  1. #11
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    439

    Default Re: package devel not found

    Quote Originally Posted by lornix View Post
    On Wed, 20 Aug 2008 20:26:03 GMT
    collinm <collinm@no-mx.forums.opensuse.org> wrote:

    >
    > i done kbuildsycoca4...
    >
    > tried to start kword
    >
    > and get libkwordpart not found
    >
    > libkwordpart is on my system....
    >
    >
    > Code:
    > --------------------
    > linux-02tg:/home/collinm # locate libkwordpart
    > /home/collinm/Developpement/koffice-build/kword/part/CMakeFiles/CMakeRelink.dir/libkwordpart.so
    > /home/collinm/Developpement/koffice-build/lib/kde4/libkwordpart.so
    > /home/collinm/Developpement/koffice-build/lib/libkwordpart.so
    >
    > --------------------


    No. It's not. It is in your home directory... it's not in the proper
    place in the system directory hierarchy to be automatically found and used.

    Another thing to note is that 'locate' uses a database which is only updated
    ONCE a day. any changes you make to the files on the disk will not be
    reflected until the following day. A better way to search for files on the
    disk would be to use 'find':

    find . -iname "libkwordpart*"

    means find, from here (.), anything with a filename which starts with
    'libkwordpart' (notice the asterisk (the star thingy) )

    --or--

    find / -iname "libkwordpart*"

    which will search the ENTIRE system to find matches. This can take a while.

    After the libkwordpart.so library is installed in the proper place, you'll
    need to run 'ldconfig' as root to update the library indexes.

    ldconfig

    Loni

    --
    L R Nix
    lornix@lornix.com
    is there a way to keep the library where is it now?
    what i need to do to ?

    i runned updatedb before doing the locate...

  2. #12
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    439

    Default Re: package devel not found

    Code:
    collinm@linux-02tg:~> export PATH=$PATH:/home/collinm/Developpement/koffice-build/bin
    collinm@linux-02tg:~> export KDEDIRS=$KDEDIRS:/home/collinm/Developpement/koffice-build
    ldconfig
    kbuildsycoca4
    same problem

  3. #13
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: package devel not found

    On Thu, 21 Aug 2008 17:46:01 GMT
    collinm <collinm@no-mx.forums.opensuse.org> wrote:

    > > > tried to start kword
    > > >
    > > > and get libkwordpart not found
    > > >
    > > > libkwordpart is on my system....
    > > >
    > > >
    > > > Code:
    > > > --------------------
    > > > linux-02tg:/home/collinm # locate libkwordpart
    > > >

    > > /home/collinm/Developpement/koffice-build/kword/part/CMakeFiles/CMakeRelink.dir/libkwordpart.so
    > > > /home/collinm/Developpement/koffice-build/lib/kde4/libkwordpart.so
    > > > /home/collinm/Developpement/koffice-build/lib/libkwordpart.so
    > > >
    > > > --------------------

    > >
    > > No. It's not. It is in your home directory... it's not in the proper
    > > place in the system directory hierarchy to be automatically found and
    > > used.
    > >

    >
    > is there a way to keep the library where is it now?
    > what i need to do to ?
    >


    You could use the LD_PRELOAD command, or
    add /home/collinm/Developpement/koffice-build/lib to the system library
    search path.

    So, two methods:

    ====1. You can use the LD_PRELOAD option to specify which libraries to load,
    you'll need to type this before EVERY test of kword


    LD_PRELOAD=/home/collinm/Developpement/koffice-build/lib/kde4/libkwordpart.so ./kword

    ====2. You can add the subdirectory where the libraries are located to the
    system library search paths:

    echo "/home/collinm/Developpement/koffice-build/lib"
    > /etc/ld.so.conf.d/collinm


    (that was all on one line, you'll need to be root to execute it)

    then run

    ldconfig

    to update the system library indexes.

    ==== Either way works, method 2 is easier overall, but you may forget to
    remove the path in /etc/ld.so.conf.d/collinm later and the system will
    likely complain when it rebuilds the library indexes. Don't forget to
    delete /etc/ld.so.conf.d/collinm when you're doing playing with
    kword/koffice.

    Loni

    --
    L R Nix
    lornix@lornix.com


  4. #14
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    439

    Default Re: package devel not found

    same problem with both method... surely the problem is another place...

    anyway

  5. #15
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: package devel not found

    On Fri, 22 Aug 2008 18:46:01 GMT
    collinm <collinm@no-mx.forums.opensuse.org> wrote:

    >
    > same problem with both method... surely the problem is another place...
    >
    > anyway
    >
    >


    You *could* actually just type 'make install' and have the libraries put in
    the proper places. That would solve many problems you're going to have.

    Loni

    --
    L R Nix
    lornix@lornix.com


Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •