I've been using Linux on and off for a few years now and the past 6 months or so has been almost constant Linux, no MS. My laptop has XP and openSUSE 10.3 with KDE 3.5 and KDE 4.1 installed. I've been using KDE4 for day-to-day use solidly for the past week or so now and I've just had a major crash which has messed up my whole openSUSE installation.

I store all my Music and Photos on an external USB drive which is always plugged in as my laptop is old and tiny. I was running Amarok, Gwenview and Dolphin in KDE 4.1 when the X server appeared to restart and I was thrown back to the login screen. I didn't get a warning or a message or anything. Confused, I tried to log back into KDE 4.1. During login an error box came up which said "Could not start kdeinit4. Check your installation." and I was thrown back to the login screen again.

I then tried to log in to KDE 3.5 which worked. However, upon meeting my desktop I got an error message saying that Kima couldn't start and there were also no icons in the 'system tray'. At this point I decided to reboot the laptop.

When the laptop came back I tried to login to KDE 4.1 again but I got the same error message. So I tried to logon to KDE 3.5 again. This worked and I got the same error message and same lack of icons. I then found out that I couldn't browse my USB drive as I didn't have the required permissions and when I "sudo su" to the USB drive I found it was there but empty.

This scared me, so for the first time in ages I rebooted into Windows XP. Thankfully XP shows all my files on the USB drive are there and are OK so I'm only left with a broken OS, not data loss.

So, does anybody know why this happened? Has anybody come across the same issue? Does anybody know how to fix it?

Thank you very much for any responses!