Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: intltool error

  1. #1

    Default intltool error

    i have an error with intltool when './configure'ing. whenever i type ./configure it runs through a list of commands and things. at the end it says:

    checking for intltool >= 0.35.0... awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
    awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
    found
    ./configure: line 7198: test: : integer expression expected
    configure: error: Your intltool is too old. You need intltool 0.35.0 or later.
    i downloaded and installed intltool 0.37.1-17.1 using YAST2
    the error still occurs.
    this may be a blatantly obvious error for you pros, but i am new at linux.
    Thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,641
    Blog Entries
    15

    Default Re: intltool error

    Quote Originally Posted by DrEaMeR23
    i have an error with intltool when './configure'ing. whenever i type
    /configure it runs through a list of commands and things. at the end
    it says:

    >
    > checking for intltool >= 0.35.0... awk: cmd. line:1: fatal: cannot
    > open file `./intltool-update.in' for reading (No such file or
    > directory) awk: cmd. line:1: fatal: cannot open file
    > `./intltool-update.in' for reading (No such file or directory)
    > found
    > ./configure: line 7198: test: : integer expression expected
    > configure: error: Your intltool is too old. You need intltool 0.35.0
    > or later.
    >


    i downloaded and installed intltool 0.37.1-17.1 using YAST2
    the error still occurs.
    this may be a blatantly obvious error for you pros, but i am new at
    linux.
    Thanks in advance
    Hi
    That indicates the file called 'intltool-update.in' doesn't exist in
    the directory, hence the error. Is there something in the readme or
    install file supplied with the package? Run configure with --help as
    there may be an option your missing? Generally it also helps (well me
    anyway) to say what package you downloaded or did it come via cvs etc
    and are trying to build.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 0:52, 1 user, load average: 0.80, 0.29, 0.23
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3

    Default Re: intltool error

    oh. well im trying to install dldi-linux-gui which is from:

    SourceForge.net: Files

    i read the install file and it told me to get some C++ Bindings:

    To compile DLDI Linux Gui, you'll need the dbus C++ Bindings of the OpenWengo project. Get it from their subversion repository.

    svn co https://dev.openwengo.org/svn/openwe...-api/libs/dbus dbus-c++

    cd to that directory
    cd dbus-c++

    Run configure WITH --enable-glib
    ./configure --enable-glib

    Compile and install it
    make
    sudo make install
    When i got to ./configure --enable-glib it said:
    bash: ./configure: No such file or directory
    i tried configure --help but it said 'command not found'

    How do i fix the initltool problem?

    Thanks in advance

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,641
    Blog Entries
    15

    Default Re: intltool error

    Quote Originally Posted by DrEaMeR23
    oh. well im trying to install dldi-linux-gui which is from:

    'SourceForge.net: Files' (http://tinyurl.com/5hq9aj)
    5hq9aj ->
    http://sourceforge.net/project/showf...ease_id=591817

    i read the install file and it told me to get some C++ Bindings:

    > To compile DLDI Linux Gui, you'll need the dbus C++ Bindings of the
    > OpenWengo project. Get it from their subversion repository.
    >
    > svn co http://tinyurl.com/6r7rzy dbus-c++

    6r7rzy ->
    https://dev.openwengo.org/svn/openwe...-api/libs/dbus
    >
    > cd to that directory
    > cd dbus-c++
    >
    > Run configure WITH --enable-glib
    > ./configure --enable-glib
    >
    > Compile and install it
    > make
    > sudo make install

    When i got to ./configure --enable-glib it said:
    > bash: ./configure: No such file or directory


    i tried configure --help but it said 'command not found'

    How do i fix the initltool problem?

    Thanks in advance
    Hi
    Try running ./autogen.sh first that should build the configure script.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 16:09, 2 users, load average: 0.26, 0.67, 0.49
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5

    Default Re: intltool error

    i did the './autogen.sh' which worked. i then could do the './configure'. which also worked. however, when i do 'make' i get an error:

    object.cpp:113: error: strncmp was not declared in this scope
    make[1]: *** [object.lo] Error 1
    make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src'
    make: *** [all-recursive] Error 1
    whats this telling me? how do i fix it?
    thanks in advance

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,641
    Blog Entries
    15

    Default Re: intltool error

    Quote Originally Posted by DrEaMeR23
    i did the './autogen.sh' which worked. i then could do the
    './configure'. which also worked. however, when i do 'make' i get an
    error:

    >
    > object.cpp:113: error: strncmp was not declared in this scope
    > make[1]: *** [object.lo] Error 1
    > make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src'
    > make: *** [all-recursive] Error 1


    whats this telling me? how do i fix it?
    thanks in advance
    Hi
    I would say that's an issue with gcc4.3 and strict headers. L R Nix
    will probably be online soon and hopefully she will have an idea on a
    fix :-)

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 20:00, 2 users, load average: 0.29, 0.20, 0.24
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  7. #7
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: intltool error

    On Tue, 19 Aug 2008 16:29:27 GMT
    Malcolm <malcolm_nospamlewis@bellsouth.net> wrote:

    >
    Quote Originally Posted by DrEaMeR23
    > i did the './autogen.sh' which worked. i then could do the
    > './configure'. which also worked. however, when i do 'make' i get an
    > error:
    >
    > >
    > > object.cpp:113: error: ‘strncmp’ was not declared in this scope
    > > make[1]: *** [object.lo] Error 1
    > > make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src'
    > > make: *** [all-recursive] Error 1

    >
    > whats this telling me? how do i fix it?
    > thanks in advance
    >
    > Hi
    > I would say that's an issue with gcc4.3 and strict headers. L R Nix
    > will probably be online soon and hopefully she will have an idea on a
    > fix :-)
    >


    NOW I know why my ears were burning....

    Hi guys!

    Let's see.... one of those "error: 'x' was not declared in this scope"
    thingy's again huh?

    Simple!!

    This error is because of updates to the gcc/g++ compilers to make them
    conform better to the standards. The header files were revamped and do not
    "helpfully" include extra headers any more.

    So... to fix....

    Look at the offending function call... in this case: "strncmp"

    Anyone know what header it's from? Well, look it up in the man pages:

    man strncmp

    in the SYNOPSIS section right at the top of the text is "#include <string.h>",
    which is for a C program... so we need to make it work for a C++ program...
    (press 'q' to exit the man page viewer)

    drop the '.h' and put a 'c' in front... thus we have "cstring"

    Add the following line to the object.cpp (right? that's what's shown in the
    error message)

    #include <cstring>

    You'll need to find any other '#include' statements in the source file, and
    put this new one just after them.

    Hopefully (!) this made sense, and you'll be able to take care of any other
    error messages like this that occur. Over time, more people will use the new
    gcc/g++ versions (4.3.1 and newer I think) and this problem will fade.

    Loni

    --
    L R Nix
    lornix@lornix.com


  8. #8

    Default Re: intltool error

    confused.... that didnt make any sense for me sorry. also i dont have manual pages for strncmp: 'no manual entry for strncmp' would it be possible for you to rewrite the instructions so they are more user friendly please?

    thanks anyway

  9. #9

    Default Re: intltool error

    i put #include <cstring> into object.cpp and ran make again. however i have a new error:

    types.cpp:69: error: free was not declared in this scope
    make[1]: *** [types.lo] Error 1
    make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src'
    make: *** [all-recursive] Error 1
    i am a real newbie at all this, so dont blame me for being ignorant.

    thanks

  10. #10
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: intltool error

    On Wed, 20 Aug 2008 09:36:03 GMT
    DrEaMeR23 <DrEaMeR23@no-mx.forums.opensuse.org> wrote:

    >
    > i put #include <cstring> into object.cpp and ran make again. however i
    > have a new error:
    >
    > > types.cpp:69: error: ‘free’ was not declared in this scope
    > > make[1]: *** [types.lo] Error 1
    > > make[1]: Leaving directory `/home/rory/DLDI/GUI/dbus-c++/src'
    > > make: *** [all-recursive] Error 1

    >
    > i am a real newbie at all this, so dont blame me for being ignorant.
    >
    > thanks
    >
    >


    You should see that you have the 'man-pages' package installed, it helps with
    many things.

    The line for this one is:

    #include <cstdlib>

    Loni

    --
    L R Nix
    lornix@lornix.com


Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •