Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: can't enable wireless

  1. #1

    Default can't enable wireless

    hi. all of the sudden - knetworkmanager says that the wireless is disabled, and there isn't any "enable wireless" option. why is this? here's some info for you that might help you help me.

    Code:
    04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
    Code:
    wlan0     IEEE 802.11g  ESSID:""
              Mode:Managed  Channel:0  Access Point: Invalid
              Tx-Power=0 dBm
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Code:
    wlan0     Interface doesn't support scanning : Network is down
    Last edited by indietrash; 18-Aug-2008 at 06:51. Reason: wireless, knetworkmanager, network manager, enable wireless

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: can't enable wireless

    SuSE version ? DE ? in my knetworkmanager it has deactivate/activate connection

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3

    Default Re: can't enable wireless

    oh. sorry. those elementary parts slip my mind every time.

    anyway, openSUSE 11.0 and KDE 3.5. I have 4.0 as well. I had an "enable wireless" option. but it suddenly uhm went away. the wireless is supposed to be activated upon start, and it worked beautifully up until just now when I rebooted. no idea why.

  4. #4

    Default Re: can't enable wireless

    when I run the network device wizard-thingy in yast, I am able to enable/disable it for a while until the wizard completes. I think when the "network services set up" gets a check - it works. but then it stops suddenly.

  5. #5

    Default Re: can't enable wireless

    on my knetwork for KDE 3.5.x If I look at deactivate connection it gives options including Switch to Online mode, if I am offline at the time. I just have to go over the Disable to let it pop up extra options

  6. #6

    Default Re: can't enable wireless

    then once I am in Online Mode I can go and select my network and have it put me online

  7. #7

    Default Re: can't enable wireless

    well that's what I'm supposed to do but uhm I can't.

    it's set to activate at boot. it's in the firewalls external zone. non-root users can control it via kinternet. it uses dhcp and the right module.

  8. #8

    Default Re: can't enable wireless

    hi I added the card as wlan1 for the third time and suddenly it started working again. I did try adding it earlier on (two times) with the exact same settings - without any luck. but now all of the sudden it started working.

  9. #9

    Default Re: can't enable wireless

    okay it's down again. it seems it's completely random. sometimes I can just ifconfig wlan0 up, or add it as wlan1 - but most of the time it simply doesn't work!

  10. #10

    Default Re: can't enable wireless

    so let me sum this up for you,


    openSUSE 11.0
    KDE 3.5

    ok. my wireless network is completely random. it's ridiculous. in knetworkmanager yer supposed'a be able to enable/disable it, but most of the time i's just disabled and I can't enable it with the manager. most of the time it's like this,


    Code:
    lolwabbit:~ # iwconfig wlan0
    wlan0     IEEE 802.11g  ESSID:""
              Mode:Managed  Channel:0  Access Point: Not-Associated
              Tx-Power=0 dBm
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B
              Encryption key:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Code:
    lolwabbit:~ # lspci |grep w
    05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
    Code:
    lolwabbit:~ # lsmod |grep iwl4965
    iwl4965               139364  0
    firmware_class         27776  2 microcode,iwl4965
    mac80211              220436  1 iwl4965
    Code:
    lolwabbit:~ # dhcpcd wlan0
    err, wlan0: ioctl SIOCSIFFLAGS: No such device
    Code:
    lolwabbit:~ # iwlist wlan0 scan
    wlan0     Interface doesn't support scanning : Network is down
    Code:
    lolwabbit:~ # ifconfig wlan0 up
    SIOCSIFFLAGS: No such device

    Code:
    lolwabbit:~ # ifup wlan0
    Network interface is managed from NetworkManager
    NetworkManager will be advised to set up wlan0
    but it cannot be assured from here.

    here's my 70.persistent-net.rules,

    Code:
    # This file was automatically generated by the /lib/udev/write_net_rules
    # program run by the persistent-net-generator.rules rules file.
    #
    # You can modify it,as long as you keep each rule on a single line.
    # PCI device 0x10ec:0x8168 (r8169)
    # PCI device 0x8086:0x4229 (iwl4965)
    # This file was automatically generated by the /lib/udev/write_net_rules
    # program run by the persistent-net-generator.rules rules file.
    #
    # You can modify it,as long as you keep each rule on a single line.
    # PCI device 0x10ec:0x8168 (r8169)
    # PCI device 0x8086:0x4229 (iwl4965)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1d:e0:c6:50:29", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:09:df:81:0c:2e", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    I've tried removing the latter lines, but when I reboot they get added automatically so I guess they are supposed to be like that. or? I have no idea. this is way above my wireless skills (none). PLEASE help. I need the wireless working on this as it is the computer I use at my technical university college.
    Last edited by indietrash; 19-Aug-2008 at 07:22. Reason: typo

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •