Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Can not switch off the desktop effect on Suse 11

  1. #1

    Default Can not switch off the desktop effect on Suse 11

    Hi:

    I was playing around with the XGL desktop effects on the SuSE 11. I enabled the effect by Simple Compiz Config Setting Manager found in application/utilities/desktop/Desktop Effects. The decoration seems to block the close, maximize and minimize button on the window title bar. I tried to switch the desktop effects off. Each time it seems to be turned off but comes back on the next logon. Is there any way I can manually switch these effects off like the

    gnome-xgl-switch --disable-xgl

    would do the trick? Since SUSE 11 gets new way of setting up XGL, I am not sure if I should still use the old way to do it. The GUI suppose to work. Is it a bug?

  2. #2

    Default Re: Can not switch off the desktop effect on Suse 11

    I used to toggle the XGL using
    1/ xgl-switch --enable/disable-xgl (in console with no graphics)
    2/ In KDE there is an icon called "Desktop effects". It can be found by search in the "Start" menu. You should use it to enable/disable certain visual effects.

    In your case that would be first 2/ and then 1/.
    Good luck.
    SDA

  3. #3

    Default Re: Can not switch off the desktop effect on Suse 11

    Thanks. I tried option 2 many times and not working for me. It the XGL effects just came back by itself.

    The option 1 gave me this

    Warning! MD5DIR is not set: you probably called this script outside SuSEconfig...!
    Using MD5DIR="/var/adm/SuSEconfig/md5"...
    No changes for /etc/X11/xdm/Xservers
    No changes for /etc/X11/xdm/xdm-config

    It doesn't seems to be working either

  4. #4
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Can not switch off the desktop effect on Suse 11

    Ok.
    Now, I'm faced with the same error message as sueyentsai. I can't switch off compiz. Any ideas?
    Thanks.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #5
    tehmasp NNTP User

    Default Re: Can not switch off the desktop effect on Suse 11

    I just had this problem.
    Enabled XGL on a system w/ a bad video card. All I got was a white screen which I could rotate via the cube plugin. I ran the 'xgl-switch --disable-xgl' command as root and noticied that it still didn't work for my regular user. Ultimately, I deleted the 'compiz' directory under my ~/.config/ directory. That allowed me to get back into gnome as my regular user. I realized that this must have been a problem since I was still able to get into X as root just fine.

    in summary,
    try running the 'xgl-switch' command AND delete the 'compiz' directory under ~/.config.

    gluck

  6. #6

    Default Re: Can not switch off the desktop effect on Suse 11

    A while ago there was a bug in which KDE would not remember between login sessions that desktop effects had been switched ON. They fixed that. Now it won't remember that they've been switched OFF.

    (me too)

  7. #7

    Default Re: Can not switch off the desktop effect on Suse 11

    Log in as root. Navigate to your home directory. If there's a folder named Compiz in the .config(hidden) directory, delete it. Log out root and back in as you. Desktop effects should be disabled.

  8. #8
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: Can not switch off the desktop effect on Suse 11

    Quote Originally Posted by opensuze View Post
    Log in as root. Navigate to your home directory. If there's a folder named Compiz in the .config(hidden) directory, delete it. Log out root and back in as you. Desktop effects should be disabled.
    BAD advice NEVER log in as root use su or sudo instead

    In a console type su then your root password then
    xgl-switch --disable-xgl (to disable Xgl and deactivate Compiz)

    Have a read here

  9. #9

    Default Re: Can not switch off the desktop effect on Suse 11

    Quote Originally Posted by geoffro View Post
    BAD advice NEVER log in as root use su or sudo instead

    In a console type su then your root password then
    xgl-switch --disable-xgl (to disable Xgl and deactivate Compiz)

    Have a read here
    This is assuming he can see a console or anything but a blank monitor with his user login.
    .......though, I suppose he could do a console login from KDM.
    Redhat 7.3, 9.0, Fedora Core 1, 2, 3, 4, openSUSE 10.1, 10.2, Fedora 7, 8, 9, openSUSE 11.0
    Preferred Desktop: Gnome

  10. #10

    Default Re: Can not switch off the desktop effect on Suse 11

    the desktop effect seems to be very tough to kill. I tried the sudo xgl-switch --disable-xgl as well as remove the compiz folder under the .config under my home folder. The next time I logon, the compiz grew back by itself

    The desktop effect is still there. Actually I don't necessary have to remove it. Just the windows decoration thing is blocking all the maximize, minimize and close icon. I have to guess where it is and hit the right spot to get those buttons functioning. If there is a way to have them show up all the time. That would be good enough.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •