Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

  1. #1
    Join Date
    Aug 2008
    Posts
    7

    Default gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Hi,

    After many days search on google and tries, I'm about to conclude that gnome-pilot is not operational on openSUSE 11.

    jpilot works great at the first try. I could stay on it but I've two Treo (650 and 680) that I synced together through Outlook on Windows, and I want to be able to do the same with Evolution. jpilot can't do that. jpilot can sync with two PDAs, but in different folders, so the contain of the two PDAs are not synced together.

    It seems that gnome-pilot, since it manage different PDAs, can sync my two Treos.

    I've created a rule file for udev:
    /etc/udev/rules.d/10-custom.rules :
    BUS=="usb",SYSFS{product}=="Palm Handheld*",KERNEL=="ttyUSB[13579]",NAME="%k",SYMLINK+="pilot",GROUP="uucp",MODE="0666",OPTIONS+="last_rule"

    I've added in /usr/share/gnome-pilot/devices.xml:
    <!-- Handspring Treo 650 -->
    <device vendor_id="0830" product_id="0061" />

    Remark: /var/log/message indicates that both Treo 650 and 680 are detected with the same vendor_id and product-id:
    Aug 14 13:12:51 linux-zxw kernel: hub 2-0:1.0: unable to enumerate USB device on port 4
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: new full speed USB device using uhci_hcd and address 32
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: configuration #1 chosen from 1 choice
    Aug 14 13:12:51 linux-zxw kernel: visor 6-2:1.0: Handspring Visor / Palm OS converter detected
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: Handspring Visor / Palm OS converter now attached to ttyUSB0
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: Handspring Visor / Palm OS converter now attached to ttyUSB1
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: New USB device found, idVendor=0830, idProduct=0061
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: Product: Palm Handheld
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: Manufacturer: Palm, Inc.
    Aug 14 13:12:51 linux-zxw kernel: usb 6-2: SerialNumber: PalmSN12345678
    Aug 14 13:12:53 linux-zxw kernel: usb 6-2: USB disconnect, address 32
    Aug 14 13:12:53 linux-zxw kernel: visor ttyUSB0: Handspring Visor / Palm OS converter now disconnected from ttyUSB0
    Aug 14 13:12:53 linux-zxw kernel: visor ttyUSB1: Handspring Visor / Palm OS converter now disconnected from ttyUSB1
    Aug 14 13:12:53 linux-zxw kernel: visor 6-2:1.0: device disconnected
    Aug 14 13:12:54 linux-zxw kernel: hub 2-0:1.0: unable to enumerate USB device on port 4
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: new full speed USB device using uhci_hcd and address 33
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: configuration #1 chosen from 1 choice
    Aug 14 13:12:54 linux-zxw kernel: visor 6-2:1.0: Handspring Visor / Palm OS converter detected
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: Handspring Visor / Palm OS converter now attached to ttyUSB0
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: Handspring Visor / Palm OS converter now attached to ttyUSB1
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: New USB device found, idVendor=0830, idProduct=0061
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: Product: Palm Handheld
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: Manufacturer: Palm, Inc.
    Aug 14 13:12:54 linux-zxw kernel: usb 6-2: SerialNumber: PalmSN12345678

    When I press the hotsync button on the Treo, the udev rule is applied so /dev/pilot is created.
    lrwxrwxrwx 1 root root 7 Aug 14 13:12 /dev/pilot -> ttyUSB1
    Notice that in the rule, I've specified GROUP=uucp, but /dev/pilot is still in the "root" group.

    pilot-xfer works great both on /dev/ttyUSB1 and /dev/pilot. So it seems to me that the udev rule is not really necessary.
    pilot-install-user can also retrieve my Treo's user name and use id.

    I've configured gnome-pilot-applet so my gpilotd's config is:
    more .gnome2/gnome-pilot.d/gpilotd

    [General]
    sync_PC_Id=-171687487
    progress_stepping=1
    num_devices=1
    num_pilots=2

    [Device0]
    type=1
    name=Cradle
    device=/dev/pilot
    speed=9600
    timeout=100

    [Pilot0]
    name=Treo650_fr
    pilotid=1392
    creation=0
    romversion=0
    pilotusername=wzx1
    basedir=/home/wzx/Palm/Treo650
    charset=CP1252

    [Pilot1]
    name=Treo680_cn
    pilotid=7195
    creation=0
    romversion=0
    pilotusername=wzx2
    basedir=/home/wzx/Palm/Treo680
    charset=CP1252

    For the two PDAs, user name and pilotid are values given by pilot-install-user command.
    I've tried timeout with different values: 0, 2, 15, 100.

    All these settings don't work, so I run gpilotd on command line for seeing what's happening:
    /usr/lib/gnome-pilot/gpilotd --oaf-activate-iid=OAFIID:GNOME_Pilot_Daemon --oaf-ior-fd=26
    gpilotd-Message: gnome-pilot 2.0.16 starting...
    gpilotd-Message: compiled for pilot-link version 0.12.2
    gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network] [Bluetooth]
    gpilotd-Message: Activating CORBA server
    IOR:0119c5bf1b00000049444c3a474e4f4d452f50696c6f742f4461656d6f6e3a312e300096030000000054424f580000000101026905000000554e49580066756c0a0000006c6f63616c686f73740000002d0000002f746d702f6f726269742d7a6978696f6e672f6c696e632d323264362d302d323863623239346361363064340000000000000000caaedfba580000000101022f2d0000002f746d702f6f726269742d7a6978696f6e672f6c696e632d323264362d302d32386362323934636136306434006800001c00000000000000390868a8fe0a2828c02b2828282828286770696c6f74640001000000480000000163623202000000050000001c00000000000000390868a8fe0a2828c02b2828282828286770696c6f746400010000001400000001672f6c01000105000000000901010000000000
    gpilotd-Message: bonobo_activation_active_server_register = 0
    gpilotd-Message: Watching Cradle (/dev/pilot)
    gpilotd-Message: Found 4766, 0001
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0502, 0736
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 091e, 0004
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 115e, f100
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 082d, 0100
    gpilotd-Message: Using net FALSE
    gpilotd-Message: Found 082d, 0200
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 082d, 0300
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0061
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0c88, 0021
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0001
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0002
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0003
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0020
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0031
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0040
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0050
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0060
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0061
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0070
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 0830, 0080
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 04e8, 8001
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 04e8, 6601
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 0038
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 0066
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 0095
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 009a
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 00c9
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 00da
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 00e9
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 0144
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 054c, 0169
    gpilotd-Message: Using net TRUE
    gpilotd-Message: Found 12ef, 0100
    gpilotd-Message: Using net TRUE

    Then nothing.

    When I killed the existing gpilotd, it's reloaded at once (by bonobo, I suppose), so I had to be fast enough to launch my command line gpilotd just after killing the running one.

    In gnome-pilot setting, I've never been able to get user name and id from Pilot.

    I've also tried to run the whole thing as root, same result.

    Here is my env:
    rpm -qa pilot* gnome-pilot* kernel* evolution*
    evolution-data-server-2.22.1.1-11.1
    evolution-2.22.1.1-15.1
    kernel-default-2.6.25.11-0.1
    gnome-pilot-lang-2.0.16-29.1
    kernel-pae-2.6.25.11-0.1
    kernel-source-2.6.25.11-0.1
    pilot-link-0.12.2-112.1
    gnome-pilot-2.0.16-29.1
    gnome-pilot-conduits-lang-2.0.16-27.1
    evolution-sharp-0.16.1.1-15.1
    evolution-pilot-2.22.1.1-15.1
    gnome-pilot-conduits-2.0.16-27.1

    It's strange that openSUSE 11 has a gnome-pilot 2.0.16, whereas on the gnome-pilot web site, the latest version is 2.0.15.
    Should I try the 2.0.15 ?

    I've also tried to boot with kernel-default and kernel-pae, I don't know if this has any influence.

    Do you have any idea ?

    Thanks in advance.

    wzx

  2. #2
    Join Date
    Aug 2008
    Location
    Chişinău, Moldova
    Posts
    13

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Hi, I just wanted to let you know that I am currently researching the same problem (it happens with openSUSE 11 and a Tungsten T5).

    After reading various tutorials I did pretty much everything you did, and got the same results.

    I am 100% sure the device works and all the low-level stuff is correct, and that the problem is in gnome-pilot.

    There is a howto on the gentoo wiki, one of the tips is as follows:
    Start off by attempting to get the basic information about the PDA. Run pilot-xfer --port /dev/tts/USB1 --list and hit the hotsync button on the PDA when prompted. It should spit out a list of information. We're not terribly interested in the information, just the fact that communication is possible.Start off by attempting to get the basic information about the PDA. Run pilot-xfer --port /dev/tts/USB1 --list and hit the hotsync button on the PDA when prompted. It should spit out a list of information. We're not terribly interested in the information, just the fact that communication is possible.
    In my case the command is replaced with pilot-xfer --port /dev/pilot --list. It prints the contents of my PDA (list of programs), and the PDA itself makes the 'hotsync' sound + afterwards it says "hotsync complete".


    I am certain that the solution lies in tinkering with gnome-pilot.

  3. #3
    Join Date
    Aug 2008
    Posts
    7

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Hi,

    I've posted the same question in the gnome-pilot mailinglist.
    The problem is HAL and it's a known bug.
    If you stop hald just before syncing the Palm, the sync will work.
    see :
    Re: gnome-pilot doesn't work on openSUSE 11 (jpilot, pilot-link both wor

    I've tried to compile gnome-pilot as suggested, but there are very different dependencies on other packages which are shipped with openSUSE 11. So the configure phase failed.

    If I can only get a gnome-pilot rpm without HAL, I'll be happy.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,493
    Blog Entries
    15

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Quote Originally Posted by wzx
    Hi,

    I've posted the same question in the gnome-pilot mailinglist.
    The problem is HAL and it's a known bug.
    If you stop hald just before syncing the Palm, the sync will work.
    see :
    'Re: gnome-pilot doesn't work on openSUSE 11 (jpilot, pilot-link both
    wor' (http://tinyurl.com/6d2n55)

    I've tried to compile gnome-pilot as suggested, but there are very
    different dependencies on other packages which are shipped with
    openSUSE 11. So the configure phase failed.

    If I can only get a gnome-pilot rpm without HAL, I'll be happy.
    Hi
    What's stopping you making the rpm without HAL? Just download the src
    rpm from opensuse.org, remove the HAL patch, modify the spec file and
    rebuild the rpm?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 13:57, 2 users, load average: 0.01, 0.10, 0.15
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5
    Join Date
    Aug 2008
    Posts
    7

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    I'm just confused by the ./configure script of gnome-pilot.

    When I run it, I get:
    ...
    checking for HAL... configure: WARNING: HAL/DBUS Library requirements (dbus-glib-1>= 0.31, hal>= 0.5.4)
    not met; disabling HAL support.
    checking for GNOME_PILOT... configure: error: Package requirements (
    libxml-2.0
    libgnome-2.0>= 2.0.0
    libgnomeui-2.0>= 2.0.0
    libglade-2.0>= 2.0.0
    libbonobo-2.0>= 2.0.0
    ORBit-2.0>= 2.0.0
    bonobo-activation-2.0>= 1.0.3
    gnome-vfs-2.0>= 2.0.0
    gconf-2.0
    ) were not met:

    No package 'libxml-2.0' found
    No package 'libgnome-2.0' found
    No package 'libgnomeui-2.0' found
    No package 'libglade-2.0' found
    No package 'libbonobo-2.0' found
    No package 'ORBit-2.0' found
    No package 'bonobo-activation-2.0' found
    No package 'gnome-vfs-2.0' found
    No package 'gconf-2.0' found

    On my system, I've the following:
    libxml-1.8.17-489.1
    libgnome-2.22.0-30.2
    libgnomeui-2.22.1-22.1
    libglade2-2.6.2-93.1
    libbonobo-2.22.0-21.1
    orbit2-2.14.12-32.1
    gnome-vfs2-2.22.0-33.1
    gconf2-2.22.0-28.1
    dbus-1-glib-0.74-88.1
    hal-0.5.11-8.1

    And I didn't know where package version requirements are defined. After reading you message, I find a gnome-pilot.spec file in the sources, but package versions there are still different:
    Requires: pilot-link >= 0.9.5
    Requires: gnome-core >= 1.2.12
    Requires: ORBit >= 0.5.7
    Requires: libglade >= 0.16
    Requires: libxml >= 1.8.12
    Requires: gnome-vfs >= 1.0

    Not only the versions are different with what's reported by ./configure, but there are less packages too.

    Thanks

  6. #6
    Join Date
    Aug 2008
    Posts
    7

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    For more precisions:
    my pilot-link version is:
    pilot-link-0.12.2-112.1

    There is no such package like gnome-core in openSUSE 11 as indicated in the spec file.
    The ./configure just stops after reporting these errors.
    No makefile created, so I can't compile.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,493
    Blog Entries
    15

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Quote Originally Posted by wzx
    I'm just confused by the ./configure script of gnome-pilot.

    When I run it, I get:
    ...
    checking for HAL... configure: WARNING: HAL/DBUS Library requirements
    (dbus-glib-1>= 0.31, hal>= 0.5.4)
    not met; disabling HAL support.
    checking for GNOME_PILOT... configure: error: Package requirements (
    libxml-2.0
    libgnome-2.0>= 2.0.0
    libgnomeui-2.0>= 2.0.0
    libglade-2.0>= 2.0.0
    libbonobo-2.0>= 2.0.0
    ORBit-2.0>= 2.0.0
    bonobo-activation-2.0>= 1.0.3
    gnome-vfs-2.0>= 2.0.0
    gconf-2.0
    ) were not met:

    No package 'libxml-2.0' found
    No package 'libgnome-2.0' found
    No package 'libgnomeui-2.0' found
    No package 'libglade-2.0' found
    No package 'libbonobo-2.0' found
    No package 'ORBit-2.0' found
    No package 'bonobo-activation-2.0' found
    No package 'gnome-vfs-2.0' found
    No package 'gconf-2.0' found

    On my system, I've the following:
    libxml-1.8.17-489.1
    libgnome-2.22.0-30.2
    libgnomeui-2.22.1-22.1
    libglade2-2.6.2-93.1
    libbonobo-2.22.0-21.1
    orbit2-2.14.12-32.1
    gnome-vfs2-2.22.0-33.1
    gconf2-2.22.0-28.1
    dbus-1-glib-0.74-88.1
    hal-0.5.11-8.1

    And I didn't know where package version requirements are defined. After
    reading you message, I find a gnome-pilot.spec file in the sources, but
    package versions there are still different:
    Requires: pilot-link >= 0.9.5
    Requires: gnome-core >= 1.2.12
    Requires: ORBit >= 0.5.7
    Requires: libglade >= 0.16
    Requires: libxml >= 1.8.12
    Requires: gnome-vfs >= 1.0

    Not only the versions are different with what's reported by
    /configure, but there are less packages too.

    Thanks
    Hi
    Normally when compiling from source you need the development versions
    of the files installed as well.

    Try just building the source rpm first, this gives a better idea of the
    files you need, eg;

    Code:
    kermit-opensuse:~ # rpmbuild
    --rebuild /home/malcolml/build/gnome-pilot-2.0.16-29.1.src.rpm
    Installing /home/malcolml/build/gnome-pilot-2.0.16-29.1.src.rpm error:
    Failed build dependencies: gob2 is needed by
    gnome-pilot-2.0.16-29.1.i586 intltool is needed by
    gnome-pilot-2.0.16-29.1.i586 libpisock-devel is needed by
    gnome-pilot-2.0.16-29.1.i586 libpisync-devel is needed by
    gnome-pilot-2.0.16-29.1.i586 update-desktop-files is needed by
    gnome-pilot-2.0.16-29.1.i586
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 15:35, 2 users, load average: 0.22, 0.11, 0.08
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  8. #8
    Join Date
    Aug 2008
    Posts
    7

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Yet other info:
    ./configure uses pkg-config for verifying package versions, and these verifications need .pc files.
    But in openSUSE 11, most packages just don't have .pc files, so these packages are seen by rpm, but not by pkg-config.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,493
    Blog Entries
    15

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    Quote Originally Posted by wzx
    Yet other info:
    /configure uses pkg-config for verifying package versions, and these
    verifications need .pc files.
    But in openSUSE 11, most packages just don't have .pc files, so these
    packages are seen by rpm, but not by pkg-config.
    Hi
    That's because the are installed when you install the devel version of
    the file...

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
    up 15:48, 2 users, load average: 0.21, 0.09, 0.07
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  10. #10
    Join Date
    Aug 2008
    Posts
    7

    Default Re: gnome-pilot doesn't work on openSUSE 11 (jpilot ok)

    So I've FTPed all required src.rpms.

    But if all I need is source files (including .pc files), what command must be used for installing these packages so necessary files go to /usr/lib/pkgconfig directory ? (and .h files go to /usr/include ?)

    I don't want to really rebuid and replace packages already present in the system, but just have depending packages's src files needed for compiling gnome-pilot.

    Thanks.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •