Ok 3D Compiz works like a dream on KDE 3. Only when I reboot I have to re-enable it in Desktop Effect's. I have installed the Codecs and clicked on the recommended Multimedia - openSUSE-Community which installed plenty of stuff, yet in kaffeine I only get sound.

If I do an upgrade. My PC falls apart. 3D no longer works, Codec problem is still not sorted. 3D is sluggish and slow, where as in a fresh install it's fine.

My intuition is telling me not to enable ATI as a repo, so I can keep the original working driver. How does one do that anyway if I do upgrade?

Sorry let me give you some specs:

KDE 3
ATI Radeon 9600.
1 Gig Ram.
160Gig HDD.
P4 Hyper-threading 2.8Ghz.
Two DVD writers.

So any idea's? I'm going back to sleep now. However it would be nice to know a few things.

Thanks.

PS Oh and I have converted away from Ubuntu. Not because I had any problems. I just like the look of openSUSE.