Results 1 to 10 of 10

Thread: Conflict resolutions

  1. #1
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Conflict resolutions

    After a corrupted install of kde4.1 I decided to reinstall opensuse. Now that I've done that I'm having trouble installing software, I keep getting conflict resolutions and I didn't get these before I did the reinstall.

    What is wrong? I can't find the w32codecs and libdvdcss2. it very frustrating to have to do it all over again and now yast is giving me trouble.

    Help!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Conflict resolutions

    You need Packman for w32codecs
    VLC for libdvdcss2

    Only install libdvdcss2 from VLC

    Install the VLC player from Packman
    Then disable the VLC repo

    Manage your software with software management rather than software updater.

    If you have a specific problem, tell us the details
    You can save the confilct errors to a file - to enable you to post them here - if it's too long, either give us the idea or put the file in pastebin or something
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,708
    Blog Entries
    1

    Default Re: Conflict resolutions

    Make sure you have some of the additional community repositories enabled via YaST > Software > Software Repsitories. Choose 'Add' then select 'Community Repositories'. You'll need to enable the 'Packman Repsotiory' for full multimedia support.

    The other useful way to search for and download software is via the openUSE Webpin. Choose your distro version, then search for 'w32codec' for example. You will get a list of '1-click' packages which makes installing required packages simple.

    Hope this helps.

  4. #4
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Conflict resolutions

    Thanks I've can now play dvds with vlc. Why can't kaffeine play the same videos? kaffeine works on my other distros. what do I have to do to get Kaffeine to work?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Conflict resolutions

    Any packages that you have from the vlc repo that are also in the packman repo, manually make sure they are forced to install packman version - including vlc player itself. all you will have from vlc is libdvdcss2

    In particular ensure you have packman packaged libffmpeg0 and xvid and vlc and not the videolan equivalents. And of course mplayer and kaffeine from packman.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Conflict resolutions

    Thanks for the advice, but I've never had to do that before once the codecs were installed kaffeine worked. Why would opensuse be different? It should not be so difficult. For now, I'll use vlc instead.

  7. #7

    Default Re: Conflict resolutions

    To get kaffeine to work properly, get rid of xinelib (Novell's crippled version) and install libxine from packman.

  8. #8
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Conflict resolutions

    how do you know if its from pacman?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Conflict resolutions

    In software management, when you highlight the package in the the list on the right, lower down there are tabs - details - dependencies...etc.. version

    In there will be all the versions available by your installed repo's
    mark the radio button for the version you want
    watch out for the different 32bit and 64bit packages
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,708
    Blog Entries
    1

    Default Re: Conflict resolutions

    An easy method (while you are grabbing packages like kaffeine and MPlayer from Packman) is to disable the other repos temporarily via YaST > Software Repositories then search for the required packages with Software Manager. You can also do this directly with the Software Manager by setting the filter to 'Respositories' then click on the 'Packaman Repository'. From here, you can choose or search for the required packages.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •