Results 1 to 2 of 2

Thread: Running Kismet

  1. #1

    Default Running Kismet

    OK, so I was able to install Kismet on openSUSE 11, but I am getting this error message:

    stacy-suse:/home/ryan # kismet
    Server options: none
    Client options: none
    Starting server...
    Waiting for server to start before starting UI...
    FATAL: Could not find user 'your_user_here' for dropping priviledges. Makesure you have a valid user set for 'suiduser' in your config file. See the 'Installation & Security' and 'Configuration' sections of the README file formore information.

    Here is what my /usr/local/etc/kismet.conf looks like:

    # Version of Kismet config
    version=2007.09.R1

    # Name of server (Purely for organizational purposes)
    servername=Kismet

    # User to setid to (should be your normal user)
    suiduser=ryan

    ryan is my normal user. I don't know why it is not working. Any help would be appreciated

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Running Kismet

    On Sat, 16 Aug 2008 06:56:03 GMT
    petaganayr <petaganayr@no-mx.forums.opensuse.org> wrote:

    >
    > OK, so I was able to install Kismet on openSUSE 11, but I am getting
    > this error message:
    >
    > stacy-suse:/home/ryan # kismet
    > Server options: none
    > Client options: none
    > Starting server...
    > Waiting for server to start before starting UI...
    > FATAL: Could not find user 'your_user_here' for dropping priviledges.
    > Makesure you have a valid user set for 'suiduser' in your config file.
    > See the 'Installation & Security' and 'Configuration' sections of the
    > README file formore information.
    >
    > Here is what my /usr/local/etc/kismet.conf looks like:
    >
    > # Version of Kismet config
    > version=2007.09.R1
    >
    > # Name of server (Purely for organizational purposes)
    > servername=Kismet
    >
    > # User to setid to (should be your normal user)
    > suiduser=ryan
    >
    > ryan is my normal user. I don't know why it is not working. Any help
    > would be appreciated
    >
    >


    The kismet server must be STARTED as root, it will drop to the specified user
    after it sets up the required wireless configurations.

    You then use the kismet client (as a regular user) to access and control (to a
    degree) the kismet server.

    su - root -c kismet

    which should start the server as root, then shift to user 'ryan' (from above)
    and start the client.

    Loni

    --
    L R Nix
    lornix@lornix.com


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •