Results 1 to 2 of 2

Thread: alsa-devel package

  1. #1

    Default alsa-devel package

    Hello,

    I'm new to the build service and try to build my first package, see NtEd. My problem is in the ./configure step. I get the error message
    Code:
    checking for ALSA... configure: error: Make sure the libasound (ALSA) devel package is installed
    On my local machine I solved this point with installing the package alsa-devel so I thought I have use this package in the specfile, too. I added
    Code:
    BuildRequires: gcc-c++, alsa-devel
    but I get the same error.

    So, what package do I have to write in the spec file? Is there a general way to find out how packages are named in the build service?

    Thanks a lot for your answers and patience with a package novice

    greetings, Carsten

  2. #2

    Lightbulb Re: [solved] alsa-devel package

    Hello,

    I found the error. I missed the line in front of the ALSA line:
    Code:
    checking for pkg-config... no
    checking for ALSA... configure: error: Make sure the libasound (ALSA) devel package is installed
    So, I addedto the spec file
    Code:
    BuildRequires: gcc-c++ pkg-config alsa-devel
    and the error is gone
    Code:
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for ALSA... yes
    Greetings, Carsten

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •