Results 1 to 6 of 6

Thread: SUSE11 rndis_wlan Problem

  1. #1
    zappedback NNTP User

    Default SUSE11 rndis_wlan Problem

    I am a linux noob and i need help getting SUSE11 to connect to my wi-fi, SUSE has detected my hardware
    as you can see SUSE is using rndis_wlan my question is how do i use rndis_wlan to connect to the web or how do i
    block it from loading so i can use ndiswrapper.
    The output from my terminal is below. Thankyou for any help.




    dmesg | grep rndis_wlan

    wlan0: register 'rndis_wlan' at usb-0000:00:10.3-3, Wireless RNDIS device, BCM4320b based, 00:16:01:09:b7:50
    usbcore: registered new interface driver rndis_wlan
    rndis_wlan 2-3:1.0: rndis media disconnect



    iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE802.11bg ESSIDff/any
    Mode:Managed Frequency:2.417 GHz Bit Rate:54 Mb/s Tx-Power=14 dBm
    RTS thr=2347 B Fragment thr=2346 B
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0



    ifconfig wlan0

    wlan0 Link encap:Ethernet HWaddr 00:16:01:09:B7:50
    BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

  2. #2
    zappedback NNTP User

    Default Re: SUSE11 rndis_wlan Problem

    Anyone?...

  3. #3
    zappedback NNTP User

    Default Re: SUSE11 rndis_wlan Problem

    No help well im off to try another Linux distro i hope SUSE 11.1 fixes the network problems that stop suse from being a better and easier to use Linux.

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: SUSE11 rndis_wlan Problem

    On Fri, 15 Aug 2008 13:56:03 GMT
    zappedback <zappedback@no-mx.forums.opensuse.org> wrote:

    >
    > No help well im off to try another Linux distro i hope SUSE 11.1 fixes
    > the network problems that stop suse from being a better and easier to
    > use Linux.
    >
    >


    You barely gave us any information about your system, your network device, or
    your current setup.

    What network device do you have?

    What is its CURRENT setup?
    IP addres, netmask, routing, dns... so forth

    Yes, this could be a huge issue that stops the world turning and prevents
    suse from being a better and easier-to-use linux... But I'm of the belief
    that if it doesn't work in suse, it might not work in another distro either.

    From my experience (I have a little)... MOST things work in suse. SOME
    things require a little more attention during setup to make them work.

    From your initial posting, you're using a device with the BCM43xx chipset.
    This chipset requires that you download and install the firmware it needs to
    work. Otherwise... nothing works.

    This problem will plague you in almost ANY other distro you try...

    From the notes posted here:

    http://en.opensuse.org/HCL/Network_Adapters_(Wireless)

    About 1/4 the way down, it lists bcm43xx... and gives this note:

    11.0 Native kernel driver. First check if b43-fwcutter is installed, if not
    install it, then run as root the included script: install_bcm43xx_firmware
    from the /usr/sbin directory. You have to be already connected to the
    Internet to run the script. Restart your system to load the driver.

    A bit terse, but succinct. If you were to read the documentation on

    http://forums.opensuse.org/network-i...less-bits.html

    You'd find some help there too for the Broadcom chipsets

    Another page dedicated to making the bcm43xx chips work with linux:

    http://linuxwireless.org/en/users/Drivers/b43

    Tends to be generic, but good information.

    Considering that you're using openSUSE 11.0... this makes things a little
    easier, as many of the bcm43xx firmware files needed are *NOW* included in a
    secondary repository, but not installed by default.

    I'll paraphrase the instructions found elsewhere:

    Please make sure the Packman repository is installed. To do this, start the
    YaST setup program, then click the following: (you can skip part of this if
    you've got the Packman repo installed already)

    - Software Management (new window opens, wait while it updates)
    - click on 'Repositories' (top menu) and select 'Repository Manager'
    - click on 'Add', select 'Community Repositories', and 'Next'
    - Wait for some processing and retrieval of new repo lists
    - Look through list, select the 'Packman Repository', click 'OK'
    There are many available, please consult the gurus on the
    forums to see which are helpful, and which might not be.
    - some more processing and downloading of repo file lists. Will
    likely need to accept one or two signing keys.
    - you're returned to Repository Manager main list, click "Ok"
    - you're returned to the Software Management screen

    Now that the Packman repo is installed, search and install the firmware
    files. Start the YaST setup program and 'Software Management' module if not
    already there from previous steps.

    - in the 'Search' box, type 'b43', click 'Search'.
    - Click in boxes to select 'b43' and 'b43legacy'
    - click 'Accept', bottom right.
    - if another window pops up with 'these files are needed too',
    click 'OK' to acknowledge this.
    - Say 'No' to 'install more software' query.

    This installs the firmware files needed to make your wireless work.

    This should be all you need. Shutdown and restart your system, and see if
    your wireless works now. You may need to set it up in the YaST network
    devices -> network settings modules, or the GUI based network-manager
    application (look in the 'tray' near the clock)

    A simple command to scan for wireless networks and test if card is working is:

    sudo iwlist scan

    Which should show you any wireless networks broadcasting around you.

    {if you get 'network is down', type 'sudo ifconfig wlan0 up', then try again.
    I hope it's called 'wlan0', could be otherwise, but it's not 'eth0' or 'lo',
    adjust as needed}

    Please be aware that while network-manager works well, the GUI interfaces
    (knetwork-manager and others) sometimes have trouble connecting first time
    around. keep trying. I've heard that this is fixed in newer updates.

    If this does not help at all, please search the forums for bcm43 or broadcom,
    or the make/model of your wireless card. I was able to glean some
    information from the meager post you made, but more information will help us
    help you.

    Other solutions involve using 'b43-fwcutter' which extracts the firmware
    files (from other sources) so that the card works. This should be
    depreciated now that the b43/b43legacy packages are available. (b43-fwcutter
    is also available via yast, you likely saw it during the search and install
    above)

    Hope this helps

    Loni

    --
    L R Nix
    lornix@lornix.com


  5. #5
    zappedback NNTP User

    Default Re: SUSE11 rndis_wlan Problem

    Thanks for posting Loni "iwlist scan" gives me this output which is my network but when i try to connect using "ifup

    wlan0" i cant get an connection i have unchecked the use ipv6 in yast and even stopped the firewall service not a

    good idea but worth a try. My wlan0 is correctly configured in yast with my SSID and Encryption key. I know network

    manager is broken so i do everything in YAST. i am such a noob so my apologies for not providing the correct info i

    am trying my best.


    iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 Scan completed :
    Cell 01 - Address: 00:16:01F4:1F
    ESSID:"XXXXXXXXXXXXXXXXXXXX"
    Mode:Managed
    Frequency:2.412 GHz (Channel 1)
    Quality=31/100 Signal level=-76 dBm
    Encryption keyn
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:bcn_int=100
    Extra:atim=0
    IE: WPA Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK




    ifup wlan0
    wlan0
    wlan0 warning: WPA configured but may be unsupported
    wlan0 warning: by this device
    wlan0 starting wpa_supplicant
    Starting DHCP Client Daemon on wlan0... . . . . . . . . . . . . . . . no IP address yet... backgrounding.
    /sbin/ifup: line 1026: 7181 Segmentation fault ifup-route $CONFIG $INTERFACE ${OPTIONS:+-o $OPTIONS}

  6. #6

    Default Re: SUSE11 rndis_wlan Problem

    Hi!
    I think there is something wrong with your device or the if_route binary or something else because you get that segmentation fault which is why you can't get connection:
    "/sbin/ifup: line 1026: 7181 Segmentation fault ifup-route "

    I also have BCM4230b usb wireless device. It works just fine with rndis_wlan. I am using networkmanager (NM) and it is behaving well. NM used to be broken in fedora 8 but is fine in fedora 9 and opensuse 11.

    Now for the driver: I think rndis_wlan is good driver and it works for the three computers that I have tried but if you insist on using ndiswrapper you can create the file

    /etc/modprobe.d/blacklist-rndis (you can put anything you want after 'blacklist-' the example is with rndis just to remind you)

    with that line in it:

    blacklist rndis_wlan

    An easy way to do it would be:
    sudo echo 'blacklist rndis_wlan' > /etc/modprobe.d/blacklist-rndis
    (the above is one line)

    or you can also do:

    su
    (it will ask you for the root password)
    kwrite /etc/modprobe.d/blacklist-rndis
    (after a few seconds a window will open, write

    blacklist rndis_wlan

    save and close the window)


    On the next plugging of the usb or restart rndis_wlan will not be loaded.

    And some more info for this guy "lornix" with the ideas for b43 and firmwares and so on ...

    A quote from b43 - Linux Wireless

    "If you have an USB device with Broadcom chip, please try the RNDIS driver. The b43/b43legacy driver will never support this device."

    Then there is some info at rndis_wlan - Linux Wireless

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •