Results 1 to 8 of 8

Thread: Compiz: Can't see desktop cube selected in desktop effects

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Compiz: Can't see desktop cube selected in desktop effects

    I can't find a previous forum post exactly on this subject, so I need new advice, please.

    I'm using OS 11.0, Gnome, with Composite enabled, the latest compiz-fusion installed, the Compiz-fusion icon showing. I am able to configure desktop effects via simple CCSM, enable them at start up. I have selected the 'Advanced' profile and Desktop Cube with 4 cols. and 1 row for desktop appearance. But I cannot see the cube and appear to have only the 1 workspace.

    What other settings should I be checking?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  2. #2

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    Make sure you have at least 2 desktops in order for the cube to work (if you have 2 its just a panel). If you want the standard cube you need to have 1 horizontal desktops, 1 vertical virtual size and 4 horizontal virtual size.

    Remember with compiz, you actually have one virtual desktop that is just expanded across the screen (thats how the cube effect works), you don't actually have 4 desktops.

  3. #3
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    Quote Originally Posted by PandaMine View Post
    Make sure you have at least 2 desktops in order for the cube to work (if you have 2 its just a panel). If you want the standard cube you need to have 1 horizontal desktops, 1 vertical virtual size and 4 horizontal virtual size.

    Remember with compiz, you actually have one virtual desktop that is just expanded across the screen (thats how the cube effect works), you don't actually have 4 desktops.
    Sorry to appear dumb, but I don't understand this. In selecting the desktop effects I have specified 4 columns and 1 row - which I assume to mean 4 desktops.

    How do I specify a horizontal desktop - or at least 2 as you are suggesting? What about a vertical virtual desktop? I see no mention of these terms in the 'desktop effects' applet.

    I was sure that my set-up would give me 4 desktops: I recall seeing a cube which I could rotate, showing 4 desktops, in my previous OS 11.0 install, which died shortly afterwards with just a white screen from which I could not recover. (I'm hoping that the same thing is not going to happen again).
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  4. #4

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    Firstly make sure your desktop cube is enabled (in the main screen of the Compiz Config Settings Manager make sure Desktop Cube and Rotate Cube are enabled)

    Then go to General Options -> Desktop Size. If you wan't your standard 4 sided cube these should be your settings
    Horizontal Virtual Size -> 4
    Vertical Virtual Size -> 1
    Number of Desktops -> 1

    To rotate your cube you just do CTRL + ALT and use your mouse to move it around. You can also layout the cube by pressing CTRL + ALT + DOWN and if you have Expo enabled you can view them all at once with Super (normally Windows Key) + E

    Also make sure that compiz is enabled and working in the first place

  5. #5
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    Quote Originally Posted by PandaMine View Post

    To rotate your cube you just do CTRL + ALT and use your mouse to move it around. You can also layout the cube by pressing CTRL + ALT + DOWN and if you have Expo enabled you can view them all at once with Super (normally Windows Key) + E
    Many thanks for this patient explanation - the Ctrl+Alt+mouse allowed me to see the cube for the first time with this installation. I tried placing a photo of a well-known female celebrity on one face of the cube, and discovered to my disappointment that rotating the cube did not enhance the view of her well publicised attributes..... The compiz development team missed an opportunity there.

    I can find no additional functions with the key combination Ctrl+Alt+DOWN -that merely seems to show me the 'wall' again, and allows me to switch to another workspace - which I can do quicker via Ctrl+Alt+LEFT/RIGHT - so I must be doing something wrong here.

    A sticky label under my keyboard says manufacturing date was 03-02-1985 so there isn't a Windows key! Can you point me to some documentation which will tell me what SUPER is mapped to?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  6. #6

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    I'm having the same problem. I have Compiz installed on KDE 4, and I can't get the cube to show up at all. I followed your instructions, but it still doesn't work.

    Also, I tried going to Utilities-->Desktop-->Desktop Effects, and I got the Simple Compiz Config Settings menu up. I check "Enable Desktop Effects," but it just makes the screen flash for a moment, and then that's it. When I close the menu and open it again, "Enable Desktop Effects" is unchecked again, and under "accessibility it says "disabled" and has a red minus sign. Do I have Compiz set up wrong?

  7. #7

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    Wow I can't even run glxgears now. Something must be wrong. I downloaded the NVidia driver from their website and installed it via command line. Now I get this:

    ~> glxgears
    Xlib: extension "GLX" missing on display ":0.0".
    glxgears: Error: couldn't get an RGB, Double-buffered visual.


    Edit:
    Ok I reinstalled the driver and now glxgears works and it keeps my settings in teh compiz manager and everything, but I still can't get the cube to show up. Any ideas please?

  8. #8

    Default Re: Compiz: Can't see desktop cube selected in desktop effec

    Oh. I figured out what was wrong. You have to alt+ctrl and also click with the mouse or use arrow keys. I was just using the alt+ctrl buttons on the keyboard and nothing was happening.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •