Although I am already aware that there are dependency issues with KDE 4.1 Factory for 64bit systems, I am currently having a dependency issue with 32 bit system.

I installed openSuse with KDE 4.1 and enabled the KDE:Factory repositories (and removed the old KDE4 repositories).

Basically I have an issue with certain Widgets, where if I try to place them it comes up with "unknown applet" on the Desktop and the Widget doesn't display properly. Apparently installing the extragear-plasma package solves this, however when I try to install this package I get these dependancy issues (Yast2 is attempting to downgrade everything)

#### YaST2 conflicts list - generated 2008-08-13 16:47:55 ####

kde4-plasma-addons-4.1.0-5.10.i586 requires kdebase4-runtime >= 4.1.0, but this requirement cannot be provided

[ ] do not install extragear-plasma-4.0.1-67.1.i586
[ ] Ignore some dependencies of kde4-plasma-addons
[ ] Following actions will be done:
deinstallation of kde4-plasma-addons-4.1.0-5.10.i586
downgrade of kdebase4-runtime-4.1.0-19.4.i586 to kdebase4-runtime-4.0.4-20.2.i586
downgrade of kdepim4-4.1.0-29.9.i586 to kdepim4-4.0.80-9.3.i586
downgrade of kdepim4-wizards-4.1.0-29.9.i586 to kdepim4-wizards-4.0.80-9.3.i586
downgrade of kdemultimedia4-4.1.0-16.5.i586 to kdemultimedia4-4.0.4-15.1.i586
downgrade of kdenetwork4-filesharing-4.1.0-15.11.i586 to kdenetwork4-filesharing-4.0.4-19.1.i586
downgrade of kdegames4-4.1.0-11.12.i586 to kdegames4-4.0.4-16.1.i586
downgrade of kdebase4-workspace-4.1.0-38.6.i586 to kdebase4-workspace-4.0.4-24.6.i586
install ktorrent-3.1.2-0.pm.1.i586 (with vendor change)
openSUSE Build Service
-->
packman.links2linux.de
downgrade of kdebase4-4.1.0-23.11.i586 to kdebase4-4.0.4-18.2.i586
downgrade of kde4-webkitpart-4.1.0.svn837566-6.25.i586 to kde4-webkitpart-4.0.71.svn800669-21.1.i586
downgrade of kde4-okular-4.1.0-23.10.i586 to kde4-okular-4.0.4-14.1.i586
downgrade of kde4-kwrite-4.1.0-23.11.i586 to kde4-kwrite-4.0.4-18.2.i586
downgrade of kde4-kwin-4.1.0-38.6.i586 to kde4-kwin-4.0.4-24.6.i586
downgrade of kde4-kwikdisk-4.1.0-17.10.i586 to kde4-kwikdisk-4.0.4-19.1.i586
downgrade of kde4-kwalletmanager-4.1.0-17.10.i586 to kde4-kwalletmanager-4.0.4-19.1.i586
downgrade of kdeartwork4-screensaver-4.1.0-7.13.i586 to kdeartwork4-screensaver-4.0.4-14.1.i586
downgrade of kde4-ksnapshot-4.1.0-23.10.i586 to kde4-ksnapshot-4.0.4-14.1.i586
downgrade of kde4-krfb-4.1.0-15.11.i586 to kde4-krfb-4.0.4-19.1.i586
downgrade of kde4-krdc-4.1.0-15.11.i586 to kde4-krdc-4.0.4-19.1.i586
downgrade of kde4-kontact-4.1.0-29.9.i586 to kde4-kontact-4.0.80-9.3.i586
downgrade of kde4-konqueror-plugins-4.1.svn838216-10.19.i586 to kde4-konqueror-plugins-4.0.svn767780-72.1.i586
downgrade of kde4-ksudoku-4.1.0-11.12.i586 to kde4-ksudoku-4.0.4-16.1.i586
downgrade of kde4-kscd-4.1.0-16.5.i586 to kde4-kscd-4.0.4-15.1.i586
downgrade of kde4-kruler-4.1.0-23.10.i586 to kde4-kruler-4.0.4-14.1.i586
downgrade of kde4-kreversi-4.1.0-11.12.i586 to kde4-kreversi-4.0.4-16.1.i586
downgrade of kde4-kpat-4.1.0-11.12.i586 to kde4-kpat-4.0.4-16.1.i586
downgrade of kde4-korganizer-4.1.0-29.9.i586 to kde4-korganizer-4.0.80-9.3.i586
downgrade of kde4-kopete-4.1.0-15.11.i586 to kde4-kopete-4.0.4-19.1.i586
downgrade of kde4-konsole-4.1.0-23.11.i586 to kde4-konsole-4.0.4-18.2.i586
downgrade of kde4-konqueror-4.1.0-23.11.i586 to kde4-konqueror-4.0.4-18.2.i586
downgrade of kde4-knotes-4.1.0-29.9.i586 to kde4-knotes-4.0.80-9.3.i586
downgrade of kde4-knewsticker-4.1.0-15.11.i586 to kde4-knewsticker-4.0.4-19.1.i586
downgrade of kde4-kmix-4.1.0-16.5.i586 to kde4-kmix-4.0.4-15.1.i586
downgrade of kde4-kmines-4.1.0-11.12.i586 to kde4-kmines-4.0.4-16.1.i586
downgrade of kde4-kmail-4.1.0-29.9.i586 to kde4-kmail-4.0.80-9.3.i586
downgrade of kde4-kmahjongg-4.1.0-11.12.i586 to kde4-kmahjongg-4.0.4-16.1.i586
downgrade of kde4-kmag-4.1.0-20.13.i586 to kde4-kmag-4.0.4-14.1.i586
downgrade of kde4-kio_sysinfo-11.1-21.18.i586 to kde4-kio_sysinfo-11.0-74.2.i586
downgrade of kde4-kio_kamera-4.1.0-23.10.i586 to kde4-kio_kamera-4.0.4-14.1.i586
downgrade of kde4-kio_audiocd-4.1.0-16.5.i586 to kde4-kio_audiocd-4.0.4-15.1.i586
downgrade of kde4-kgpg-4.1.0-17.10.i586 to kde4-kgpg-4.0.4-19.1.i586
downgrade of kde4-kget-4.1.0-15.11.i586 to kde4-kget-4.0.4-19.1.i586
downgrade of kde4-kcalc-4.1.0-17.10.i586 to kde4-kcalc-4.0.4-19.1.i586
downgrade of kde4-kaddressbook-4.1.0-29.9.i586 to kde4-kaddressbook-4.0.80-9.3.i586
downgrade of kde4-dolphin-4.1.0-23.11.i586 to kde4-dolphin-4.0.4-18.2.i586
downgrade of kde4-ark-4.1.0-17.10.i586 to kde4-ark-4.0.4-19.1.i586
downgrade of kde4-akregator-4.1.0-29.9.i586 to kde4-akregator-4.0.80-9.3.i586
downgrade of PolicyKit-kde-0.0.svn810197-4.47.i586 to PolicyKit-kde-0.0.svn810196-5.1.i586
downgrade of kde4-kdnssd-4.1.0-15.11.i586 to kde4-kdnssd-4.0.4-19.1.i586
downgrade of kde4-kdf-4.1.0-17.10.i586 to kde4-kdf-4.0.4-19.1.i586
downgrade of kde4-kdepasswd-4.1.0-23.11.i586 to kde4-kdepasswd-4.0.4-18.2.i586
downgrade of kde4-kfind-4.1.0-23.11.i586 to kde4-kfind-4.0.4-18.2.i586
downgrade of kde4-kgamma-4.1.0-23.10.i586 to kde4-kgamma-4.0.4-14.1.i586
downgrade of kde4-kfloppy-4.1.0-17.10.i586 to kde4-kfloppy-4.0.4-19.1.i586
downgrade of kde4-kdm-4.1.0-38.6.i586 to kde4-kdm-4.0.4-24.6.i586
downgrade of kde4-kcolorchooser-4.1.0-23.10.i586 to kde4-kcolorchooser-4.0.4-14.1.i586
downgrade of kde4-kate-4.1.0-14.9.i586 to kde4-kate-4.0.4-14.1.i586
downgrade of kde4-gwenview-4.1.0-23.10.i586 to kde4-gwenview-4.0.4-14.1.i586
downgrade of kde4-kdessh-4.1.0-17.10.i586 to kde4-kdessh-4.0.4-19.1.i586
downgrade of kde4-keditbookmarks-4.1.0-23.11.i586 to kde4-keditbookmarks-4.0.4-18.2.i586
downgrade of kde4-kdialog-4.1.0-23.11.i586 to kde4-kdialog-4.0.4-18.2.i586
install ktorrent-lang-3.1.2-0.pm.1.i586 (with vendor change)
openSUSE Build Service
-->
packman.links2linux.de
downgrade of kdebase4-workspace-devel-4.1.0-38.6.i586 to kdebase4-workspace-devel-4.0.4-24.6.i586
downgrade of kdebase4-session-4.1.0-12.4.i586 to kdebase4-session-4.0.4-6.1.i586
downgrade of kdebase4-nsplugin-4.1.0-23.11.i586 to kdebase4-nsplugin-4.0.4-18.2.i586
downgrade of kde4-konqueror-plugins-debuginfo-4.1.svn838216-10.19.i586 to kde4-konqueror-plugins-debuginfo-4.0.svn767780-72.1.i586
downgrade of kde4-konqueror-plugins-debugsource-4.1.svn838216-10.19.i586 to kde4-konqueror-plugins-debugsource-4.0.svn767780-72.1.i586
downgrade of kde4-kio_sysinfo-branding-openSUSE-11.1-21.18.i586 to kde4-kio_sysinfo-branding-openSUSE-11.0-74.2.i586
downgrade of libakonadi4-4.1.0-1.11.i586 to libakonadi4-4.0.72-14.1.i586
downgrade of libkdepimlibs4-4.1.0-1.11.i586 to libkdepimlibs4-4.0.72-14.1.i586
downgrade of kdepimlibs4-4.1.0-1.11.i586 to kdepimlibs4-4.0.72-14.1.i586
downgrade of libkde4-4.1.0-26.4.i586 to libkde4-4.0.4-15.2.i586
downgrade of kdelibs4-4.1.0-26.4.i586 to kdelibs4-4.0.4-15.2.i586
downgrade of libkde4-devel-4.1.0-26.4.i586 to libkde4-devel-4.0.4-15.2.i586
downgrade of kdelibs4-core-4.1.0-26.4.i586 to kdelibs4-core-4.0.4-15.2.i586
downgrade of libkdecore4-devel-4.1.0-26.4.i586 to libkdecore4-devel-4.0.4-15.2.i586
downgrade of kdelibs4-doc-4.1.0-26.4.i586 to kdelibs4-doc-4.0.4-15.2.i586
downgrade of libkdecore4-4.1.0-26.4.i586 to libkdecore4-4.0.4-15.2.i586
downgrade of libkdegames4-4.1.0-11.12.i586 to libkdegames4-4.0.4-16.1.i586
downgrade of libkdepim4-4.1.0-29.9.i586 to libkdepim4-4.0.80-9.3.i586


#### YaST2 conflicts list END ###
This also happens when I attempt to install newer KDE4 versions of apps (for example K3B KDE4). What is interesting is that when I attempt to install it through zypper using sudo zypper install extragear-plasma it just replies with "Nothing to do".

If someone needs the repositories I have to create a second post since I will bypass the character limit