Results 1 to 4 of 4

Thread: kmail can not be loaded inside of kontact

  1. #1
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    88

    Default kmail can not be loaded inside of kontact

    Hey, Guy

    I got a problem with kontact. I am in kde4.1 32 bit and kmail, kontact are the same version. They were working together in kde4. I removed kontact (its configure files) before. I reinstalled kontact today and set kmail as the startup component for kontact. However when I start kontact, kmail starts automatically in a single window just the same as start kmail directly.

    I manually put kontact_kmailpluginEnabled=true (I thought it should be added automatically when the file is created)into kontactrc but it still does not work.

    pls advise.

    Thanks,

  2. #2
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: kmail can not be loaded inside of kontact

    chinese ys wrote:

    >
    > Hey, Guy
    >
    > I got a problem with kontact. I am in kde4.1 32 bit and kmail, kontact
    > are the same version. They were working together in kde4. I removed
    > kontact (its configure files) before. I reinstalled kontact today and
    > set kmail as the startup component for kontact. However when I start
    > kontact, kmail starts automatically in a single window just the same as
    > start kmail directly.
    >
    > I manually put kontact_kmailpluginEnabled=true (I thought it should be
    > added automatically when the file is created)into kontactrc but it
    > still does not work.
    >
    > pls advise.
    >
    > Thanks,
    >
    >


    I had this same problem 2 things 1) do you keep your KDE 4.1 install up to date with what is in the factory repo? If not then install the updates and try again. If you do keep 4.1 up to date then see if kmail is not properly closing

    pgrep kmail (or what ever meathod you preffer to get the process ID)
    kill (PID of kmail)
    then load up Kontact.
    --
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

  3. #3
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    88

    Default Re: kmail can not be loaded inside of kontact

    [QUOTE=vendion;1855734]chinese ys wrote:
    [color=blue]
    I had this same problem 2 things 1) do you keep your KDE 4.1 install up to date with what is in the factory repo? If not then install the updates and try again. If you do keep 4.1 up to date then see if kmail is not properly closing

    pgrep kmail (or what ever meathod you preffer to get the process ID)
    kill (PID of kmail)
    then load up Kontact.


    Thanks man. Problem is solved. It is because of the kmail-session process.

  4. #4
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: kmail can not be loaded inside of kontact

    chinese ys wrote:
    [color=blue]
    >
    > vendion;1855734 Wrote:
    >> chinese ys wrote:
    >>
    >> I had this same problem 2 things 1) do you keep your KDE 4.1 install up
    >> to date with what is in the factory repo? If not then install the
    >> updates and try again. If you do keep 4.1 up to date then see if kmail
    >> is not properly closing
    >>
    >> pgrep kmail (or what ever meathod you preffer to get the process ID)
    >> kill (PID of kmail)
    >> then load up Kontact.
    >>
    >>
    >> Thanks man. Problem is solved. It is because of the kmail-session
    >> process.

    >
    >

    Your welcome, and just so you know this seems to only happen if Kmail is opened as a standalone program, so every time you run just kmail check to see if it closed out completely and if not kill it.
    --
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •