Results 1 to 8 of 8

Thread: ATI X1300, Compiz, White screen

  1. #1
    matt NNTP User

    Default ATI X1300, Compiz, White screen

    I've been struggling to get compiz work on a Thinkpad T60 with an ATI X1300 video adapter in it. I've perused various posts on the subject, but have not found the answer.

    I put on a fresh install of OpenSUSE 11 and proceeded to do the one-click install of the ATI video drivers, which worked fine. But if I enable 3D Effects, my desktop goes to the classic White Screen of Death. My only way out is to switch to an alternate console, go to text mode, remove my .config/compiz directory and switch back to graphic mode. I found that just executing "compiz --replace" will immediately cause the white screen effect.

    Is there any way to get compiz to work on a T60 with an ATI X1300? Or will it just not work on this hardware? If it will, what is the secret? None of the posts I've read so far had anything that worked.

    Thanks.

    Matt

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: ATI X1300, Compiz, White screen

    It could be you need an older version of the ATI driver for the X1300.

    There are some suggestions on the ATI - openSUSE wiki page (see troubleshooting - the bit on ATI).
    I was planning on installing openSUSE 11.0 on a desktop that has an ATI X1300... Might as well do it today. Will let you know how that goes.
    Have a lot of fun!

  3. #3
    matt NNTP User

    Default Re: ATI X1300, Compiz, White screen

    Well, here is the weird thing. When I first loaded the laptop, I went into YaST and picked the ATI repository and selected the driver to install. I did not use the "one click" method (partly, because I did not know about it).

    So, I reloaded OpenSUSE 11.0 on this laptop and this time, I did the one click method and did the aticonfig -initial. Still same problem. But I noticed that when I tried to run sax2, I got errors about it not being able to access the display. I also noticed that the 3D checkbox was unchecked.

    So, I switched to text mode (init 3) and ran sax2. This time, I was able to click the 3D box and save the changes.

    Now, I went back into the gui (init 5) and tried compiz, same problem. I ran fglrxinfo, and I noticed that the driver listed was the Mesa driver (?), which I don't think is right. It should have been the ATI driver.

    So I ran sax2 again and just went through the motions of save changes (even though I changed nothing). This time, fglrxinfo showed ATI!!!

    So I launched the 3D effects app, and sure enough, it worked this time.

    I don't really understand what happened here (can someone explain?). Not sure why the ATI driver was not being used (xorg.conf problem?).

    I will say this, it is kinda slow, so in the end, I may not leave it enabled after all. Simple things like resizing a window have a 10 second delay on them and compiz takes a lot of CPU. Granted, this is a two year old laptop, but still, it has a 1.83Ghz T2400 (I think, not in front of it right now) with 3GB of RAM.

    Maybe there are other tweaks I can do? I'm afraid to change anything! This is what I always hate about using Linux on a desktop, seems like I am always having this fragile setup with video or something like that (I was hoping OpenSUSE 11.0 would change that).

    Matt

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: ATI X1300, Compiz, White screen

    Hi Matt,

    Well I've done the setup... The one-click worked like I charm.
    So no white screen there..

    The snag you've hit is what happens due to the ' aticonfig --initial ' tool not removing the previous radeon entries.
    So the xorg.conf holds both options.

    The ideal thing to do is to go into runlevel 3 (easiest by rebooting and entering ' init 3 ' as boot option and then logging into the presented console as root).
    There you can run ' sax2 -r -m 0=fglrx '. This reruns a clean X configuration using the installed ati driver.
    After running sax2 and saving the configuration reboot and all should be well.
    The wiki also states this in the troubleshooting bit.

    The X1300 is a budget video card and not build for great 3D wonders.
    There are a couple of parameters you could try. I'll post the relevant bits from my xorg.conf. You might find some entries useful (but these are also from the wiki).

    One last thing is that openSUSE 11.0 defaults to AIGLX (due to popular demand). Many ATI cards seem to run better on XGL. This could also mean smoother 3D.

    I'll post back once I've played with the options...
    Have a lot of fun!

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: ATI X1300, Compiz, White screen

    Well after some tinkering these xorg.conf settings seem to work fine (only posting the relevant lines).
    If you select the correct minimize/maximize (as other) animations it should be quite doable.
    This can be tuned using compizconfig-settings-manger.

    The thing still bugging is the CPU load that seems higher (CPU on one core is around 20-30% without doing too much).
    Guess DRI is not fully utilized?

    Code:
    <snip>
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "IgnoreABI" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "dbe"
      Load         "type1"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
      Load         "dri"
    EndSection
    
    <snip>
    
    Section "Device"
      BoardName    "Radeon X1300/X1550 Series (RV516 7183)"
      Driver       "fglrx"
      Identifier   "Device[0]"
    #added options as stated in wiki
      Option      "UseFastTLS" "2"
    #  Option      "UseInternalAGPGART" "no"
      Option      "mtrr" "off"
      Option      "no_accel" "no"
      Option      "no_dri" "no"
      Option      "EnablePrivateBackZ" "no"
      Option      "backingstore" "true"
    #end added options
      Option       "XAANoOffscreenPixmaps" "true"
    #  Option       "Capabilities" "0x00000000"
    #  Option       "OpenGLOverlay" "off"
    #  Option       "FSAAScale" "0"
    #  Option       "FSAAEnable" "on"
    #  Option       "VideoOverlay" "on"
      Option       "XaaNoOffscreenPixmaps"
      VendorName   "ATI"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
    Option       "Composite" "on"
    EndSection
    Have a lot of fun!

  6. #6
    reddie NNTP User

    Default Re: ATI X1300, Compiz, White screen

    hy, i'm tottaly noob at linux but i know that i turn on the desktop effets than after restart i have white screen. i think i have the same problem. so what should i do??? please help. thx

  7. #7

    Default Re: ATI X1300, Compiz, White screen

    This worked for me:

    Configuring graphics cards - openSUSE

    Specifically, the running the sax2 -r as root part.

  8. #8
    smily 03 NNTP User

    Default Re: ATI X1300, Compiz, White screen


    This worked for me:

    'Configuring graphics cards - openSUSE'
    (http://en.opensuse.org/Configuring_Drivers)

    Specifically, the running the sax2 -r as root part.


    --
    smily_03
    ------------------------------------------------------------------------
    smily_03's Profile: http://forums.opensuse.org/member.php?userid=21713
    View this thread: http://forums.opensuse.org/showthread.php?t=392477


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •