Results 1 to 5 of 5

Thread: How to compile CLAWS-MAIL plug-in

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default How to compile CLAWS-MAIL plug-in

    I've just tried my first ever compile, getting further than I thought before being stymied by my own ignorance. I need some advice please.

    I want to compile a plug-in for the CLAWS-MAIL email application. (the plug-in does not appear in the claws-mail extra plug-ins package). Following the install instructions available with the source package, execution of the ./configure command produced the following error information:

    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for CLAWS_MAIL... configure: error: Package requirements (claws-mail >= 3.4.0.65) were not met:

    No package 'claws-mail' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables CLAWS_MAIL_CFLAGS
    and CLAWS_MAIL_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    I understand this to mean that no file named 'claws-mail.pc' could be found in the pkg-config folder in my /usr/lib folder - and indeed this is true.

    I now (think) I understand how to set the environment variables which are quoted, so that the need for the .pc file is avoided. The problem I have is that I have no idea what values these 2 environment variables should be set to. I have read the pkg-config manual and there is no reference to them (for obvious reasons).

    Where can I find a definition of their values?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  2. #2

    Default Re: How to compile CLAWS-MAIL plug-in

    > checking for pkg-config... /usr/bin/pkg-config
    > checking pkg-config is at least version 0.9.0... yes
    > checking for CLAWS_MAIL... configure: error: Package requirements
    > (claws-mail >= 3.4.0.65) were not met:
    >
    > No package 'claws-mail' found


    Generally, when configure complains about a missing package, you need to
    install its corresponding -devel package. In this case, you'll want to
    install claws-mail-devel and claws-mail-extra-plugins-devel.


  3. #3
    gamasensei NNTP User

    Smile Re: How to compile CLAWS-MAIL plug-in

    That helped me ....
    now my plugins are configuring fine ....
    though i couldn't find claws-mail-extra-plugins-devel ....
    but unable to make ....

  4. #4
    gamasensei NNTP User

    Default Re: How to compile CLAWS-MAIL plug-in

    I finally installed claws-mail-plugins package ... and it gave me all the plugins i wanted like rss, notifier, calendar ...

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: How to compile CLAWS-MAIL plug-in

    Quote Originally Posted by gamasensei
    I finally installed claws-mail-plugins package ... and it gave me all
    the plugins i wanted like rss, notifier, calendar ...
    Hi
    You can download via the repositories, no need to compile.
    http://software.opensuse.org/search?...1&q=claws-mail

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
    up 1:11, 3 users, load average: 0.09, 0.12, 0.09
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •