Results 1 to 10 of 10

Thread: I cannot update my OpenSUSE 11

  1. #1

    Default I cannot update my OpenSUSE 11

    Hi,
    I am a new member in the OpenSUSE world. I was using Kubuntu 8.04 .

    I have installed OpenSUSE 11 on my system. Everyting working fine.I have added multimedia repositories and it also works pefect.

    now, when I go to online update, it gives me error and cannot update my system. I have attached screenshots of this error. Please guide me what to do to update my system.

    Screenshots :
    Screenshot 1
    Screenshot 2

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: I cannot update my OpenSUSE 11

    Please excuse me for answering your question with more questions, but would you be able to do the following, please?

    Can you please post the output of the command "zypper sl" in a terminal window.

    That will output your current repositories, which will make this problem more clear.

    Thank you!

    Folding@Home
    Help save lives with Folding@Home

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: I cannot update my OpenSUSE 11

    OK
    Use Yast Software - Software Management


    I see you are running Gnome but must have kde4 installed too.
    Have you added the 4.1 repo's? As the errors are related to that.

    You should be able to work thru using software management
    the libkonq4 package needs deleting and libkonq5 needs installing, but going by your errors I would say you don't have needed kde4.1 repo's in your list and libkonq5 will not be there.

    Do you want to have kde4? If so, I would suggest adding the 4.1 repo's
    or just delete kde4 and stick with gnome and maybe kde3
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: I cannot update my OpenSUSE 11

    Thanks for reply...

    I had selected to install KDE3, KDE4 and GNOME at isntallation, and all working perfectly.

    Here is my command output of "zypper sl" :
    bimal@linux-3k3r:~> zypper sl
    # | Alias | Name | Enabled | Refresh
    ---+--------------------------------------------------------------------------------------+-----------------------------------------------------+---------+--------
    1 | Index of /repositories/X11:/xfce/openSUSE_11.0 | openSUSE BuildService - XFCE | Yes | Yes
    2 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    3 | repo-debug | openSUSE-11.0-Debug | No | No
    4 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes
    5 | Index of /repositories/Virtualization:/Qemu/openSUSE_11.0 | openSUSE BuildService - Virtualization (QEMU) | Yes | Yes
    6 | Main Repository (OSS) | Main Repository (OSS) | Yes | Yes
    7 | http://www.opensuse-education.org/do.../repo/1.0/11.0 | openSUSE Education | Yes | Yes
    8 | Index of /repositories/KDE:/Backports/openSUSE_11.0 | openSUSE BuildService - KDE:Backports | Yes | Yes
    9 | Index of /repositories/server:/mail/openSUSE_11.0 | openSUSE BuildService - Mail Server | Yes | Yes
    10 | Main Repository (NON-OSS) | Main Repository (NON-OSS) | Yes | Yes
    11 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
    12 | Index of /repositories/server:/database/openSUSE_11.0 | openSUSE BuildService - Database | Yes | Yes
    13 | PK_TMP_DIR | PK_TMP_DIR | Yes | Yes
    14 | Index of /repositories/KDE:/Community/openSUSE_11.0 | openSUSE BuildService - KDE:Community | Yes | Yes
    15 | Index of /repositories/games/openSUSE_11.0 | openSUSE BuildService - Games | Yes | Yes
    16 | Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0 | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes
    17 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
    18 | repo-oss | openSUSE-11.0-Oss | Yes | No
    19 | http://www2.ati.com/suse/11.0 | ATI Repository | Yes | Yes
    20 | VideoLan Repository | VideoLan Repository | Yes | Yes
    21 | Index of /repositories/Mono:/Community/openSUSE_11.0 | openSUSE BuildService - Mono:Community | Yes | Yes
    22 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
    23 | Index of /repositories/Emulators:/Wine/openSUSE_11.0 | openSUSE BuildService - Wine CVS Builds | Yes | Yes
    24 | Index of /repositories/GNOME:/STABLE/openSUSE_11.0 | openSUSE BuildService - GNOME:STABLE | Yes | Yes
    25 | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0 | openSUSE BuildService - KDE4:Factoryesktop | Yes | Yes
    26 | Index of /distribution/11.0/repo/debug | Main Repository (DEBUG) | Yes | Yes
    27 | Packman Repository | Packman Repository | Yes | Yes
    28 | Index of /repositories/X11:/XGL/openSUSE_11.0 | openSUSE BuildService - X11GL | Yes | Yes
    29 | Index of /repositories/server:/php/openSUSE_11.0 | openSUSE BuildService - PHP | Yes | Yes
    30 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0 | openSUSE BuildService - OpenOffice.org | Yes | Yes
    31 | Index of /repositories/drivers:/webcam/openSUSE_11.0_Update | openSUSE BuildService - Drivers for webcams | Yes | Yes
    32 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes
    33 | Index of /repositories/GNOME:/Community/openSUSE_11.0 | openSUSE BuildService - GNOME:Community | Yes | Yes
    bimal@linux-3k3r:~>

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: I cannot update my OpenSUSE 11

    libkonq4 package needs deleting and libkonq5 needs installing
    did you try this?

    How experienced are you?
    You have a plethora of repo's if you are new to Linux!
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: I cannot update my OpenSUSE 11

    I have added all this repositories via the HowToForge website (Link: The Perfect Desktop - OpenSUSE 11 (GNOME) - Page 3 | HowtoForge - Linux Howtos and Tutorials )

    You say.. what do I do? I am a new in OpenSUSE.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: I cannot update my OpenSUSE 11

    Going back to screenshots and the package errors:

    As I have said use Software Management
    mark libkonq4 to delete and libkonq5 to install/update

    I suspect you have some older 4.0.4 plasmoids that are causing errors

    I suggest you filter by repo and go to 4.1 and choose update all unconditionally
    see what errors you get then
    you can always exit and start again - trying different options

    If you want more plasmoids for kde4.1 add this repo:
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: I cannot update my OpenSUSE 11

    Quote Originally Posted by caf4926 View Post
    Going back to screenshots and the package errors:

    As I have said use Software Management
    mark libkonq4 to delete and libkonq5 to install/update

    I suspect you have some older 4.0.4 plasmoids that are causing errors

    I suggest you filter by repo and go to 4.1 and choose update all unconditionally
    see what errors you get then
    you can always exit and start again - trying different options

    If you want more plasmoids for kde4.1 add this repo:
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop
    Thank you for this.
    Sorry... I still haven't done as you say. but.. I has loggedin in kde4 and do zypper up command. Now the update is started.

    I will reply here if it fails or anything goes wrong.

    Thank you

  9. #9

    Default Re: I cannot update my OpenSUSE 11

    @ caf4926
    I have added your repo and done command zypper up but still some problems.

    Is there any command to fully update my system?

    I am currently in KDE4.

    When I do zypper up command, I got this massage :
    linux-3k3r:~ # zypper up
    Downloading repository 'PK_TMP_DIR' metadata [done]
    Reading installed packages...
    Nothing to do.
    linux-3k3r:~ #
    But still I am with KDE 4.0.4. I want KDE 4.1

    and also, when I start OpenSUSE Updater, it gives me a list to updates. (see screenshots)

    Is there the zyper up command can only install security patches only ?

    I want a single command to fully update my system. Because the OpenSUSE Updater is not working. Here I attached screenshot of what it displays. At the screenshot-2, I had clicked SelectAll Packages and then clicked Install and give my password. But after 10-20 seconds it was doing nothing. Again I click the OpenSUSE Updater and again I click SelectAll Packages and again I click Insall, the window ask me password I give the password and again nothing works.

    Attachments :
    Screenshot 1
    Screenshot 2

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: I cannot update my OpenSUSE 11

    Have you tried Yast - Software - Software Management??

    In there Filter by Repositories - Updates
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •