Hi there,
Every once in a while (a couple of times a day) my window manager crashes, taking away every window's titlebar and i get a kde message telling me the window manager had crashed. I get following backtrace:
Code:
Application: KDE Window Decorator (kde4-window-decorator), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb55aa6f0 (LWP 29050)]
[New Thread 0xb3eb4b90 (LWP 29655)]
[KCrash handler]
#6  0xb7459abb in QProcess::setProcessState () from /usr/lib/libQtCore.so.4
#7  0xb745a289 in ?? () from /usr/lib/libQtCore.so.4
#8  0xb745f356 in ?? () from /usr/lib/libQtCore.so.4
#9  0xb7496d45 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb7459e8e in QProcess::waitForFinished () from /usr/lib/libQtCore.so.4
#11 0xb745a4be in QProcess::~QProcess () from /usr/lib/libQtCore.so.4
#12 0x0805fe12 in KWD::Window::~Window ()
#13 0x0805a68d in KWD::Decorator::handleWindowRemoved ()
#14 0x08050f64 in KWD::Decorator::qt_metacall ()
#15 0xb74c445a in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#16 0xb74c49d2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#17 0xb6d42283 in KWindowSystem::windowRemoved () from /usr/lib/libkdeui.so.5
#18 0xb6d44b1c in ?? () from /usr/lib/libkdeui.so.5
#19 0xb6d53b43 in NETRootInfo::update () from /usr/lib/libkdeui.so.5
#20 0xb6d53f2f in NETRootInfo::event () from /usr/lib/libkdeui.so.5
#21 0xb6d44ddd in ?? () from /usr/lib/libkdeui.so.5
#22 0xb6c1e9a9 in KApplication::x11EventFilter () from /usr/lib/libkdeui.so.5
#23 0x080564df in KWD::Decorator::x11EventFilter ()
#24 0xb7a0da1e in ?? () from /usr/lib/libQtGui.so.4
#25 0xb7a1a15b in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#26 0xb7a413ae in ?? () from /usr/lib/libQtGui.so.4
#27 0xb74b133a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#28 0xb74b14fa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#29 0xb74b36dd in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#30 0xb79b6d47 in QApplication::exec () from /usr/lib/libQtGui.so.4
#31 0x080524cd in main ()
#0  0xffffe430 in __kernel_vsyscall ()
To get my titlebars back, I just open the "Desktp Effects" CompizSettings and hit the Checkmark. That's bringing everything back.
Can anyone tell me why this keeps happening? It's kind of annoying... and is anyone experiencing the same problem?
Btw. I'm using OSS11 with KDE 4.1.1.

Thanks,
Ron