Results 1 to 3 of 3

Thread: Problem with fonts

  1. #1
    Maxorata NNTP User

    Default Problem with fonts

    Hi,
    I've installed a set of fonts (it's called Funfonts) which may be very neat and cool, but they replaced my applications' default fonts.
    Openoffice toolbars are almost unreadable and that was the case for most of my applications, but I managed to fix all of them, except for OpenOffice. No matter what I do, it still continues using those ugly fonts. I was thinking about reinstalling Suse 11.0 again, but there is probably a better way to solve this problem, so I hope that some of you, who knows more than I do, can help me get rid of these fonts, or at least force Openoffice to use the ones that I like. I'll never install third party fonts again.
    Thanks in advance for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Problem with fonts

    Maxorata wrote:

    >
    > Hi,
    > I've installed a set of fonts (it's called Funfonts) which may be very
    > neat and cool, but they replaced my applications' default fonts.
    > Openoffice toolbars are almost unreadable and that was the case for
    > most of my applications, but I managed to fix all of them, except for
    > OpenOffice. No matter what I do, it still continues using those ugly
    > fonts. I was thinking about reinstalling Suse 11.0 again, but there is
    > probably a better way to solve this problem, so I hope that some of
    > you, who knows more than I do, can help me get rid of these fonts, or
    > at least force Openoffice to use the ones that I like. I'll never
    > install third party fonts again.
    > Thanks in advance for your help.
    >
    >


    Openoffice uses Gtk for it's widgets and fonts and such.

    The 'personal settings' (Desktop Control Panel thingy) has a page where you
    can specify the default GTK fonts to use (at least in 11.0, 10.3 might
    also)

    Under 'Appearance and Themes' -> 'GTK Styles and Fonts', middle of page.

    Might help.

    Loni

    --
    L R Nix
    lornix@lornix.com

  3. #3

    Default Re: Problem with fonts

    Openoffice.org uses cairo fonts to enable font rendering in them. What you need are a set of cairo fonts that have subpixel hinting enabled in them. Opensuse 11.0 onwards has disabled subpixel hinting in their cairo libraries and thus the horrible font rendering.

    You have 2 options to enable a subpixel-rendered cairo patch:

    1. Install an older cairo package for Opensuse 10.3...force the installation by dropping to the shell mode and remove cairo by rpm -e cairo-* --nodeps. And then install the new one by rpm -ivh cairo-*. You the need to lock this version through Yast/zypper.

    2. Obtain another package, which is newer than 10.3 and you can find detailed instructions in my reply at:- /dev/loki: Freetype2 packages with subpixel hinting.

    I am able to get really good Openoffice.org font rendering on my KDE 3.5.9 system by using the freetype2 packages at opensuse-community.org/subpixel and the cairo2 rpms from the above links.

    Hope this helps!

    -Anshul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •