Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Firmware problem.

  1. #1

    Default Firmware problem.

    I need firmware. But what kind?

    I have this output

    usb 2-5. 2: new high speed USB deviece using ehci_hcd and adress 5
    usb 2-5. 2: configuration #1 chosen from 1 choice
    usb 2-5. 2: New USB device found, idVendor=13d3, idProduct=3247
    usb 2-5. 2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 2-5. 2: Product: 802.11 n WLAN
    usb 2-5. 2: Manufacturer: Ralink
    usb 2-5. 2: SerialNumber: 1.0

    I have found a site, but I dunno with firmware I've to download

    Ralink Driver Download -- Open Drivers

    thnx in advance.

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Firmware problem.

    could try the drivers here Ralink Technology: Linux personally wouldn't trust that site you gave, too many pop-ups trying to get through. Just select your device & download the appropriate file, unzip/tar the file, read the read-me inside as it will contain instructions on what to do

    Andy

  3. #3

    Default Re: Firmware problem.

    I've read the Readme, but it's rather confusing

    for example, it says:

    $tar -xvzf DPB_RT2860_Linux_STA_x.x.x.x.tgz


    I Copied/Pasted that into Konsole, but it says that the command is not found.

    What do I wrong?

  4. #4
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Firmware problem.

    to unzip/tar a file, try right-clicking it & from the extract menu,select extract to here. for more info on using tarfiles,etc, have a look at my own little reminder i have Stuntmanandys openSUSE/SuSE forum • View topic - Install Tar or bzipped files

    Andy

  5. #5

    Default Re: Firmware problem.

    Thanks for the tutorial

    Still, I've problems. I cannot download gcc and gcc++, simply because the target system doesn't have any Internet-connection right now. Mabey they are already on the system, because I've downloaded the newest SUSE, but I dunno.

    When I do this step:

    5 ) type ./configure and press enter, let it do it's thing.

    It says that the file doesn't exist.

  6. #6
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Firmware problem.

    gcc/gcc++ is on the install dvd, along with any other bits you may need. as for 5 ) it may not need that, may just need to run make. As i say, more important is the info contained in the read-me file

    Andy

  7. #7

    Default Re: Firmware problem.

    The info is very confusing. Mabey a more skilled person, like you, could take a look at it?

    * README
    *
    * Ralink Tech Inc.
    *
    * Ralink Technology: Home
    *

    =======================================================================
    ModelName:
    ===========
    RT2860 Wireless Lan Linux Driver


    =======================================================================
    Driver lName:
    =============
    rt2860.o/rt2860.ko


    =======================================================================
    Supporting Kernel:
    ===================
    linux kernel 2.4 and 2.6 series.
    Tested in Redhat 7.3 or later.


    =======================================================================
    Description:
    =============
    This is a linux device driver for Ralink RT2860 ABGN WLAN Card.


    =======================================================================
    Contents:
    =============
    Makefile : Makefile
    *.c : c files
    *.h : header files


    =======================================================================
    Features:
    ==========
    This driver implements basic IEEE802.11. Infrastructure and adhoc mode with
    open or shared or WPA-PSK or WPA2-PSK authentication method.
    NONE, WEP, TKIP and AES encryption.


    =======================================================================
    Build Instructions:
    ====================

    1> $tar -xvzf DPB_RT2860_Linux_STA_x.x.x.x.tgz
    go to "./DPB_RT2860_Linux_STA_x.x.x.x" directory.

    2> In Makefile
    set the "MODE = STA" in Makefile and chose the TARGET to Linux by set "TARGET = LINUX"
    define the linux kernel source include file path LINUX_SRC
    modify to meet your need.

    3> In os/linux/config.mk
    define the GCC and LD of the target machine
    define the compiler flags CFLAGS
    modify to meet your need.
    ** Build for being controlled by NetworkManager or wpa_supplicant wext functions
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
    => #>cd wpa_supplicant-x.x
    => #>./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d
    ** Build for being controlled by WpaSupplicant with Ralink Driver
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
    => #>cd wpa_supplicant-0.5.7
    => #>./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d

    4> $make # compile driver source code

    5> $cp RT2860STA.dat /etc/Wireless/RT2860STA/RT2860STA.dat
    # !!!check if it is a binary file before loading !!!

    6> load driver
    #[kernel 2.4]
    # $/sbin/insmod rt2860sta.o
    # $/sbin/ifconfig ra0 inet YOUR_IP up

    #[kernel 2.6]
    # $/sbin/insmod rt2860sta.ko
    # $/sbin/ifconfig ra0 inet YOUR_IP up

    7> unload driver
    $/sbin/ifconfig ra0 down
    $/sbin/rmmod rt2860sta

    =======================================================================
    CONFIGURATION:
    ====================
    RT2860 driver can be configured via following interfaces,
    i.e. (i)"iwconfig" command, (ii)"iwpriv" command, (iii) configuration file

    i) iwconfig comes with kernel.
    ii) iwpriv usage, please refer to file "iwpriv_usage.txt" for details.
    iii)modify configuration file "RT2860STA.dat" in /etc/Wireless/RT2860STA/RT2860STA.dat.

    Configuration File : RT2860STA.dat
    ---------------------------------------
    # Copy this file to /etc/Wireless/RT2860STA/RT2860STA.dat
    # This file is a binary file and will be read on loading rt.o module.
    #
    # Use "vi -b rt61sta.dat" to modify settings according to your need.
    #
    # 1.) set NetworkType to "Adhoc" for using Adhoc-mode, otherwise using Infrastructure
    # 2.) set Channel to "0" for auto-select on Infrastructure mode
    # 3.) set SSID for connecting to your Accss-point.
    # 4.) AuthMode can be "WEPAUTO", "OPEN", "SHARED", "WPAPSK", "WPA2PSK", "WPANONE"
    # 5.) EncrypType can be "NONE", "WEP", "TKIP", "AES"
    # for more information refer to the Readme file.
    #
    #The word of "Default" must not be removed
    Default
    CountryRegion=5
    CountryRegionABand=7
    CountryCode=
    SSID=Dennis2860AP
    NetworkType=Infra
    WirelessMode=9
    Channel=0
    BeaconPeriod=100
    TxPower=100
    BGProtection=0
    TxPreamble=0
    RTSThreshold=2347
    FragThreshold=2346
    TxBurst=1
    WmmCapable=0
    AckPolicy=0;0;0;0
    AuthMode=OPEN
    EncrypType=NONE
    WPAPSK=
    DefaultKeyID=1
    Key1Type=0
    Key1Str=
    Key2Type=0
    Key2Str=
    Key3Type=0
    Key3Str=
    Key4Type=0
    Key4Str=
    PSMode=CAM
    FastRoaming=0
    RoamThreshold=70
    HT_RDG=1
    HT_EXTCHA=0
    HT_OpMode=1
    HT_MpduDensity=4
    HT_BW=1
    HT_AutoBA=1
    HT_BADecline=0
    HT_AMSDU=0
    HT_BAWinSize=64
    HT_GI=1
    HT_MCS=33
    HT_MIMOPSMode=3
    IEEE80211H=0
    TGnWifiTest=0
    WirelessEvent=0

    -----------------------------------------------
    *NOTE:
    WMM parameters
    WmmCapable Set it as 1 to turn on WMM Qos support
    AckPolicy1~4 Ack policy which support normal Ack or no Ack
    (AC_BK, AC_BE, AC_VI, AC_VO)

    All WMM parameters do not support iwpriv command but ¡¥WmmCapable¡¦¡¦,
    please store all parameter to RT2860STA.dat, and restart driver.

    -----------------------------------------------
    syntax is 'Param'='Value' and describes below.

    @> CountryRegion=value
    value
    0: use 1 ~ 11 Channel
    1: use 1 ~ 13 Channel
    2: use 10 ~ 11 Channel
    3: use 10 ~ 13 Channel
    4: use 14 Channel
    5: use 1 ~ 14 Channel
    6: use 3 ~ 9 Channel
    7: use 5 ~ 13 Channel
    31: use 1 ~ 14 Channel (ch1-11:active scan, ch12-14 passive scan)

    @> CountryRegionABand=value
    value
    0: use 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165 Channel
    1: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140 Channel
    2: use 36, 40, 44, 48, 52, 56, 60, 64 Channel
    3: use 52, 56, 60, 64, 149, 153, 157, 161 Channel
    4: use 149, 153, 157, 161, 165 Channel
    5: use 149, 153, 157, 161 Channel
    6: use 36, 40, 44, 48 Channel
    7: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165 Channel
    8: use 52, 56, 60, 64 Channel
    9: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 149, 153, 157, 161, 165 Channel
    10: use 36, 40, 44, 48, 149, 153, 157, 161, 165 Channel
    11: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 149, 153, 157, 161 Channel

    @> CountryCode=value
    value
    AG, AR, AW, AU, AT, BS, BB, BM, BR, BE, BG, CA, KY, CL, CN, CO, CR, CY, CZ, DK, DO, EC, SV, FI, FR, DE,
    GR, GU, GT, HT, HN, HK, HU, IS, IN, ID, IE, IL, IT, JP, JO, LV, LI, LT, LU, MY, MT, MA, MX, NL, NZ, NO,
    PE, PT, PL, RO, RU, SA, CS, SG, SK, SI, ZA, KR, ES, SE, CH, TW, TR, GB, UA, AE, US, VE
    "" => using default setting: 2.4 G - ch 1~11; 5G - ch 52~64, 100~140, 149~165

    @> SSID=value
    value
    0~z, 1~32 ascii characters.

    @> WirelessMode=value
    value
    0: legacy 11b/g mixed
    1: legacy 11B only
    2: legacy 11A only //Not support in RfIcType=1(id=RFIC_5225) and RfIcType=2(id=RFIC_5325)
    3: legacy 11a/b/g mixed //Not support in RfIcType=1(id=RFIC_5225) and RfIcType=2(id=RFIC_5325)
    4: legacy 11G only
    5: 11ABGN mixed
    6: 11N only
    7: 11GN mixed
    8: 11AN mixed
    9: 11BGN mixed
    10: 11AGN mixed

    @> Channel=value
    value
    depends on CountryRegion or CountryRegionABand

    @> BGProtection=value
    value
    0: Auto
    1: Always on
    2: Always off

    @> TxPreamble=value
    value
    0reamble Long
    1reamble Short
    2:Auto

    @> RTSThreshold=value
    value
    1~2347

    @> FragThreshold=value
    value
    256~2346

    @> TxBurst=value
    value
    0: Disable
    1: Enable

    @> NetworkType=value
    value
    Infra: infrastructure mode
    Adhoc: adhoc mode
    I made it shorter. Please say if you want the other part.

    All help is welcome

  8. #8
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Firmware problem.

    untar the file as i said in an earlier post. make sure you know where you untarred the file.
    1 )open a console
    2 ) cd to where the folder/files are
    3 ) type make & press enter,let it do it's stuff.
    4 ) once done su to root
    5 ) type make install,this should install everything necessary.
    6 ) copy the list of things they say to /etc/wireless.
    7 ) configure the wireless as they stated
    see if that helps

    Andy

  9. #9

    Default Re: Firmware problem.

    I still got a problem at step 3.

    Ok, I'll write down every exact thing I do:

    1- I open Konsole
    2- I type cd /home/Kooiman/, where the unpacked files are.
    3- I type make

    Result: unknown command

  10. #10
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Firmware problem.

    looks like make is not installed, it's on the install media. Ensure you have make,gcc/gcc++,kernel sources/headers installed as a basic for compiling

    Andy

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •