Results 1 to 9 of 9

Thread: How to make stubborn atheros ar242 (5211) work - solution

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Talking How to make stubborn atheros ar242 (5211) work - solution

    This wireless on asus laptop is a real pain in the neck. But not more stubborn then myself.

    I managed to configure it with MadWiFi...
    actually, ndiswrapper helped. Here how it was...

    with ath_pci alone, yast could not configure the card. Reason unknown. With ndiswrapper it could, but system was freezing within 2 minutes.

    So, I put up ndiswrapper, configured the card, set to manual startup, configured wpa_supplicant, rebooted. Wireless was now working, but prone to freezing the system.

    Then I blacklisted ndiswrapper, unloaded module, recompiled madwifi, modprobbed ath_pci, gone to Yast and in kernel, I forced ath_pci module loading.

    Voila!!!

  2. #2
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Thumbs down Re: How to make stubborn atheros ar242 (5211) work - solutio

    I am terribly sorry. This post was premature overjoy.
    ndiswrapper was still left in memory and yes, still freezes the system.

    I cant make it work with madwifi with no chance at all no matter what I try.

    Nothing is left for me except to wait for better days and use window$ when I need wireless...

    ****!

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: How to make stubborn atheros ar242 (5211) work - solution

    beli0135 wrote:

    >
    > I am terribly sorry. This post was premature overjoy.
    > ndiswrapper was still left in memory and yes, still freezes the
    > system.
    >
    > I cant make it work with madwifi with no chance at all no matter what I
    > try.
    >
    > Nothing is left for me except to wait for better days and use window$
    > when I need wireless...
    >
    > ****!
    >
    >


    Did you uninstall ndiswrapper? it may still be loaded through some arcane
    magic. And reboot after uninstalling it, so as to have a 'really' clean
    slate.

    Loni
    --
    L R Nix
    lornix@lornix.com

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: How to make stubborn atheros ar242 (5211) work - solutio

    Issue resolved. Solution lies in installing latest snapshot of madwifi from snapshot directory. 'stable' version does not work.
    After that, everything gone smootly.

  5. #5
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: How to make stubborn atheros ar242 (5211) work - solution

    On Fri, 15 Aug 2008 12:26:03 GMT
    beli0135 <beli0135@no-mx.forums.opensuse.org> wrote:

    >
    > Issue resolved. Solution lies in installing latest snapshot of madwifi
    > from snapshot directory. 'stable' version does not work.
    > After that, everything gone smootly.
    >
    >


    Congrats!

    --
    L R Nix
    lornix@lornix.com


  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: How to make stubborn atheros ar242 (5211) work - solutio

    Thanks!
    I will make sure to post solution somewhere else, so word spreads out.

  7. #7
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: How to make stubborn atheros ar242 (5211) work - solutio

    Funny...
    Yesterday I tried BackTrack 3 live linux.
    In first line after login, I typed "modprobe ath_pci" and wireless started to work full power.

    ... and how much pain I had to make it work here in openSUSE 11.0

    really funny...

  8. #8
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: How to make stubborn atheros ar242 (5211) work - solution

    On Sat, 23 Aug 2008 15:36:01 GMT
    beli0135 <beli0135@no-mx.forums.opensuse.org> wrote:

    >
    > Funny...
    > Yesterday I tried BackTrack 3 live linux.
    > In first line after login, I typed "modprobe ath_pci" and wireless
    > started to work full power.
    >
    > .. and how much pain I had to make it work here in openSUSE 11.0
    >
    > really funny...
    >
    >


    Alas, there are restrictions on which firmware and drivers OpenSUSE can
    distribute with their operating system. Search for Broadcom, Atheros,
    NVIDIA, ATI... I imagine there's more.

    OpenSUSE tends to make it easy... and doesn't include them. ALL of them are
    available through easily added repositories and packages. Information
    detailing installation can be found by searching the OpenSUSE Wiki and these
    forum.

    Backtrack is a much smaller distribution and serves a particular purpose and
    is built to facilitate that. I find it very handy myself. So they included
    what drivers they could. You'll notice they don't support full 3D graphics,
    but only enough to get the machine usable for its intended purpose. Each
    distribution is different.

    Starting with openSUSE 11.0, there was an OSS Atheros driver included with
    the kernel named 'ath5k'. Initially, it wasn't mature enough to handle our
    cards as needed, so it's been recommended to disable it for the moment, and
    install the easily obtainable MadWifi drivers... which quite literally... work
    immediately upon installation IF YOU DISABLE THE ATH5K DRIVER FIRST. Yes,
    this is probably confusing to users.

    I've written some step-by-step instructions on how to install the MadWifi
    drivers in OpenSUSE 11.0...

    =================8<==========>8===================
    Steps to install MadWifi driver for Atheros Wireless:

    (This is given as performed on a KDE 3.5.9 installation.
    The applications *should* be similar for Gnome and KDE 4.x)

    1. Blacklist the 'ath5k' driver
    From a terminal:
    su - root
    {supply password}
    echo "blacklist ath5k" > /etc/modprobe.d/ath5k
    uname -r
    {remember whether it says '-default' or '-pae'}

    2. Add the MadWifi Repository and software
    Start the YaST Setup Program
    -> Software Management
    -> click on 'Repositories' (top menu)
    -> click on 'Repository Manager'
    -> click on 'Add' button, towards bottom
    -> verify 'Specify URL' selected
    -> url is 'http://madwifi.org/suse/11.0'
    -> enter a name, 'Madwifi' works
    -> click on 'Next', returns to list of current repos
    -> click on 'Ok', returns to software installation page
    -> click in Search box, enter 'madwifi', click 'Search'
    -> depending on remembered entry from above:
    -> select either 'madwifi-kmp-default'
    or 'madwifi-kmp-pae'
    -> click on 'Accept', bottom right
    If it pops up a window saying
    'these packages were needed too', say 'Ok'
    -> wait briefly while drivers are downloaded and installed
    -> exit from 'YaST control center'

    3. Reboot

    4. Using YaST -> Network Devices -> Network Settings
    -> On the 'Global Settings' tab, choose Traditional
    or network-manager mode for control
    -> For Traditional, set up your wireless nic on the
    'Overview' tab.
    -> For network-manager mode, setup is done on your
    Desktop, via the 'knetwork-manager' application
    in the tray next to the clock.

    5. Some Caveats....
    knetwork-manager (the green globe) has been known to be
    'reluctant' to automatically connect. This should be
    resolved soon, but you may need to manually choose a
    network to connect to at startup for now.
    =================8<==========>8===================

    There's a very good chance that your Atheros wireless will work if you'll
    follow these instructions.

    Loni

    --
    L R Nix
    lornix@lornix.com


  9. #9
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: How to make stubborn atheros ar242 (5211) work - solutio

    I must add that for me, or my card, Madwifi from repository didn't worked either. I needed a latest snapshot and then started to work properly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •