Results 1 to 4 of 4

Thread: sauerbraten can not run

  1. #1

    Default sauerbraten can not run

    Opensuse 11 bit
    i install sauerbraten form packman
    but can not start:

    init: sdl
    init: enet
    init: video: mode
    init: video: misc
    init: gl
    Renderer: GeForce 8600M GT/PCI/SSE2 (NVIDIA Corporation)
    Driver: 2.1.2 NVIDIA 173.14.09
    Rendering using the OpenGL 1.5 GLSL shader path.
    could not load texture data/notexture.png
    could not find core textures


    i have install libpng both 64bit and 32 bit!
    how can i solove this problem?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: sauerbraten can not run

    Hmmm... I had the same problem, but managed to solve it. I should be able to help you.

    Do you have both the sauerbraten and sauerbraten-data packages installed (Packman repo).

    Do you have the ~/.sauerbraten directory present?

    In my case, I didn't originally have the data package installed. Even after I did, it still wouldn't start from K Menu. After looking at the sauerbraten.sh script in /usr/bin, I realised that I needed to delete the .sauerbraten directory. The script then recreates it with links to the /usr/games/sauerbraten and usr/share/games/sauerbraten directories, as required. However if .sauerbraten exists already, it will not add links, so in my case the data packages were not being included. See script below:

    linux:/usr/bin # cat sauerbraten.sh
    #!/bin/sh
    CUBE_DIR=$HOME/.sauerbraten
    if [ ! -d $CUBE_DIR ]; then
    mkdir -p $CUBE_DIR
    cd $CUBE_DIR
    ln -s /usr/games/sauerbraten/* .
    ln -s /usr/share/games/sauerbraten/* .
    rm servers.cfg 2> /dev/null
    fi
    cd $CUBE_DIR
    exec ./sauer_client $*
    I could have done this housekeeping manually. I stumbled on the problem after executing ./sauer_client from a console with success.

    Hope it gets you sorted.

  3. #3
    Join Date
    Jun 2008
    Location
    Bandung, Indonesia
    Posts
    64

    Default Re: sauerbraten can not run

    @deano_ferrari
    I have the same problem, and removing the .sauerbraten directory and re-run the application fix it, thank you so much!
    Linux user: #448598
    openSUSE Indonesia: http://opensuse.or.id/

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: sauerbraten can not run

    Happy gaming!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •