Results 1 to 3 of 3

Thread: new zypper on openSUSE 10.3

  1. #1
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default new zypper on openSUSE 10.3

    Long ago I installed zypper 0.11.4 from the zypper backport repository. All worked fine. Since a few weeks I try to upgrade to zypper 0.12 but I always fail due to dependency issues.
    Code:
    #### YaST2 conflicts list - generated 2008-08-04 21:05:53 ####
    
    nothing provides satsolver-tools = 0.10.0 needed by libzypp-5.0.2-2.3.i586
    
        [ ] libzypp-5.0.2-2.3.i586 nicht installieren
    
    
    nothing provides satsolver-tools = 0.10.0 needed by libzypp-5.0.2-2.3.i586
    
        [ ] zypper-0.12.0-2.1.i586 nicht installieren
    
    
    nothing provides libzypp.so.424 needed by yast2-pkg-bindings-2.17.0-2.1.i586
    
        [ ] satsolver-tools-0.10.2-6.2.i586 nicht installieren
        [ ] Following actions will be done:
    downgrade of yast2-pkg-bindings-2.16.38-2.2.i586 to yast2-pkg-bindings-2.15.51-4.i586
    deinstallation of yast2-ncurses-pkg-2.16.13-2.2.i586
    deinstallation of yast2-qt-pkg-2.16.46-2.6.i586
    downgrade of yast2-online-update-2.17.0-2.2.noarch to yast2-online-update-2.15.24-0.1.noarch
    downgrade of yast2-ntp-client-2.17.0-2.3.noarch to yast2-ntp-client-2.15.12-7.noarch
    
    
    #### YaST2 conflicts list END ###
    OK, satsolver-tools = 0.10.0 is demanded but 0.10.2 is available. Same with libzypp where libzypp.so.424 is demanded but libzypp.so.500 is provided.
    Can anyone tell me how to (I) bypass these dependency issues and (II) report dependency problems to the packagers?

  2. #2
    Join Date
    Jun 2008
    Location
    Cluj-Napoca, Romania
    Posts
    8

    Default Re: new zypper on openSUSE 10.3

    I second that. Having the same problems here...
    Unsigned! 0.o

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: new zypper on openSUSE 10.3

    supertimorplusfort wrote:
    > Long ago I installed zypper 0.11.4. All worked fine. Since a few weeks I
    > try to upgrade to zypper 0.12


    Q: Do the expected benefits of 'upgrading' outweigh the frustrations
    encountered in trying?

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •