Results 1 to 7 of 7

Thread: Run Command Xfce Startup

  1. #1

    Default Run Command Xfce Startup

    Running Suse 11 and Xfce4

    To improve Nvidia 2d performance I edited my xorg.conf file as specified by Nvidia. I now need these commands to run every time I start the X server:

    nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    nvidia-settings -a InitialPixmapPlacement=2

    Nvidia suggests putting it in .xinitrc, .kderc or .gnomerc. I don't have any of those files.

    How can I run those commands every time my computer starts?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,485
    Blog Entries
    15

    Default Re: Run Command Xfce Startup

    Quote Originally Posted by mooreted
    To improve Nvidia 2d performance I edited my xorg.conf file as specified
    by Nvidia. I now need these commands to run every time I start the X
    server:

    nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    nvidia-settings -a InitialPixmapPlacement=2

    Nvidia suggests putting it in .xinitrc, .kderc or .gnomerc. I don't
    have any of those files.

    How can I run those commands every time my computer starts?
    Hi
    They should be fine to run in /etc/init.d/boot.local

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 8 days 1:35, 1 user, load average: 0.14, 0.13, 0.14
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3

    Default Re: Run Command Xfce Startup

    Nope,that didn't do it. I think boot.local runs before the driver. I need the command to run when X starts.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,485
    Blog Entries
    15

    Default Re: Run Command Xfce Startup

    Quote Originally Posted by mooreted
    Nope,that didn't do it. I think boot.local runs before the driver. I
    need the command to run when X starts.
    Hi
    OK, so is it at runlevel 5, or when the user logs in to the DE?

    If runlevel 5, then use the /etc/init.d/skeleton file to create the
    appropriate startup.

    Else create a script of the two commands the use Xfce4 menu > Settings >
    Xfce 4 Autostarted Applications and add it there.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 8 days 2:35, 1 user, load average: 0.16, 0.20, 0.17
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5
    Join Date
    Jul 2008
    Location
    Voorhout, Netherlands
    Posts
    262

    Default Re: Run Command Xfce Startup

    mooreted wrote:
    > To improve Nvidia 2d performance I edited my xorg.conf file as specified
    > by Nvidia. I now need these commands to run every time I start the X
    > server:
    >
    > nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    > nvidia-settings -a InitialPixmapPlacement=2
    >
    > Nvidia suggests putting it in .xinitrc, .kderc or .gnomerc. I don't
    > have any of those files.
    >
    > How can I run those commands every time my computer starts?


    You can always make the file .xinitrc (or any of the other files).
    echo "nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    nvidia-settings -a InitialPixmapPlacement=2" > ~/.xinitrc

  6. #6

    Default Re: Run Command Xfce Startup

    Quote Originally Posted by malcolmlewis View Post
    Hi
    OK, so is it at runlevel 5, or when the user logs in to the DE?

    If runlevel 5, then use the /etc/init.d/skeleton file to create the
    appropriate startup.

    Else create a script of the two commands the use Xfce4 menu > Settings >
    Xfce 4 Autostarted Applications and add it there.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 8 days 2:35, 1 user, load average: 0.16, 0.20, 0.17
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12
    Yeah, RL5 should work. Thanks, I appreciate it.

  7. #7

    Default Re: Run Command Xfce Startup

    Found an easy way to do it. Created a script for the Nvidia 2D tweak then ran "xfce4-autostart-editor" and added it. Works great.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •