Results 1 to 7 of 7

Thread: How I got Compiz-Fusion and Emerald to launch on start

  1. #1
    xVx-01 NNTP User

    Default How I got Compiz-Fusion and Emerald to launch on start

    Compiz-fusion comes on the OpenSuse 11 cd and I'd heard great things about it so I decided to try it out. Playing around with it and trying out new settings was no problem --everything worked great. But when I tried to get it to load automatically on startup, I started having troubles.

    Did a little research and found that Compiz-Fusion usually launches with something called the Fusion Icon, a system tray icon program not included on the Suse 11 cd. I eventually found a download for it. You can access it here:
    Software.openSUSE.org

    The install of Fusion Icon went great. Once it was installed it automatically ran on startup, and started Compiz right away. I was able to set emerald as my default window decorator and download pretty emerald themes from KDE-Look.org. I could easily enter the Compiz settings manager and the Emerald themes manager very conveniently.

    However there was a problem. Upon restarting my Xserver (I'm using KDE 3.whatever) the default KDE window decorations appeared. But when I went into the Fusion Icon menu emerald was still checked as the window decorator! I was able to start emerald easily by switching to another decorator then switching back. But how to get it to load on startup?

    So I did a little research and learned that it seemed like Compiz was loading, then Emerald was loading, THEN the KDE window decorator was loading, bumping the Emerald default out of comission. One of the solves I read on this problem suggested changing the order of the startup apps from Emerald starting first to KDE window decorator starting first. Then when Emerald started it would take priority. Easy as pie right? Well the only problem was that the way to do this was through System -> Preferences -> More Preferences -> Sessions ->Startup Programs in Gnome. The problem? There is no KDE menu that matches this description, nor could I find any options in KDE to change the order or the contents of the startup programs.

    Well after being frustrated for a while and following some dead ends, I finally found this patch on a Ubuntu forum.

    How to start Emerald with Compiz-Fusion - Ubuntu Forums

    sudo gedit /usr/bin/compiz

    change line 238 and 240
    from "/usr/bin/gtk-window-decorator" to "/usr/bin/emerald"

    save file.

    This is an extract of the file:

    # start the gtk-window-decorator if present
    if [ -x /usr/bin/gtk-window-decorator ] && [ -n "$GNOME_DESKTOP_SESSION_ID" ]; then
    /usr/bin/emerald --replace &
    elif [ -x /usr/bin/kde-window-decorator ] && [ -n "$KDE_FULL_SESSION" ]; then
    /usr/bin/emerald --replace &
    FALLBACKWM="/usr/bin/kwin"
    fi

    To check the patch run Alt+F2 and write "compiz --replace".
    If all is ok you will see the correct emerald theme active.
    There were some differences between my settings and this description, for example the file I had to edit was usr/bin/compiz-decorator. I don't know which lines I actually replaced but the text of my file was as follows:


    # fall back to any decorator that is installed
    if [ -z "$DECORATOR" ]; then
    verbose "Couldn't find a perfect decorator match; trying all decorators\n"
    if [ -x ${COMPIZ_BIN_PATH}emerald ]; then
    DECORATOR=emerald
    elif [ -x ${COMPIZ_BIN_PATH}gtk-window-decorator ]; then
    DECORATOR=gtk-window-decorator
    elif [ -x ${COMPIZ_BIN_PATH}kde-window-decorator ]; then
    DECORATOR=kde-window-decorator
    elif [ -x ${COMPIZ_BIN_PATH}kde4-window-decorator ]; then
    DECORATOR=kde4-window-decorator
    fi
    before, and I edited it to

    # fall back to any decorator that is installed
    if [ -z "$DECORATOR" ]; then
    verbose "Couldn't find a perfect decorator match; trying all decorators\n"
    if [ -x ${COMPIZ_BIN_PATH}emerald ]; then
    DECORATOR=emerald
    elif [ -x ${COMPIZ_BIN_PATH}gtk-window-decorator ]; then
    /usr/bin/emerald --replace &
    elif [ -x ${COMPIZ_BIN_PATH}kde-window-decorator ]; then
    /usr/bin/emerald --replace &
    elif [ -x ${COMPIZ_BIN_PATH}kde4-window-decorator ]; then
    /usr/bin/emerald --replace &
    fi
    after. I saved the original file to usr/bin/compiz-decorator.originalbackup to be safe. I didn't have any luck with running compiz --replace, but when I restarted the xserver session, it worked beautifully. Now my emerald themes and compiz settings load on startup! =)

  2. #2
    umob NNTP User

    Default Re: How I got Compiz-Fusion and Emerald to launch on start

    It works for me too. Thanx! (SUSE 11, Intel x3100)

  3. #3

    Default Re: How I got Compiz-Fusion and Emerald to launch on start

    Hi.

    I'm using GNOME and I never installed the fusion icon to have emerald by default
    I just followed these steps (I found'em in another post BTW):

    1. Installed one-click nVdia driver
    2. Rebooted
    3. Installed emerald and emerald themes (YasT)
    4. Opened ccsm >Effects >Window Decorator and changed "compiz-decorator" to "emerald --replace".
    5. Opened/edited (as root) /usr/bin/compiz-manager and changed USE_EMERALD="" to say USE_EMERALD="YES" and
    6. <Ctrl> + <Alt> + BackSpace (Twice) to log out and re-entered my session.
    That was it

    Cheers

    Luis C.

  4. #4

    Default Re: How I got Compiz-Fusion and Emerald to launch on start

    I don't like hacking with files like this, especially since it's not a config file, but I got emerald to work using a less invasive replacement that is similar to lucasuam, however my system is KDE4. In /usr/bin/compiz-decorator line 30 I changed it from

    USE_EMERALD="no"
    to

    USE_EMERALD="yes"
    This allowed me get emerald to start correctly while also still being able to choose compiz-decorator or kde-window-decorator if I choose to in the future. I think xVx's edit always starts emerald regardless of what decorator you enter choose as the default for compiz. This is fine if all you want is emerald. I do like emerald a lot now after using it, it's just so cool looking and comes with so many awsome themes out of the box!

  5. #5
    Join Date
    Sep 2008
    Location
    malaysia
    Posts
    9

    Default Re: How I got Compiz-Fusion and Emerald to launch on start

    seem lot of solutions for this.but,i just wanna ask all of you,do you have problem when minimize window?

    ex.i choose airplane for my minimize effect.but no effect occur.if i choose sidekick,the effect occur.why?

    plz visit the problem at -->
    compiz fusion 0.7.6,wow!but.... - openSUSE Forums

  6. #6
    Join Date
    Jun 2008
    Location
    Mexico
    Posts
    205

    Default Re: How I got Compiz-Fusion and Emerald to launch on start

    Quote Originally Posted by hafizakahbk View Post
    seem lot of solutions for this.but,i just wanna ask all of you,do you have problem when minimize window?

    ex.i choose airplane for my minimize effect.but no effect occur.if i choose sidekick,the effect occur.why?

    plz visit the problem at -->
    compiz fusion 0.7.6,wow!but.... - openSUSE Forums
    What GPU are you using?... Intel nVidia, ATI.. etc.

    This seems more like a GPU issue and not a compiz issue.

    Cheers

    Luis

    PS1. BTW, if you have a Inte GPU, most probabily I don't know what to do.... sorry

    PS2. If you have a nVidia or ATI card just enable the the repository. Update it. Make changes (by installing the driver) and reboot. Most probabily this is your problem. (in most cases when you have a nVidia graphic card the "open source nv" dirver is installed by default. The steps above will change it have the propietary one wich works very nice.
    La Humildad no es "Status"..
    ... es un �"Don"!

  7. #7
    LuisC-SM NNTP User

    Default Re: How I got Compiz-Fusion and Emerald to launch on start


    hafizakahbk;1870568 Wrote:
    > seem lot of solutions for this.but,i just wanna ask all of you,do you
    > have problem when minimize window?
    >
    > ex.i choose airplane for my minimize effect.but no effect occur.if i
    > choose sidekick,the effect occur.why?
    >
    > plz visit the problem at -->
    > 'compiz fusion 0.7.6,wow!but.... - openSUSE Forums'
    > (http://tinyurl.com/3weu5d)


    What GPU are you using?... Intel nVidia, ATI.. etc.

    This seems more like a GPU issue and not a compiz issue.

    Cheers

    Luis

    PS1. BTW, if you have a Inte GPU, most probabily I don't know what to
    do.... sorry

    PS2. If you have a nVidia or ATI card just enable the the repository.
    Update it. Make changes (by installing the driver) and reboot. Most
    probabily this is your problem. (in most cases when you have a nVidia
    graphic card the "open source nv" dirver is installed by default. The
    steps above will change it have the propietary one wich works very nice.


    --
    La Humildad no es "Status"..
    ... es un "Don"!

    My Desktop HW Specs: http://tinyurl.com/9vttxu
    ------------------------------------------------------------------------
    LuisC-SM's Profile: http://forums.opensuse.org/member.php?userid=652
    View this thread: http://forums.opensuse.org/showthread.php?t=391736


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •