Results 1 to 8 of 8

Thread: No read access to Vista's partition

  1. #1

    Default No read access to Vista's partition

    I have a read-only access to Vista's partition. Is it possible to get read-write access to it?

  2. #2
    Join Date
    Jun 2008
    Location
    Taiwan
    Posts
    150

    Default Re: No read access to Vista's partition

    umount this partition and then use ntfs-3g to mount it
    Regards,
    Bryan Yu
    http://lifestory.moqin.com/

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: No read access to Vista's partition

    I have a read-only access to Vista's partition. Is it possible to get read-write access to it?
    Your /etcfstab file probably needs editing to give you user rw permissions. Post your configuration if you need further help.

  4. #4

    Default Re: No read access to Vista's partition

    I will try that. But what will happen if there is another NTFS drive plugged in by USB? Will it be automatically detected and given RW permissions?

    This set up is not for me, but my father, and he should not need to mess around with configuration files. I will leave to another country tomorrow, so everything should 'just work'.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: No read access to Vista's partition

    No. The issue is fixed differently for USB-ntfs.

    If you want to write to the USB drive when it automounts, you have to adjust the automount for external NTFS drives to cause them to be automounted as read-write when you attach them to the usb plug. You can do that by entering this command into your console/terminal:
    sudo ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs
    That command puts a redirection link into the system whereby system calls to mount.ntfs (which gives read-only mounts) are redirected to mount.ntfs-3g (which gives read-write mounts).
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  6. #6

    Default Re: No read access to Vista's partition

    Quote Originally Posted by deano_ferrari View Post
    Your /etcfstab file probably needs editing to give you user rw permissions. Post your configuration if you need further help.
    Okay, I just looked that up, and found out that I am clueless on what to do, so I better ask. Usually when I try to fix something myself, then I will break the system a couple of times. It is fine when I am experimenting on my system, but I am not. So, the particual line says:
    Code:
    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK1237G_57MFT9J2T-part2 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=et_EE.UTF-8 0 0

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: No read access to Vista's partition

    You need to adjust the fmask and dmask values like this:

    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK1237G_57MFT9J2T-part2 /windows/C ntfs-3g users,gid=users,fmask=113,dmask=002,locale=et_EE.UTF-8 0 0
    You can do this by editing fstab directly, or alternatively, launch the yast > system > partitioner and edit the settings (fstab options) for the relevant ntfs partition.

  8. #8

    Default Re: No read access to Vista's partition

    Thank you, this works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •