Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Atheros - I am desperate, please help

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Atheros - I am desperate, please help

    Hello.

    I am really desperate to setup the wireless. It worked, for some short period of time, I do not remember what I did, so I have a proof that it can be configured. But that is forgotten how and I am pressing reset switch... Lets go from beginning: Atheros detected but not working and cannot be setup via Yast.

    then I gone to: Atheros ndiswrapper - openSUSE
    after doing what is told there, here is what I got
    Code:
    laptux:/home/ebeli # dmesg | grep ndiswrapper
    ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
    ndiswrapper: driver net5211 (,05/02/2007,5.3.0.45) loaded
    ndiswrapper (ZwClose:2227): closing handle 0xf79aa6a8 not implemented
    ndiswrapper (NdisWriteErrorLogEntry:191): log: C0001389, count: 4, return_address: fa376064
    ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xf398ea00
    ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x28
    ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xfa2c8000
    ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xfa2c8000
    ndiswrapper (mp_init:216): couldn't initialize device: C000009A
    ndiswrapper (pnp_start_device:439): Windows driver couldn't initialize the device (C0000001)
    ndiswrapper (mp_halt:259): device f2811500 is not initialized - not halting
    ndiswrapper: device eth%d removed
    ndiswrapper: probe of 0000:02:00.0 failed with error -22
    usbcore: registered new interface driver ndiswrapper
    I just cannot make it work. Yast always ask "ndiswrapper is not modeprobed, do you want...".
    Anyways, doesnt work. I removed ndisrwapper driver and finally, removed ndiswrapper itself.

    Then I gone to MadWiFi option.
    1st, I blacklisted ath5k module and gone to Atheros madwifi - openSUSE
    I did what I was told there, modprobed ath_pci, rebooted.
    Code:
    laptux:/home/ebeli # dmesg | grep ath
    ath_hal: module license 'Proprietary' taints kernel.
    ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    ath_pci: 0.9.4
    Code:
    laptux:/home/ebeli # modinfo ath_pci
    filename:       /lib/modules/2.6.25.11-0.1-pae/weak-updates/ath/ath_pci.ko
    license:        Dual BSD/GPL
    version:        0.9.4
    description:    Support for Atheros 802.11 wireless LAN cards.
    author:         Errno Consulting, Sam Leffler
    srcversion:     D3FD3BD11169A96DBCFF8DE
    alias:          pci:v0000168Cd00009013sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000001Dsv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000001Csv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000001Bsv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000001Asv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000019sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000018sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000017sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000016sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000015sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd0000101Asv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00001014sv*sd*bc*sc*i*
    alias:          pci:v000010B7d00000013sv*sd*bc*sc*i*
    alias:          pci:v0000A727d00000013sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000013sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000012sv*sd*bc*sc*i*
    alias:          pci:v0000168Cd00000007sv*sd*bc*sc*i*
    depends:        ath_hal,wlan
    vermagic:       2.6.25.5-2-pae SMP mod_unload 586
    parm:           countrycode:Override default country code (int)
    parm:           maxvaps:Maximum VAPs (int)
    parm:           outdoor:Enable/disable outdoor use (int)
    parm:           xchanmode:Enable/disable extended channel mode (int)
    parm:           rfkill:Enable/disable RFKILL capability (int)
    parm:           autocreate:Create ath device in [sta|ap|wds|adhoc|ahdemo|monitor] mode. defaults to sta, use 'none' to disable (charp)
    parm:           ratectl:Rate control algorithm [amrr|minstrel|onoe|sample], defaults to 'sample' (charp)
    parm:           ath_debug:Load-time debug output enable (int)
    snapshot1

    when I try to add new wireless, module box is just empty. It doesnt help to write ath_pci inside, because it looses it on the next open.
    snapshot2

    Please help.

  2. #2
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Atheros - I am desperate, please help

    You have the 'vermagic' problem...code that's there to insure that
    the kernel you compiled the driver for, matches the kernel
    you're now trying to install/use the driver in.
    [Note how kernel versions on 'filename' line do NOT match those
    on the 'vermagic' line.]

    So, basically, you need to RE-COMPILE (re-make) the driver, before
    you do the 'make install' step (which moves the compiled driver from
    your work area down into the kernel that it's gonna run under).

    The cleanest way is just to re-do everything...delete the work directory that
    you initially un-TARed the downloaded madwifi driver into, then re-do
    the 'tar' etc.

    Make sense?

    [That said, don't feel bad. It's not your fault. Novell screwed up when they
    chose to pre-install 'ath5k' instead of the madwifi driver. In my opinion.
    Which is only ONE of their sub-optimal choices that is making 11.0
    such a support nightmare.]
    Box1: MEPIS-8.5/sidux/openSUSE-11.3M6(broken-wifi/hiddenSSIDs)/XP(32-bit), nvidia 5200
    Lap1: antiX-8.5(KDE4.4.3)/MEPIS-8.5/Vista, Intel 945GM, builtin-wifi->Broadcom-4311(drv=wl)

  3. #3
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Atheros - I am desperate, please help

    well, I do not quite understood what you said.
    I removed madwifi from yast then
    I downloaded sources of the MadWiFi (not rpm), I did make and make install.
    Suse offers madwifi 0.9.3, I have newest from the madwifi site.

  4. #4
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Atheros - I am desperate, please help

    Make sure that you have blacklisted 'ath5k' driver.

    Also, make sure that if you have the file:
    '/etc/modprobe.d/ndiswrapper'
    present, that you delete it.
    (It defines 'wlan0' device, which you do NOT now want.)

    Then, if you see the device name 'wlan0' associated with the
    device (on 'network devices'->'network settings' screen), click
    on the 'delete' option and get rid of it. Re-boot.

    [Any of the above stuff is left over is left-over from your attempts to
    use either ndiswrapper and/or the 'ath5k' driver.]

    Now configure your device (for the ath_pci module). You should now
    be able to get it to work. The device name should come up as 'ath0'.

    Post back if you still have problems.

    Hope this helps...

    Dave
    Box1: MEPIS-8.5/sidux/openSUSE-11.3M6(broken-wifi/hiddenSSIDs)/XP(32-bit), nvidia 5200
    Lap1: antiX-8.5(KDE4.4.3)/MEPIS-8.5/Vista, Intel 945GM, builtin-wifi->Broadcom-4311(drv=wl)

  5. #5
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Atheros - I am desperate, please help

    Quote Originally Posted by cookdav View Post
    Make sure that you have blacklisted 'ath5k' driver.
    it was already. Double-check, yes, it is in blacklist.

    Quote Originally Posted by cookdav View Post
    Also, make sure that if you have the file:
    '/etc/modprobe.d/ndiswrapper'
    present, that you delete it.
    (It defines 'wlan0' device, which you do NOT now want.)
    it was there, I have deleted it now, rebooted

    Quote Originally Posted by cookdav View Post
    Now configure your device (for the ath_pci module). You should now
    be able to get it to work. The device name should come up as 'ath0'.
    Post back if you still have problems.
    Hope this helps...

    Dave
    Thanks Dave, but We're back to square 1...
    Please see http://www.varnus.com/snapshot1.png

    I cannot configure it, as it is disabled. Unless you thought on some other kind of configuration, like adding new device. Which if I do, I do not have any modules listed in module combobox, and if I write ath_pci, it is lost on next open of yast->network devices

    there is something interesting in hwinfo:
    Code:
    70: udi = '/org/freedesktop/Hal/devices/pci_168c_1c'
      pci.subsys_vendor_id = 6715 (0x1a3b)
      info.subsystem = 'pci'
      pci.device_class = 2 (0x2)
      info.product = 'AR242x 802.11abg Wireless PCI Express Adapter'
      pci.device_subclass = 0 (0x0)
      info.udi = '/org/freedesktop/Hal/devices/pci_168c_1c'
      pci.device_protocol = 0 (0x0)
      pci.vendor = 'Atheros Communications Inc.'
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:06.0/0000:02:00.0'
      info.vendor = 'Atheros Communications Inc.'
      info.parent = '/org/freedesktop/Hal/devices/pci_1039_a'
      pci.product = 'AR242x 802.11abg Wireless PCI Express Adapter'
      pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:06.0/0000:02:00.0'
      pci.product_id = 28 (0x1c)
      linux.hotplug_type = 2 (0x2)
      pci.vendor_id = 5772 (0x168c)
      linux.subsystem = 'pci'
      pci.subsys_product_id = 4134 (0x1026)
    
    ~~~~~~
    
    12: PCI 200.0: 0282 WLAN controller
      [Created at pci.310]
      UDI: /org/freedesktop/Hal/devices/pci_168c_1c
      Unique ID: B35A.m0vUiPh1JS3
      Parent ID: H0_h.VpS90DeKnS9
      SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:02:00.0
      SysFS BusID: 0000:02:00.0
      Hardware Class: network
      Model: "Atheros AR242x 802.11abg Wireless PCI Express Adapter"
      Vendor: pci 0x168c "Atheros Communications, Inc."
      Device: pci 0x001c "AR242x 802.11abg Wireless PCI Express Adapter"
      SubVendor: pci 0x1a3b 
      SubDevice: pci 0x1026 
      Revision: 0x01
      Features: WLAN
      Memory Range: 0xfaaf0000-0xfaafffff (rw,non-prefetchable)
      IRQ: 16 (1 event)
      Module Alias: "pci:v0000168Cd0000001Csv00001A3Bsd00001026bc02sc00i00"
      Driver Info #0:
        Driver Status: ath5k is not active
        Driver Activation Cmd: "modprobe ath5k"
      Driver Info #1:
        Driver Status: ath_pci is active
        Driver Activation Cmd: "modprobe ath_pci"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #17 (PCI bridge)
    Now, something from a boot.log

    Code:
    <6>ath_pci: 0.9.4
    <6>ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    <7>PCI: Setting latency timer of device 0000:02:00.0 to 64
    <3>wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
    <6>ACPI: PCI interrupt for device 0000:02:00.0 disabled
    What the hack is the problem here?

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Atheros - I am desperate, please help

    beli0135 wrote:
    >
    > <6>ath_pci: 0.9.4
    > <6>ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    > <7>PCI: Setting latency timer of device 0000:02:00.0 to 64
    > <3>wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
    > <6>ACPI: PCI interrupt for device 0000:02:00.0 disabled
    >
    > --------------------
    >
    >
    > What the hack is the problem here?


    As the message says, that driver does not support that hardware! You probably
    have exhausted the Atheros knowledge here. I would post this message (with the
    last line changed) to linux-wireless@vger.kernel.org. That is where the wireless
    experts hang out.

    Larry


  7. #7
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Atheros - I am desperate, please help

    Thank you Larry.
    a week ago, I do not know what I did, but for a brief moment, before reboot, I managed to set it up. I do not know how, I know that I had ndiswrapper and ath_pci at the same time up.
    After reboot it stopped working, and after, neither with ndiswrapper nor ath_pci could I make it work. But it DID worked for a bit...


  8. #8
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: Atheros - I am desperate, please help

    I got mine going with ndiswrapper. Get the driver here: http://blakecmartin.googlepages.com/...-32-0.2.tar.gz For 64bit change the 32 in the link to 64.

    Install the .inf file with
    Code:
    ndiswrapper -i path_to_.inf
    Remove ath5k
    Code:
    modprobe -r ath5k
    Add ath5k to the end of /etc/modprobe.d/blacklist file
    Code:
    blacklist ath5k
    modprobe ndiswrapper module
    Code:
    modprobe ndiswrapper
    Open Yast>System>/etc/sysconfig Editor. Expand System>Kernel and select MODULES_LOADED_ON_BOOT. Add ndiswrapper. Reboot. Then set it up with Yast again. Just be sure to change the module option while setting up the card under the hardware tab from ath5k to ndiswrapper. You should be good to go after another reboot.
    Klaatu Barada Nikto

  9. #9
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Atheros - I am desperate, please help

    OH YEA!
    Worked!!!

    I done the same procedure before, but I see now that the driver you provided has some bytes difference from the driver I got on CD with laptop. Probably there was the catch.
    Anyways, it is working.

    A BIG THANKS!!!

  10. #10
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Atheros - I am desperate, please help

    well it worked, but I have another problem now.

    After a few minutes, my whole system freezes.

    Anyone knows why and how to avoid?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •