Results 1 to 5 of 5

Thread: Configuration Pure-Ftpd

  1. #1
    RegisSCOTTO NNTP User

    Default Configuration Pure-Ftpd

    Hello,

    I've installed Xinet and the daemon pure-ftpd, on console tty under KDE, i type ftp 127.0.0.1, pure-ftpd write these informations but impossible to connect, in fact, i've "login authentification failed", but i don't know where correct configuration to obtain a good logon on ftp, can you help me to understand pure-ftpd philosophy.

    In advance, thank you.

    And excuse my awfull writing language

  2. #2
    PeeGee NNTP User

    Default Re: Configuration Pure-Ftpd

    SCOTTOREGIS wrote:
    > Hello,
    >
    > I've installed Xinet and the daemon pure-ftpd, on console tty under
    > KDE, i type ftp 127.0.0.1, pure-ftpd write these informations but
    > impossible to connect, in fact, i've "login authentification failed",
    > but i don't know where correct configuration to obtain a good logon on
    > ftp, can you help me to understand pure-ftpd philosophy.
    >
    > In advance, thank you.
    >
    > And excuse my awfull writing language
    >
    >


    I've just spent a few hours getting pure-ftp to work (but I was trying
    to upload from XP in Virtualbox!), so I can understand your frustrations.

    Firstly, do you get asked for a name and password at the start or are
    you using anonymous access - you may need to post the messages to get
    specific help? For personal reasons I have restricted ftp access to myself.

    If you have enabled "authenticated users only" or "both" (I used YAST),
    have you added the user to the "ftp" group?

    I'm sure someone experienced will be along shortly :-)

    --
    PeeGee

    Asus M2V-MX SE, AMD 64X2 3800+, openSuSE 10.3 x86-64/XP Home dual boot
    Asus M2NPV-VM, AMD LE1640, openSuSE 11.0 x86-64/XP Home dual boot

  3. #3
    RegisSCOTTO NNTP User

    Default Re: Configuration Pure-Ftpd

    Hello,

    I've created "public" with password "public", group ftp by default, when i type "ftp 127.0.0.1" :
    _
    regis@linux-mj1z:~> ftp 127.0.0.1
    Connected to 127.0.0.1.
    220-Welcome to Pure-FTPd.
    220-You are user number 1 of 50 allowed.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    Name (127.0.0.1:regis): public
    331 User public OK. Password required
    Password:
    530 Login authentication failed
    ftp: Login failed.
    ftp>
    _

    Can you tell me where configure the anthentication ? OK, it's Yast, but where ?

    Thank you

    Friendly,

    Regis

  4. #4
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Configuration Pure-Ftpd

    You should not use xinet to launch pure-ftpd or any other ftpd for that matter - it has some downsides.

    To enable normal users (users from /etc/passwd rather than anonymous users or virtual users), edit:
    /etc/pure-ftpd/pure-ftpd.conf and find:

    # Don't allow authenticated users - have a public anonymous FTP only.
    AnonymousOnly yes

    change that to no.

    # Disallow anonymous connections. Only allow authenticated users.
    NoAnonymous no

    change that to yes.

    ---

    To fire up pure-ftpd without xinetd:
    rcpure-ftpd start

    To enable it to start on every startup:
    chkconfig pure-ftpd on

    Remember that everytime you change the configuration file, pure-ftpd needs to be reloaded - with rcpure-ftpd restart

    Remember to edit the /etc/xinetd.d/pure-ftpd and disable it so it doesn't conflict with the service based pure-ftpd. Restart xinetd for it to take effect.

  5. #5
    RegisSCOTTO NNTP User

    Default Re: Configuration Pure-Ftpd

    Hello Chrysantine (and many thanks), Hi all,

    ok for your parameters, it run perfectly, however, i can download but not upload : connection terminated or interrupted, i make the download from a PC under Windows with FileZilla, and upload don't run .

    How to make uploaded files from this account (name : public / passwd : public) ?

    Thanks more again !!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •