Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Mailto does not work in Firefox

  1. #1
    d_hignett NNTP User

    Default Mailto does not work in Firefox

    The "mailto" facility if Firefox does not work, ie when I click a "mailto" link on a page nothing happens.

    I use Kmail and have set it as the default mail program in KDE control centre.

    I have looked at Forefox settings and the only applicable one seems to be "Applications" which allows you to set an application, helper, etc for any type of content, but the list of content types is empty and there seems to be no way to populate it.

    I am using Open SUSE 11.0 with all updates, so Firefox 3.0.1.

    Anyone help with getting "mailto" to work ?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: Mailto does not work in Firefox

    Try this. Enter 'about:config' in the URL bar of firefox. Right-click within the table of existing entries, and you will get a box open. Choose 'New' > 'String', then enter the preference name 'network.protocol-handler.app.mailto'. Enter 'kmailservice' as the value.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: Mailto does not work in Firefox

    Update (to above). I remember successfully setting kmail as the default mailto app with firefox 2 over a year ago. Things seemed to have changed a bit as it didn't work as expected.

    Now, I was able to make the required change via Edit > Preferences. I set 'mailto' to 'Use other...' and navigated to /usr/bin/kmail. (I'm using KDE4 version of kmail. The KDE3 executable is located at /opt/kde3/bin/kmail).

  4. #4
    d_hignett NNTP User

    Default Re: Mailto does not work in Firefox

    Quote Originally Posted by deano_ferrari View Post
    Try this. Enter 'about:config' in the URL bar of firefox. Right-click within the table of existing entries, and you will get a box open. Choose 'New' > 'String', then enter the preference name 'network.protocol-handler.app.mailto'. Enter 'kmailservice' as the value.
    I have already entered that pref, as advised in the Firefox Support system, with the value as the full path to kmail. That did not work. I changed the value as per your suggestion but that did not work either.

    I think the problem has something to do with the fact that Firefox Preferences - Applications gives an empty list for "Content Type".

    Regards

    David

  5. #5

    Default Re: Mailto does not work in Firefox

    Quote Originally Posted by deano_ferrari View Post
    Update (to above). I remember successfully setting kmail as the default mailto app with firefox 2 over a year ago. Things seemed to have changed a bit as it didn't work as expected.

    Now, I was able to make the required change via Edit > Preferences. I set 'mailto' to 'Use other...' and navigated to /usr/bin/kmail. (I'm using KDE4 version of kmail. The KDE3 executable is located at /opt/kde3/bin/kmail).
    Thanks! I had tolerated this problem with my system, as I found out one day after the switch to FF 3.0 that mailto: was not working. I tried going the about:config route as mentioned, but to no avail. It was not a big enough thing for me to sweat, but I sure am glad to fix it.

    Thanks again!

    d_hignett: I don't know why your list is unpopulated. That is a strange one. Have you tried poking around the mozilla support forums? Last time I was there, they had quite a bit of traffic.

  6. #6
    d_hignett NNTP User

    Default Re: Mailto does not work in Firefox

    Quote Originally Posted by wnj92996 View Post

    d_hignett: I don't know why your list is unpopulated. That is a strange one. Have you tried poking around the mozilla support forums? Last time I was there, they had quite a bit of traffic.
    I have been on the Mozilla forum. Searching "mailto" got about 300 hits, with lots of the same problem, but no proper solution. I posted my own question but have had no replies.

    Thanks for the suggestions. I guess I am stuck with copy and paste email links.

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Mailto does not work in Firefox

    Hmm, strange one. My application list is populated and in fact the application for mailto: is set to Thunderbird, with the opportunity to change it. I've got standard 11.0 and FF3.0.1 too.

    Maybe try creating another Firefox profile and see if it works there? Do you own all the files under .mozilla? Sometimes if you have at some point run firefox as some other user it creates config files that you don't own and therefore cannot edit.

  8. #8
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Mailto does not work in Firefox

    On Mon, 18 Aug 2008 10:36:02 GMT
    ken yap <ken_yap@no-mx.forums.opensuse.org> wrote:

    >
    > Hmm, strange one. My application list is populated and in fact the
    > application for mailto: is set to Thunderbird, with the opportunity to
    > change it. I've got standard 11.0 and FF3.0.1 too.
    >
    > Maybe try creating another Firefox profile and see if it works there?
    > Do you own all the files under .mozilla? Sometimes if you have at some
    > point run firefox as some other user it creates config files that you
    > don't own and therefore cannot edit.
    >
    >


    firefox doesn't setup "mailto:" link support automatically since there are
    many to choose from on the linux platform.

    Ken has thunderbird available since he likely had it installed before he
    installed firefox (a guess). But considering the programs are from same
    source, them working together automatically is expected.

    Firefox 3 has better support for mailto since it allows one to set it up
    through the preferences menu, under applications. Mine currently says
    "Always Ask"... so it should prompt you when you click on a mailto link.
    Choosing 'Use Other...' in the dropdown allows you to enter the path to a
    program you'd like to use for email handling.

    A slightly more detailed writeup is here, from the mozilla.com site:

    http://tinyurl.com/62uocc
    http://support.mozilla.com/en-US/kb/...sed+by+Firefox

    Of course, there are always add-ons (extensions) which will extend the
    functionality of firefox:

    http://tinyurl.com/6a7f79
    https://addons.mozilla.org/en-US/fir...mailto&cat=all

    Hope this helps

    Loni

    --
    L R Nix
    lornix@lornix.com


  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Mailto does not work in Firefox

    No, the odd thing is that the OP claims his application list cannot be edited. I just tried creating a new profile and the application list had a few starter entries, including Thunderbird. But even if that were not there, he should be able to add it. That's why I suspect something odd in his profiles.

    The associations are in a file called mimeTypes.rdf in the profile directory BTW.

  10. #10
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Mailto does not work in Firefox

    On Mon, 18 Aug 2008 20:26:04 GMT
    ken yap <ken_yap@no-mx.forums.opensuse.org> wrote:

    >
    > No, the odd thing is that the OP claims his application list cannot be
    > edited. I just tried creating a new profile and the application list
    > had a few starter entries, including Thunderbird. But even if that were
    > not there, he should be able to add it. That's why I suspect something
    > odd in his profiles.
    >
    > The associations are in a file called mimeTypes.rdf in the profile
    > directory BTW.
    >
    >


    {chuckle} I'd recommend removing the file and allowing firefox to recreate
    it... but I get the feeling I'm going to get flamed for telling someone else
    to delete something else in another forum. {Sigh} Can't win.

    Loni

    --
    L R Nix
    lornix@lornix.com


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •