Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Eclipse and KDE4.1 panel/kicker

  1. #1
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    78

    Default Eclipse and KDE4.1 panel/kicker

    I'm running OpenSuse 11, with KDE 4.1. Eclipse is doing strange things to the panel/kicker/taskbar at the bottom of the screen.

    If Eclipse is running (even with a small file) mousing over the panel causes the icon & text of the item on the panel to disappear. Even the clock will disappear when it updates the time. Note this is only when Eclipse is the active application running. Eg if I switch to Firefox while Eclipse is still running, the problem goes away till I switch back to Eclipse.

    This has happened on KDE4 with Eclipse Europa, and now on 4.1 with the latest version Version: 3.4.0 (Build id: I20080617-2000) Ganymede. I was hoping that either KDE4.1 or that latest version of Eclipse would fix it - neither did.

    Oddly, NetBeans works fine - no issues with the panel, so I'm sure its not a Java-KDE4 issue.

    Anyone know how to stop this?

    Thanks
    BZFlag: good clean fun. Sorta.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Eclipse and KDE4.1 panel/kicker

    do you have desktop effects, either native kde4 or compiz
    and if yes, have you tried without?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    dead_knight NNTP User

    Default Re: Eclipse and KDE4.1 panel/kicker

    I have this problem too.

    I disable compiz on KDE 4.1, but this problem continues.

  4. #4
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    78

    Default Re: Eclipse and KDE4.1 panel/kicker

    Ahh...nice to know I'm not the only one.
    I disabled Desktop Effects, logged out & back in again, but that made no difference either.

    I've also found that OpenOffice Writer does this too - dang annoying.

    Maybe its some issue Java + QT apps or something?
    BZFlag: good clean fun. Sorta.

  5. #5
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    78

    Default Re: Eclipse and KDE4.1 panel/kicker

    Ok, this thread over on Nvidia's site seems to indicate its an issue in the driver, and affects other apps besides OpenOffice and Eclipse.

    compiz-fusion artefact in gtk apps nvidia 169.07 - nV News Forums
    BZFlag: good clean fun. Sorta.

  6. #6
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Eclipse and KDE4.1 panel/kicker

    Nvidia just released new drivers this past week
    (which I installed...fixed some issues I had).
    Unix Drivers Portal Page

    [Using this method is 'harder way' of installing nvidia (from source).
    And, you'll have to re-install again each time that openSUSE
    upgrades the kernel.]
    For details, see:
    NVIDIA - openSUSE
    Box1: MEPIS-8.5/sidux/openSUSE-11.3M6(broken-wifi/hiddenSSIDs)/XP(32-bit), nvidia 5200
    Lap1: antiX-8.5(KDE4.4.3)/MEPIS-8.5/Vista, Intel 945GM, builtin-wifi->Broadcom-4311(drv=wl)

  7. #7

    Default Re: Eclipse and KDE4.1 panel/kicker

    The NVIDIA driver version 173.14.12 doesn't fix this issue.

    It doesn't occurs on every system with a KDE 4.1 / NVIDIA combination. My laptop (GeForce 9500M GS) doesn't show this effect, the desktop system (GeForce 7600 GT) does.

  8. #8
    winterstream NNTP User

    Default Re: Eclipse and KDE4.1 panel/kicker

    On my system, the corruption only occurs when a text editor is active in Eclipse. Try clicking on another widget in Eclipse so that no text editor will be active.

    On way to improve the corruption problem is to force the focus to be under the mouse (you can set this in System Settings > Window Behaviour; change the focus policy to "Focus strictly under the mouse" - sorry if the English text doesn't match mine; I'm using a translated interface).

    This doesn't fix everything; animating plasmids will still be corrupted while you are working in Eclipse, but at least the taskbar corruption should be fixed.

  9. #9
    finder87 NNTP User

    Default Re: Eclipse and KDE4.1 panel/kicker

    I also have this bug appeared. I'm using eclipse 3.3.2 which I downloaded from eclipse.org site, kde 4.1, latest compiz and latest NVIDIA drivers (video card is 6100). Does anyone know the reason why it happens?

  10. #10
    usaar33 NNTP User

    Default Re: Eclipse and KDE4.1 panel/kicker

    I also have this issue (using nvidia drivers albeit not compwiz). However, I also experience an even worse problem:

    Occasionally, screens become entirely blacked out. Here is firefox after it became just a black screen:


    I can fix this by cycling through my virtual desktops, but even then corruption also remains. Needless to say, this makes it quite difficult to use my computer.

    Even if there is no way to per se fix the problem, is there some way to "force" a rerendering?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •