Results 1 to 4 of 4

Thread: Wireless detected but can't get IP

  1. #1
    hanks_alonso NNTP User

    Default Wireless detected but can't get IP

    Hi,

    I have a notebook with 2915ABG wireless network interface. My problem is, using wifi-radar, iwconfig, kWlan it can detect avail able wireless APs but it can't get an IP with any of it even with the open network.

    Below are few results :

    Code:
    linux:~ # iwlist eth1 guest
    Setting up wifi connection for
    Interface eth1, ESSID: JARINGguest...
    eth1      Scan completed :
              Cell 01 - Address: 00:0B:86:36:2D:F2
                        ESSID:"guest"
                        Protocol:IEEE 802.11bg
                        Mode:Master
                        Frequency:2.412 GHz (Channel 1)
                        Encryption key:off
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                                  11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Quality=61/100  Signal level=-64 dBm
                        Extra: Last beacon: 48ms ago
    
    linux:~ # iwconfig eth1 essid guest key off ap any
    linux:~ # dhclient eth1
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    Listening on LPF/eth1/00:0e:35:68:3b:4d
    Sending on   LPF/eth1/00:0e:35:68:3b:4d
    Sending on   Socket/fallback
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    This notebook was installed previously with Slackware 12.1 and it got no problem.

    Please help.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Wireless detected but can't get IP

    Does your connection work when setting the ip & route using ifconig & setting dns manually?

    Another option is to set up this connection using YaST > Network Settings.

    Have a first try using the ifup (traditional) method found in the Global Options tab and in the overview tab set all the needed settings for your wireless card.

    It should not be giving this issue, but to rule it out also temporarily stop the firewall using ' SuSEfirewall2 off'

    hope that helps,
    Wj
    Have a lot of fun!

  3. #3
    hanks_alonso NNTP User

    Default Re: Wireless detected but can't get IP

    Hi Magic,

    Its working now. Thanks for the assist. Seems that only KnetworkManager managed to make my wireless connection works while others (wifi-radar, kwlan) failed.

    It SUSE have different ways in configuring network interface compare to other distros?

    BTW, I'm new to openSUSE

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Wireless detected but can't get IP

    Good to hear it's working now

    There are three ways I know of configuring a network interface in openSUSE;
    1) Manually using ifconfig and iwconfig in a terminal console(this is the spartan way)
    2) using ifup in YaST > Network Devices (select to use it in the Global Options tab).
    3) using Networkmanager through YaST or by using Networkmanagers configuration options (Also select to use it in the Global Options tab in YaST > Network Devices)

    & Welcome to openSUSE !!

    Hope you enjoy,
    Wj
    Have a lot of fun!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •