hi,
on my thinkpad T60 i'm using updated opensuse 11.0 with KDE4.1 from obs-KDE4:factory repos and madwifi driver from madwifi.org. I can't get my wireless card working properly. I was trying several ways but with no luck.

1)networkmanager - can't manage wireless connections using knetworkmanager - i don't see any networks (there are no scan results), when added essid manually (and other options) knetwrokmanager creates profile but on click nothing happens

from /var/log/NetworkManager
<info> ath0: driver does not support SSID scans (scan_capa 0x00).
<WARN> real_act_stage2_config(): Activation (ath0/wireless): couldn't send wireless configuration to the supplicant.

2)iwconfig - i'm able to set up connection and succesfully connect but after some time my connection is dropped down. The txpower is automatically falling to 8dBm so i need to manually set up the txpower to 16/17dbm (heh..sometimes works with value 16 else 17).

some info:
dmesg | grep ath
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
ath_pci: 0.9.4
ath_rate_sample: 1.2 (0.9.4)
martian source 255.255.255.255 from 192.168.1.1, on dev ath0
martian source 255.255.255.255 from 192.168.1.1, on dev ath0
SFW2-INext-DROP-DEFLT IN=ath0 OUT= MAC= SRC=192.168.1.19 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
SFW2-INext-DROP-DEFLT IN=ath0 OUT= MAC= SRC=192.168.1.19 DST=224.0.0.251 LEN=242 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=222
SFW2-INext-DROP-DEFLT IN=ath0 OUT= MAC= SRC=192.168.1.19 DST=224.0.0.251 LEN=347 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=327
SFW2-INext-DROP-DEFLT IN=ath0 OUT= MAC= SRC=192.168.1.19 DST=224.0.0.251 LEN=347 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=327
SFW2-INext-DROP-DEFLT IN=ath0 OUT= MAC= SRC=192.168.1.19 DST=224.0.0.251 LEN=347 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=327
martian source 255.255.255.255 from 192.168.1.1, on dev ath0
...

lspci -v
03:00.0 Ethernet controller: Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)
Subsystem: IBM ThinkPad 11a/b/g Wireless LAN Mini Express Adapter (AR5BXB6)
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at edf00000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Capabilities: [60] Express Legacy Endpoint, MSI 00
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Kernel driver in use: ath_pci
Kernel modules: ath5k, ath_pci

any ideas?

thanks