Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: I do not use A4 paper...

  1. #1
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    297

    Default I do not use A4 paper...

    Nevertheless, every now and then, some app insists on using A4. It would seem like the wrong default (A4 printing on letter paper loses some lines at the bottom. The reverse does not have that problem.) Anyway, this is a really tiresome battle. I want to shoot down dead forever this A4 monster so I don't have to worry about it any more. How do I do that? (All my printers are configured as using letter paper. One printer is kind enough to upgrade my A4 print jobs to legal, except it is rotated 90 degrees and loses even more lines than if it were on letter paper.) It really should not be so difficult. Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: I do not use A4 paper...

    A lot depends on what applications you are using. OpenOffice allows you to set paper size globally and for each document. If you use KDE applications, there is an option under Properties to configure the paper size. If you always use Legal, 'Save' the changes as your default and this will be used by all KDE related programs; if you need to print a different size, you can select it but not save it and when you next open a KDE application, it will revert to 'Legal'.
    .

  3. #3
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    297

    Default Re: I do not use A4 paper...

    Thanks. Found the global KDE setting and it seems I had found it previously. It is set to "letter". I was using Firefox, not Kbrowser when I encountered the issue. But, I tried it again and it printed correctly, so maybe the printer was in some funny state. Who knows? It's too complicated to see an obvious cause. Thank you.

  4. #4
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    297

    Default Re: I do not use A4 paper...

    Still not done. I set OpenOffice to letter. I set KDE to letter. I configured CUPS to letter. I just used enscript. A4 again. Lost a half inch of crucial text. Letter is smaller than A4. If it is necessary to frustrate everyone by making it next to impossible to change paper type, why not at least choose the smaller paper size so at least everything is printed? >:-(

  5. #5
    PV NNTP User

    Default Re: I do not use A4 paper...

    bkorb wrote:

    >
    > Still not done. I set OpenOffice to letter. I set KDE to letter. I
    > configured CUPS to letter. I just used enscript. A4 again. Lost a
    > half inch of crucial text. Letter is smaller than A4. If it is
    > necessary to frustrate everyone by making it next to impossible to
    > change paper type, why not at least choose the smaller paper size so at
    > least everything is printed? >:-(
    >
    >

    bkorb;

    Have you set the paper size with printmanager and/or directly in cups
    (http://localhost:631/printers/)?
    --
    P. V.
    Only fools rush in where angels fear to tread.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: I do not use A4 paper...

    Have you had a look at /etc/papersize file? Try changing the string from 'a4' to 'letter'.

    I think some older apps (like xpdf and enscript) still check this config file for paper size.

  7. #7
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: I do not use A4 paper...

    bkorb wrote:
    > Nevertheless, every now and then, some app insists on using A4. It
    > would seem like the wrong default (A4 printing on letter paper loses
    > some lines at the bottom. The reverse does not have that problem.)
    > Anyway, this is a really tiresome battle. I want to shoot down dead
    > forever this A4 monster so I don't have to worry about it any more.
    > How do I do that? (All my printers are configured as using letter
    > paper. One printer is kind enough to upgrade my A4 print jobs to
    > legal, except it is rotated 90 degrees and loses even more lines than
    > if it were on letter paper.) It really should not be so difficult.
    > Thanks.
    >
    >

    In the future a thread like this might be better suited in the Software
    forum as this has nothing to do with the Install/Boot/Login of the OS.

  8. #8
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    297

    Default Re: I do not use A4 paper...

    ``In the future a thread like this might be better suited in
    the Software forum as this has nothing to do with the
    Install/Boot/Login of the OS.''
    Perhaps. It is at install time that I feel the pain, though.
    Next time, "software" it is.

    Anyway, three weeks later and I'm still screwing around with
    finding new places where the string "A4" got hidden away and
    causing my print jobs to get mutilated or forcing me to go
    through several layers of menus to set paper type on each and
    every print request. The installation process needs to set
    the paper type correctly in all the hidden places.
    Yes, I am frustrated and irritated. It has been *THREE* weeks.

    Also:
    $ cat /etc/papersize
    letter

    so that is not it. /etc/cups/ppd/bunker.ppd has:
    *DefaultPageSize: Letter
    yet jobs that go there want to print in A4.

    ``Have you set the paper size with printmanager and/or
    directly in cups (http://localhost:631/printers/)?''

    I've been through the cups configury more often than I can count.
    I surely don't know where to find paper size in there.
    "Modify Printer" is simply way too obvious a choice for such a
    thing, and it is not in there. And I've set my locale to
    US English, so that should hint at "letter" size. I did find
    reference to using ``-o media=Letter'' on all my print jobs.
    That would suck. Especially since more often than not I'm
    printing from FireFox or Thunderbird. But those apps prefer to
    use the system setting and the system setting does not seem to
    be either /etc/papersize or the KDE properties setting.

    So, to me this feels like an installation issue because you generally want to solve it at install time. My installation suggestions:
    1. default to "letter" because it is smaller than A4.
    2. come up with an installation script that will hunt down
    every last place where primary applications (FireFox,
    OpenOffice, Thunderbird, KDE, CUPS, etc. etc) hide the
    keyword "letter" and make it possible to easily replace it
    with "A4"
    3. Once the list of paper size config files has been assembled,
    publish the thing in a Google-able place so folks with old
    software (like SuSE 11.0) can go back and fix things up.

    This whole thing is really, really tiresome. Sorry to rant
    so much.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: I do not use A4 paper...

    > This whole thing is really, really tiresome. Sorry to rant
    > so much.


    yep, sometimes a good rant is "good for the soul"...so might be to
    think about all the other things good which you can have with the
    money you saved by not following the M$ herd..

    by the way, i had the opposite problem some years back when i used A4
    and the software of that day (OS/2 from a little company named IBM)
    insisted on hiding "letter" in numerous places just to get under my
    skin....(in other words, i do feel for you)....it took me a lot more
    than three weeks to solve (with a VERY active newsnet group
    helping)!! </sigh.>

    --
    DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
    3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

  10. #10
    PV NNTP User

    Default Re: I do not use A4 paper...

    bkorb wrote:

    <snip>
    > ``Have you set the paper size with printmanager and/or
    > directly in cups (http://localhost:631/printers/)?''
    >
    > I've been through the cups configury more often than I can count.
    > I surely don't know where to find paper size in there.
    > "Modify Printer" is simply way too obvious a choice for such a
    > thing, and it is not in there. And I've set my locale to
    > US English, so that should hint at "letter" size. I did find
    > reference to using ``-o media=Letter'' on all my print jobs.
    > That would suck. Especially since more often than not I'm
    > printing from FireFox or Thunderbird. But those apps prefer to
    > use the system setting and the system setting does not seem to
    > be either /etc/papersize or the KDE properties setting.
    >

    <snip>
    bkorb;
    Paper Size in under the "Set printer options" tab, listed under each printer.

    http://localhost:631/printers/; find your printer in the list; choose "Set
    Printer Options".
    --
    P. V.
    Only fools rush in where angels fear to tread.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •