Results 1 to 3 of 3

Thread: pkcon internal-error : Repo exception

  1. #1

    Question pkcon internal-error : Repo exception

    Hi,

    I have fresh install of opensuse 11, yesterday I have installed opera rpm and everything was fine. Later I started install of flash player, but my g/f came and I needed to leave ;) So I switched the computer off during the installation (using menu copmuter/shutdown) and now i have the repo exception :( I should have tried the cancel button first, but too late now :(

    user@linux-9qup:~/Desktop> pkcon install flash-plugin-9.0.124.0-release.i386.rpm
    Error: internal-error : Repo exception
    install-files runtime was 0.1 seconds

    I have two questions:
    - how do I repair the damaged repo
    - how do I safely cancel package installation process to avoid happening of this again?

    It would be perhaps faster to reinstall the whole suse, but I want to learn to solve problems, because it looks great - just installed on a new computer and all drivers are working out of the box :) The computer came with preinstalled vista, but after my month experience with that OS I found out, that windows are going wrong way... ;)

    I'm a suse newbie, so please be patient with me ;) I had only some experiences with debian (just command line, without x or gnome), but debian installation failed on my new computer, so I'm trying luck with suse :)

    Thank you for help.

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: pkcon internal-error : Repo exception

    pkcon? - Wrong.

    su -c "zypper in flash-player" - Right.

    Installing directly from RPMs - Wrong.
    Adding the proper repositories - in this case OSS & Non-OSS - Right.

    YAST -> Software Repositories -> Add -> Community Repositories, click on OSS & non-OSS, perhaps Packman as well. OK. Finish.

  3. #3

    Default Re: pkcon internal-error : Repo exception

    Wow, what a fast reply Thank you. This worked. But...

    ...it does not solve my problem though - rightclick on any rpm I donwload from internet and choose "open with package installer" causes the same repo exception Pkcon worked fine before I messed it up with shutdown.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •