Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: 11 with new ATI drivers

  1. #1

    Default 11 with new ATI drivers

    So...

    I did an update last night with the newer kernal and several other updates. Okay

    Then I downloaded the latest ATI drivers dated as 21 July. I thought, "Yeah, maybe this'll make the graphics stop being so danged sluggish." Well, after I shelled and installed the drivers and rebooted, it boots into the konsole rather KDE.

    Any ideas? I'm sure its probably a simple little command I don't know (I hope).

  2. #2

    Default Re: 11 with new ATI drivers

    tdy i updated my ati driver .d compiz fusion ..
    i used control settings- desktop effects.....after that nothing happened (only i can see white screen)

    i cant see the desktop..did u had these problems?? if u know the solution help me!

  3. #3

    Default Re: 11 with new ATI drivers

    Had problems once like that. At the login screen select terminal or console (cant remember what it is exactly). When at a command prompt type sax2. Should load up a screen that will let you reload default screen settings. My experience so far with ATI is that it is very finicky with settings and only a few really work.

    Hope it helps.

  4. #4

    Default Re: 11 with new ATI drivers

    Update:

    I shelled the ati drivers in the terminal as su. Didnt help anything. 11 still boots straight to the terminal.

    HELP!!!

  5. #5

    Default Re: 11 with new ATI drivers

    Yet another update:

    Found this interesting line on the load screen
    "The failsafe X.Org configuration /etc/X11/xorg.cong.install no longer exists. Either move it back (if still available) or copy /etc/X11/xorg.conf to /etc/X11/xorg.conf.install to use the native graphics driver instead of the failsafe graphics driver. Of course the latter option no longer can be called failsafe."

    Thanks ATI. You killed my graphics drivers.

    Still lost...

  6. #6

    Default Re: 11 with new ATI drivers

    Okay. Here I am again.

    So I went to the ATI installation page and found a text line in one of the install window pictures. It says that if X server fails to load then as root type 'aticonfig --initial -f'.

    https://a248.e.akamai.net/f/674/9206...at87-inst.html

    It worked. X server is back up on my notebook.

    Hope this helps someone out someday.


    ~Knuckles

  7. #7
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: 11 with new ATI drivers

    Be sure after you installed the ATI driver that you configured Sax2.



    The above link will walk you through the process of configuring the drivers after you have installed them. One change, though: when you are in Sax2, be sure that 3D Acceleration is checked. If 3D Acceleration is off while Compiz(-Fusion) is enabled through desktop effects, this can cause errors. The white screen problem sounds like a driver issue, so as long as the driver (preferably the 1-Click installer found in the link above) is installed properly, the system is rebooted, and Sax2 is configured correctly, the white screen should go away.

    Hope that helps!

    Folding@Home
    Help save lives with Folding@Home

  8. #8
    Jrg von Frantzius NNTP User

    Default Re: 11 with new ATI drivers

    Hi,

    I'm having simliar problems, and only yesterday I discovered that at
    least you can toggle compositing with Alt+Shift+F12 at runtime. That's
    very helpful if you don't want to go searching for the compositing
    option in the .kde4 configuration files on the command line, because
    your X is messed up completely...

    prabhakaran1989 wrote:
    > tdy i updated my ati driver .d compiz fusion ..
    > i used control settings- desktop effects.....after that nothing
    > happened (only i can see white screen)
    >
    > i cant see the desktop..did u had these problems?? if u know the
    > solution help me!
    >
    >
    >


  9. #9
    Jrg von Frantzius NNTP User

    Default Re: 11 with new ATI drivers

    OK I just got it working, and it even still works after a reboot ;-)
    Following these steps should help:

    1. Download
    https://a248.e.akamai.net/f/674/9206...x86.x86_64.run,
    or what download link
    http://ati.amd.com/support/drivers/l...ux-radeon.html
    currently shows
    2. "chmod u+x ati-driver-installer-8-7-x86.x86_64.run" to make it
    executable
    3. "ati-driver-installer-8-7-x86.x86_64.run" to invoke the installer,
    which will produce an RPM for you (it won't really install at this
    point)
    4. in the pop-up window, chose "distribution specific installer
    package", select "opensuse110"
    5. result is a "fglrx_7_1_0_SUSE110-8.512-1.i386.rpm" in the same
    directory, install by right-clicking in dolphin/konqueror "Open
    with Install Software"
    6. If it tells you about conflicting packages, you have de-install
    your currently installed ATI driver prior to step 5 (I recommend
    not to reboot immediately afterwards, before installing the new
    driver!)
    7. After installation of the rpm, invoke "aticonfig --initial"
    8. Reboot
    9. Watch lovely KDE 4.1 with compositing and acceptable performance :-)



    prabhakaran1989 wrote:
    > tdy i updated my ati driver .d compiz fusion ..
    > i used control settings- desktop effects.....after that nothing
    > happened (only i can see white screen)
    >
    > i cant see the desktop..did u had these problems?? if u know the
    > solution help me!
    >
    >
    >




  10. #10

    Default Re: 11 with new ATI drivers

    Getting the black screen with mouse pointer.

    When I ctrl-alt-F1 and go to the console I go to sax2. But, it says "access to display denied."

    I'm assuming that the ati drivers have taken dominion over the sax configuration...

    Does anyone know how to use aticonfig --initial?

    How do you pause the screen that shows all the different commands (its 5 or 6 pages of stuff and i'd like to actually be able to read it.)

    Thx

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •