Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: KDE 4.1 one click installer ruined my openSUSE

  1. #1
    Join Date
    Jun 2008
    Location
    Munich
    Posts
    355

    Unhappy KDE 4.1 one click installer ruined my openSUSE

    Today I tried the 4.1 KDE one click install on my opensuse 11 64bit installation (4.0 preinstalled). First I ran into tons of dependencies errors I ignored. After installing it from the factory repo I restarted the xserver and I was thrown back to the terminal command prompt. No chance to get it back to start.

    Now I have to reinstall from the scratch

    Is there any way to upgrade to 4.1 without that horrible dependencies errors? Did anybody test the packages before it where released and announced to be easily installed by a so called one click installer?

    Sorry, I'm a bit angry about it cause it costs me a lot of time to get my desktop back to the same state I had before.

    cu
    Gargi

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Quote Originally Posted by HRGargi View Post
    First I ran into tons of dependencies errors I ignored.


    You never.. EVER ignore dependency errors. On that note, wait a few days until all the repositories have sync'ed KDE changes and everything has been tested to work 100%.

  3. #3
    Join Date
    Jun 2008
    Location
    Munich
    Posts
    355

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Is there a way to resolve the missing dependencies?

    ...

    Edit: just haven't seen your second sentence under that big picture
    I hope that the packages are moved into the update repo cause I think remaining in the factory repo we'll never get all dependencies cleared.

  4. #4

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Quote Originally Posted by HRGargi View Post
    Today I tried the 4.1 KDE one click install on my opensuse 11 64bit installation (4.0 preinstalled). First I ran into tons of dependencies errors I ignored. After installing it from the factory repo I restarted the xserver and I was thrown back to the terminal command prompt. No chance to get it back to start.

    Now I have to reinstall from the scratch

    Is there any way to upgrade to 4.1 without that horrible dependencies errors? Did anybody test the packages before it where released and announced to be easily installed by a so called one click installer?

    Sorry, I'm a bit angry about it cause it costs me a lot of time to get my desktop back to the same state I had before.

    cu
    Gargi
    Yes, I am sure they tested the packages. And while I didn't use the one-click installer, I have upgraded with absolutely no issues. What I did:

    1. Install both KDE3 and KDE4, while making KDE4 the default, at install of 11.0.

    2.
    Code:
    zypper ref
    followed by
    Code:
    zypper up -t package
    Everything worked like a charm. This was, of course, after I set up the 3 KDE4 repos.

    I think that maybe you should think a little about the statement "First I ran into tons of dependencies errors I ignored."

    I mean, seriously, that's just not a very good decision.

  5. #5
    Join Date
    Jun 2008
    Location
    Munich
    Posts
    355

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Quote Originally Posted by wnj92996 View Post
    ...
    I mean, seriously, that's just not a very good decision.
    Yes, normally it isn't. But I just had cases you could ignore it. In that case it was a real mistake. But what I don't understand is why there is a one click installer provided leading into those kind of confusions.

    Edit: Next time I better test it on a virtualbox installation before I touch my working installation

    cu
    Gargi

  6. #6

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    This was, of course, after I set up the 3 KDE4 repos.
    Which are ??

  7. #7

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    i installed via the one click and was surprised to find no Dragon Player, i thought that was a default part of 4.1?

  8. #8
    Join Date
    Jun 2008
    Location
    Rotterdam, Port to Europe
    Posts
    207

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Upgrading to 4.1 from 4.0.99 went well. I always use YaST, paterns, this time I left the 3.5 for what it is and did KDE as mentioned & Gnome. The only issue was with DidiKam / showfoto it seems I got 0.9.4 from the UNSTABLE repo and should have had 0.10.x from the Factory.

    The problem the OP mentions I think has to do with him upgrading from the wrong repo. If you use the one-click install a few times, most likely you will have Factory & UNSTABLE repo's added. Which may be fine for a single app but not for a whole sys upgrade from STABLE.
    OpenSuSE Leap 42.3 / KDE 5.8 | Intel i7 3770 | 16GBRam | 120 + 80GB SSD's | Benq 27" | DVD | PhilipsToUcam 740 | HPpsc2355p | Logitech KB & mouse | 320 +160 + 80 + 80 GB USB HDD's | Fritz!Box Fon WLAN 7360 | (V)DSL 12 MB/s | SuSE since 2001

  9. #9
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Quote Originally Posted by HRGargi View Post
    But what I don't understand is why there is a one click installer provided leading into those kind of confusions.
    Gargi
    It's got nothing to do with 'one-click installer'. All the one-click installer
    is gonna do is define one or more repositories, and then invoke a template
    install (which knows a series of package names to install).

    But, what you're not understanding is that 'the devil is in the details'.
    In reality, what's been going on for the last 2 or 3 weeks is that they
    check in new editions of about 50 packages almost EVERY DAY.
    So, if you happen upon the scene during the middle of them inserting
    the newest versions of all their freshly rebuilt code into the repos, you'll get a bunch
    of 'version mismatches' that to you become 'dependency conflicts'.

    So, like they said, you decided to ignore the dependency conflicts, and
    messed up your system. The rest of us just saw the conflicts, bailed out,
    came back a half-hour later, refreshed, found no dependency conflicts, and installed
    the next version. [I've updated KDE 4.x at least 20 times in the last 3 weeks.]

    "Once burned, twice learned."

    Hope that clarifies it.

  10. #10

    Default Re: KDE 4.1 one click installer ruined my openSUSE

    Quote Originally Posted by killerbot View Post
    Which are ??
    To get the 4.1 betas, you needed to have been updating from Factory. The three repos are Community, Desktop, and Extra-Apps, all of which you can find here: KDE/Repositories - openSUSE

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •