Results 1 to 10 of 10

Thread: localhost access suddenly not working!

  1. #1

    Angry localhost access suddenly not working!

    Gnome 2.2 SUSE 10.3 Apache/2.2.4

    How to fix this problem?

    I'm getting Access forbidden Error 403 for
    http://localhost/
    http://127.0.0.1

    and haven't modified any configuration files!!!

    http://localhost/server-info still working!

    the only process I used was Yast HTTP Server to check configuration but did not save (Abort)

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: localhost access suddenly not working!

    Look at /var/log/apache2/error_log as to the cause of the issue.

  3. #3

    Default Re: localhost access suddenly not working!

    Thanks Chrysantine,

    I founded many entry like this one
    [Tue Jul 29 12:18:31 2008] [notice] caught SIGTERM, shutting down
    [Tue Jul 29 12:19:56 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Tue Jul 29 12:19:56 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Tue Jul 29 12:19:58 2008] [notice] Apache/2.2.4 (Linux/SUSE) mod_ssl/2.2.4 OpenSSL/0.9.8e PHP/5.2.6 with Suhosin-Patch configured -- resuming normal operations

    and few like this one!

    [Thu Jul 24 17:41:33 2008] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /srv/www/htdocs/

    If it is the root cause? it doesn't tell me what directive I have to change and what process changed it.


    I'm new to linux I'm wondering if it not related to user access rights level or group? (default)

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: localhost access suddenly not working!

    This is normal. Directory indexing is off by default in OpenSUSE, but if you put an index.html in the directory it will be served.

  5. #5
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: localhost access suddenly not working!

    By default, Apache listen to index pages in SUSE.
    try put some index.php or index.html and you will see the page.
    Other wise will give forbidden error while accessing dir.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  6. #6

    Default Re: localhost access suddenly not working!

    !index.html in /srv/www/htdocs is installed by default by apache RPM.

    In the meantime I used Yast "HTTP server" and "DNS Server" to check settings instead of using "DNS and host name" GUI. and now it's getting worst, I don't even have access to http://localhost/server-info
    that was working before.

  7. #7
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: localhost access suddenly not working!

    Try create index.php with the following code:
    <?php
    echo phpinfo();
    ?>
    And save it as info.php in your www directory, and run it like:

    Hope this helps.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  8. #8

    Default Re: localhost access suddenly not working!

    just to clarfied the situation

    Errro 403 for
    -http://localhost
    -http://127.0.0.1
    -http://localhost/server-info

    all from /srv/www/htdocs index.htm or .php

    but work find with

    http://localhost/username/index.php

    /home/username/public_html/ index.htm or .php

  9. #9

    Default Re: localhost access suddenly not working!

    I done it after installing appache and it was running find.
    but now it only works from http://localhost/username/info.php not anymore from http://localhost/info.php

  10. #10

    Default Re: localhost access suddenly not working!

    Founded the cause and solution

    Using Yast2 "HTTP Server" GUI it created a new filename yast2_vhosts.conf in /etc/apache2/vhosts.d/
    this overwrite default installation settings by enabling a virtual host virtual host not working???

    So I'm back to default settings.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •